summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-12-24 22:28:46 +0100
committerMaciej Barć <xgqt@gentoo.org>2022-12-24 23:26:48 +0100
commit889a3cff4fa58c3b06643479ec34656758c52315 (patch)
treee059c742171c9919fadb96340eb75bc9bc1965a9
parentprofiles: Unmask scanner USE flag on arm64 (diff)
downloadgentoo-889a3cff4fa58c3b06643479ec34656758c52315.tar.gz
gentoo-889a3cff4fa58c3b06643479ec34656758c52315.tar.bz2
gentoo-889a3cff4fa58c3b06643479ec34656758c52315.zip
sci-mathematics/flocq: new package; add 4.1.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--sci-mathematics/flocq/Manifest1
-rw-r--r--sci-mathematics/flocq/flocq-4.1.0.ebuild31
-rw-r--r--sci-mathematics/flocq/metadata.xml18
3 files changed, 50 insertions, 0 deletions
diff --git a/sci-mathematics/flocq/Manifest b/sci-mathematics/flocq/Manifest
new file mode 100644
index 000000000000..f04ae7c7ad49
--- /dev/null
+++ b/sci-mathematics/flocq/Manifest
@@ -0,0 +1 @@
+DIST flocq-4.1.0.tar.gz 447412 BLAKE2B 1b993a0e86bd440602b16b94ed5aff4b95a3c732eca87c683d239702b285dee8eaaf7dad77f730ae4929bb24504e5fd12b9a181d48efac4c3db7f0606637c018 SHA512 677e0de1406b3c7e5504d114a5b18ec07c719bbad79a2cfb750ac309fd5ab09be5493afdb1786b5a188cece59fddcd4167e28bf3be4facbdea8fe3b11cdf1ab1
diff --git a/sci-mathematics/flocq/flocq-4.1.0.ebuild b/sci-mathematics/flocq/flocq-4.1.0.ebuild
new file mode 100644
index 000000000000..f48862539920
--- /dev/null
+++ b/sci-mathematics/flocq/flocq-4.1.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multiprocessing
+
+DESCRIPTION="Formalization of floating-point arithmetic for the Coq proof assistant"
+HOMEPAGE="http://flocq.gforge.inria.fr/
+ https://gitlab.inria.fr/flocq/flocq/"
+SRC_URI="https://flocq.gitlabpages.inria.fr/releases/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=sci-mathematics/coq-8.12"
+BDEPEND="${RDEPEND}"
+
+src_compile() {
+ ./remake --jobs=$(makeopts_jobs) || die
+}
+
+src_install() {
+ DESTDIR="${D}" ./remake install || die
+
+ dodoc AUTHORS INSTALL.md NEWS.md README.md
+
+ insinto /usr/share/${PN}
+ doins -r examples
+}
diff --git a/sci-mathematics/flocq/metadata.xml b/sci-mathematics/flocq/metadata.xml
new file mode 100644
index 000000000000..4514b79800af
--- /dev/null
+++ b/sci-mathematics/flocq/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-mathematics@gentoo.org</email>
+ <name>Gentoo Mathematics Project</name>
+ </maintainer>
+ <longdescription>
+ Flocq (Floats for Coq) is a formalization of floating-point arithmetic for
+ the Coq proof assistant. It provides a comprehensive library of theorems on
+ a multi-radix multi-precision arithmetic. It also supports efficient
+ numerical computations inside Coq.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://gitlab.inria.fr/flocq/flocq/-/issues/</bugs-to>
+ </upstream>
+</pkgmetadata>