summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Scruggs <j.scruggs@gmail.com>2016-10-28 11:46:47 +0100
committerDavid Seifert <soap@gentoo.org>2016-10-29 00:30:36 +0200
commit88f92032cd9768fff8af37c8fd68ede1a7241879 (patch)
tree6f109400e972e9645530fe6b162c05cbb8f89129
parentmedia-libs/audiofile: Add gcc 6 build fixes patch (diff)
downloadgentoo-88f92032.tar.gz
gentoo-88f92032.tar.bz2
gentoo-88f92032.zip
dev-python/m2crypto: Add missing RDEPEND on dev-python/typing
Gentoo-bug: 597744 * EAPI=6 * Removing old ebuild as it doesn't have the dependency, so m2crypto will not work right. Signed off by: Jonathan Scruggs (j.scruggs@gmail.com) Closes: https://github.com/gentoo/gentoo/pull/2686 Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--dev-python/m2crypto/m2crypto-0.25.1-r1.ebuild (renamed from dev-python/m2crypto/m2crypto-0.25.1.ebuild)7
1 files changed, 4 insertions, 3 deletions
diff --git a/dev-python/m2crypto/m2crypto-0.25.1.ebuild b/dev-python/m2crypto/m2crypto-0.25.1-r1.ebuild
index c7509ea2e5a5..b2ad706d26d0 100644
--- a/dev-python/m2crypto/m2crypto-0.25.1.ebuild
+++ b/dev-python/m2crypto/m2crypto-0.25.1-r1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
PYTHON_COMPAT=( python2_7 )
PYTHON_REQ_USE="threads(+)"
@@ -17,12 +17,13 @@ SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+KEYWORDS="~amd64"
IUSE="libressl"
RDEPEND="
!libressl? ( >=dev-libs/openssl-0.9.8:0= )
- libressl? ( dev-libs/libressl:= )
+ libressl? ( dev-libs/libressl:0= )
+ dev-python/typing
"
DEPEND="${RDEPEND}
>=dev-lang/swig-1.3.28:0