summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-04-09 19:28:53 +0100
committerSam James <sam@gentoo.org>2023-04-09 19:30:42 +0100
commit8906975b99a7c9999b31fc70662dedfec89103f7 (patch)
treef2dc14804244f3e6ccbb9484e1a10f4dbafd342a
parentx11-themes/fedora-backgrounds: add 38.1.1 (diff)
downloadgentoo-8906975b99a7c9999b31fc70662dedfec89103f7.tar.gz
gentoo-8906975b99a7c9999b31fc70662dedfec89103f7.tar.bz2
gentoo-8906975b99a7c9999b31fc70662dedfec89103f7.zip
sys-libs/minizip-ng: add 3.0.10
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-libs/minizip-ng/Manifest1
-rw-r--r--sys-libs/minizip-ng/minizip-ng-3.0.10.ebuild93
2 files changed, 94 insertions, 0 deletions
diff --git a/sys-libs/minizip-ng/Manifest b/sys-libs/minizip-ng/Manifest
index 46d51ee763c0..5690168d5d70 100644
--- a/sys-libs/minizip-ng/Manifest
+++ b/sys-libs/minizip-ng/Manifest
@@ -1,2 +1,3 @@
+DIST minizip-ng-3.0.10.tar.gz 771145 BLAKE2B 6bab59f830b8be929b6293c9408dd70165ffe094a71bcff82eab71f9d077f4d5360f6081e0ca631090810dfc58a81b03926c797e5c156d0f1437df78292a1f09 SHA512 38021137bebb8805279e729e0801ee15133e6379bdd1862d0dea60f13fb1d63402477f3ea9a6c22fc8c85eb13dd9b38d9536680806850060a44a5a9f015fa829
DIST minizip-ng-3.0.8.tar.gz 643788 BLAKE2B aa937fe8d0e776c8a00754c7a5eae7769b096d044a1b65b124adc0531b757579d8e0e0f5a4784669d9d94a7ea512625160b8b02f908a29e027f31911adf0f524 SHA512 f9742c5fc54ac08d78d7e942e90a7e7f1bc40a2812e7555570bd152ed441dbc5a004b79d2edf32d3fbda64db493cd1a0512d16deb84c0791d3fc86718e9ad0b1
DIST minizip-ng-3.0.9.tar.gz 646390 BLAKE2B ba823e371dd65788404c8628d1e3de74d28bb86a378eb19b2f9636d96b402e43831238a5296d22febe46c58f2e340d8439ad4117db513b949c9cd99a32fa5df6 SHA512 a52c43d0e208eb6acf56f80804fe99c265baec2a60f6cd80fc9ba160ca3c076e6c118be9108db84728310b14640cab0e0d301d4c763713c90bd344990a43f5fd
diff --git a/sys-libs/minizip-ng/minizip-ng-3.0.10.ebuild b/sys-libs/minizip-ng/minizip-ng-3.0.10.ebuild
new file mode 100644
index 000000000000..35459128380a
--- /dev/null
+++ b/sys-libs/minizip-ng/minizip-ng-3.0.10.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Worth keeping an eye on 'develop' branch upstream for possible backports,
+# as they copied this practice from sys-libs/zlib upstream.
+
+inherit cmake
+
+DESCRIPTION="Fork of the popular zip manipulation library found in the zlib distribution"
+HOMEPAGE="https://github.com/zlib-ng/minizip-ng"
+SRC_URI="https://github.com/zlib-ng/minizip-ng/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="compat openssl test zstd"
+RESTRICT="!test? ( test )"
+
+# Automagically prefers sys-libs/zlib-ng if installed, so let's
+# just depend on it as presumably it's better tested anyway.
+RDEPEND="
+ app-arch/bzip2
+ app-arch/xz-utils
+ sys-libs/zlib-ng
+ virtual/libiconv
+ compat? ( !sys-libs/zlib[minizip] )
+ openssl? ( dev-libs/openssl:= )
+ zstd? ( app-arch/zstd:= )
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-cpp/gtest )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DMZ_COMPAT=$(usex compat)
+
+ -DMZ_BUILD_TESTS=$(usex test)
+ -DMZ_BUILD_UNIT_TESTS=$(usex test)
+
+ -DMZ_FETCH_LIBS=OFF
+ -DMZ_FORCE_FETCH_LIBS=OFF
+
+ # Compression library options
+ -DMZ_ZLIB=ON
+ -DMZ_BZIP2=ON
+ -DMZ_LZMA=ON
+ -DMZ_ZSTD=$(usex zstd)
+ -DMZ_LIBCOMP=OFF
+
+ # Encryption support options
+ -DMZ_PKCRYPT=ON
+ -DMZ_WZAES=ON
+ -DMZ_OPENSSL=$(usex openssl)
+ -DMZ_LIBBSD=ON
+ -DMZ_SIGNING=ON
+
+ # Character conversion options
+ -DMZ_ICONV=ON
+ )
+
+ cmake_src_configure
+}
+
+src_test() {
+ local myctestargs=(
+ # TODO: investigate
+ -E "(raw-unzip-pkcrypt|raw-append-unzip-pkcrypt|raw-erase-unzip-pkcrypt|deflate-unzip-pkcrypt|deflate-append-unzip-pkcrypt|deflate-erase-unzip-pkcrypt|bzip2-unzip-pkcrypt|bzip2-append-unzip-pkcrypt|bzip2-erase-unzip-pkcrypt|lzma-unzip-pkcrypt|lzma-append-unzip-pkcrypt|lzma-erase-unzip-pkcrypt|xz-unzip-pkcrypt|xz-append-unzip-pkcrypt|xz-erase-unzip-pkcrypt|zstd-unzip-pkcrypt|zstd-append-unzip-pkcrypt|zstd-erase-unzip-pkcrypt)"
+ )
+
+ # TODO: A bunch of tests end up looping and writing over each other's files
+ # It gets better with a patch applied (see https://github.com/zlib-ng/minizip-ng/issues/623#issuecomment-1264518994)
+ # but still hangs.
+ cmake_src_test -j1
+}
+
+src_install() {
+ cmake_src_install
+
+ if use test ; then
+ # Test binaries, bug #874591
+ rm "${ED}"/usr/bin/minigzip || die
+ rm "${ED}"/usr/bin/minizip-ng || die
+ fi
+
+ if use compat ; then
+ ewarn "minizip-ng is experimental and replacing the system zlib[minizip] is dangerous"
+ ewarn "Please be careful!"
+ fi
+}