summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-01 08:26:31 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-01 08:41:34 +0200
commit890a9b003a1fdb1028a75d534f7d31c7140a58d7 (patch)
treee3fdd1909f853550834b474f2da7ff2bf9d169dc
parentdev-python/asgiref: Bump to 3.5.1 (diff)
downloadgentoo-890a9b003a1fdb1028a75d534f7d31c7140a58d7.tar.gz
gentoo-890a9b003a1fdb1028a75d534f7d31c7140a58d7.tar.bz2
gentoo-890a9b003a1fdb1028a75d534f7d31c7140a58d7.zip
dev-python/sphinxcontrib-spelling: Bump to 7.3.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/sphinxcontrib-spelling/Manifest1
-rw-r--r--dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-7.3.3.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-spelling/Manifest b/dev-python/sphinxcontrib-spelling/Manifest
index b5915e95e87a..1dacedae960e 100644
--- a/dev-python/sphinxcontrib-spelling/Manifest
+++ b/dev-python/sphinxcontrib-spelling/Manifest
@@ -1 +1,2 @@
DIST sphinxcontrib-spelling-7.3.2.tar.gz 51813 BLAKE2B 7c96f3b102fa33ea4d9e35100930a157200a1c01c51d8ec5145c45c5a24e3b5de35f6c4669177363c6098cb96275e10c39ff660c36d209cb6fa658e50cb8e169 SHA512 043a50f694366de4a3aedc24ca2ea7d89c85087097264f4e4fc860f68a3df5a67f19ec7172e4a67074377846d013d24edecd751885136c7263bc30b034c0f0e9
+DIST sphinxcontrib-spelling-7.3.3.tar.gz 51912 BLAKE2B 6a9bd90db2298beb78686252d555dd5e77d0c9042eb0986dd2eeab9e413a921c5f5f594c539c2cfe6315002c2f2892241b789b10976e634158f3ca1d8be1b627 SHA512 7406bd846c5eac507f8e4481ada4d0d725d0a3ad8cf2f8fd3328389128cf54091bb0e304dfe23fdf771a26d9103d2c028d2f7f29e1949ca59fcf43de5bac9cb1
diff --git a/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-7.3.3.ebuild b/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-7.3.3.ebuild
new file mode 100644
index 000000000000..b0c435cd27a2
--- /dev/null
+++ b/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-7.3.3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx spelling extension"
+HOMEPAGE="
+ https://github.com/sphinx-contrib/spelling/
+ https://pypi.org/project/sphinxcontrib-spelling/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/pyenchant[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]
+ test? (
+ app-dicts/myspell-en
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # requires the git repo
+ tests/test_filter.py::test_contributors
+)
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}
+
+python_test() {
+ distutils_write_namespace sphinxcontrib
+ rm -rf sphinxcontrib || die
+ epytest tests
+}