summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-05 12:04:46 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-05 12:35:44 +0200
commit8924f2f63e62ba08a30432c6d2a148fc3145b09e (patch)
tree1c11777189f3c18ad41a1c92d25c39c6c769cecd
parentdev-python/watchgod: Remove old (diff)
downloadgentoo-8924f2f6.tar.gz
gentoo-8924f2f6.tar.bz2
gentoo-8924f2f6.zip
dev-python/sqlalchemy: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/sqlalchemy/Manifest2
-rw-r--r--dev-python/sqlalchemy/sqlalchemy-1.4.31.ebuild71
-rw-r--r--dev-python/sqlalchemy/sqlalchemy-1.4.35.ebuild93
3 files changed, 0 insertions, 166 deletions
diff --git a/dev-python/sqlalchemy/Manifest b/dev-python/sqlalchemy/Manifest
index 1354b6811f4a..d6c5b87b467c 100644
--- a/dev-python/sqlalchemy/Manifest
+++ b/dev-python/sqlalchemy/Manifest
@@ -1,4 +1,2 @@
-DIST SQLAlchemy-1.4.31.tar.gz 7999646 BLAKE2B 4c394aaa4bc5636cc90f06017466c227b5e16fc54c3a9a42b18cc13906640e4710146325e870598f8905074bf6dad42ea524febc029b1dd5f063e978ebc9a442 SHA512 e54261fcf992845b2e6be47d23f530aec28c7517e6741b1b6a101b9888d3dc3162c1eeab0acc1edb33f56f1360bae3cdccdbcbff0e1e88e477c93d0cd910c17c
-DIST SQLAlchemy-1.4.35.tar.gz 8136388 BLAKE2B 01a47eab8e11daef133a218a7ef13fa149fb4616b531c3c6d227cc26e3264c259f42770b72335a9fbda5e66ae1ce242fcbe676a528ca1af896d990a84a1f1a57 SHA512 195ab35934bca36e7c4c2127f153eff31775f7f150163912f79143efae63911eded67d8645e08ede2c533c675d18c3c5796235e0c0f6d1e6ebb97664ac13f171
DIST SQLAlchemy-1.4.36.tar.gz 8146415 BLAKE2B 62560ac2f2c542d60588a24eef225d39f1b6c4cf6feddfac4631e06731206a837cc0f76b88b40c73600361243857e9e1768b4b4ac0bf5ee8e28736d81028ae58 SHA512 c9bb38ce5eeb7817727e93695f10cf5c247710b809f3298b233ed8be4e2cc08e5a14581d0c5aa2af02d7a49f036fe3a0bb7a88120b58bdce0f115016bdaf2c77
DIST SQLAlchemy-1.4.37.tar.gz 8155965 BLAKE2B cf21c2ab73a5ba2576a857a12f30ea516265af946e25c1b137e57019d862bf04f4757b4755cee28e6f53642d1f1b58f43c99cd1c69f87640e47ac8a1d1ff8d28 SHA512 3f8a814f9bb6fa273f7b210c4567bf7411d0cf2e5caf010a5387fb946063704c342072145a858fb906545dfb1b959155d041e6073273674e51715356fc1f39e6
diff --git a/dev-python/sqlalchemy/sqlalchemy-1.4.31.ebuild b/dev-python/sqlalchemy/sqlalchemy-1.4.31.ebuild
deleted file mode 100644
index 0498d407f41f..000000000000
--- a/dev-python/sqlalchemy/sqlalchemy-1.4.31.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{8..10} )
-PYTHON_REQ_USE="sqlite?"
-
-inherit distutils-r1 optfeature
-
-MY_PN="SQLAlchemy"
-MY_P="${MY_PN}-${PV/_beta/b}"
-
-DESCRIPTION="Python SQL toolkit and Object Relational Mapper"
-HOMEPAGE="https://www.sqlalchemy.org/ https://pypi.org/project/SQLAlchemy/"
-SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
-IUSE="examples +sqlite test"
-
-BDEPEND="
- test? (
- $(python_gen_impl_dep sqlite)
- )
-"
-
-distutils_enable_tests pytest
-
-EPYTEST_IGNORE=(
- # hardcode call counts specific to Python versions
- test/aaa_profiling
-)
-
-src_prepare() {
- sed -i -e '/greenlet/d' setup.cfg || die
- distutils-r1_src_prepare
-}
-
-python_test() {
- # upstream's test suite is horribly hacky; it relies on disabling
- # the warnings plugin and turning warnings into errors; this also
- # means that any DeprecationWarnings from third-party plugins cause
- # everything to explode
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x PYTEST_PLUGINS=
- # upstream automagically depends on xdist when it is importable
- if has_version "dev-python/pytest-xdist[${PYTHON_USEDEP}]"; then
- PYTEST_PLUGINS+=xdist.plugin
- fi
- epytest
-}
-
-python_install_all() {
- if use examples; then
- docompress -x "/usr/share/doc/${PF}/examples"
- dodoc -r examples
- fi
-
- distutils-r1_python_install_all
-}
-
-pkg_postinst() {
- optfeature "asyncio support" dev-python/greenlet
- optfeature "MySQL support" dev-python/mysqlclient dev-python/pymysql \
- dev-python/mysql-connector-python
- optfeature "postgresql support" dev-python/psycopg:2
-}
diff --git a/dev-python/sqlalchemy/sqlalchemy-1.4.35.ebuild b/dev-python/sqlalchemy/sqlalchemy-1.4.35.ebuild
deleted file mode 100644
index 86ec1697ec2b..000000000000
--- a/dev-python/sqlalchemy/sqlalchemy-1.4.35.ebuild
+++ /dev/null
@@ -1,93 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{8..10} )
-PYTHON_REQ_USE="sqlite?"
-
-inherit distutils-r1 optfeature
-
-MY_PN="SQLAlchemy"
-MY_P="${MY_PN}-${PV/_beta/b}"
-
-DESCRIPTION="Python SQL toolkit and Object Relational Mapper"
-HOMEPAGE="
- https://www.sqlalchemy.org/
- https://pypi.org/project/SQLAlchemy/
- https://github.com/sqlalchemy/sqlalchemy/
-"
-SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
-IUSE="examples +sqlite test"
-
-BDEPEND="
- test? (
- $(python_gen_impl_dep sqlite)
- )
-"
-
-distutils_enable_tests pytest
-
-EPYTEST_IGNORE=(
- # hardcode call counts specific to Python versions
- test/aaa_profiling
-)
-
-src_prepare() {
- sed -i -e '/greenlet/d' setup.cfg || die
- distutils-r1_src_prepare
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # warning tests are unreliable
- test/base/test_warnings.py
- )
- [[ ${EPYTHON} == pypy3 ]] && EPYTEST_DESELECT+=(
- test/ext/test_associationproxy.py::ProxyHybridTest::test_msg_fails_on_cls_access
- )
- if ! has_version "dev-python/greenlet[${PYTHON_USEDEP}]"; then
- EPYTEST_DESELECT+=(
- test/ext/asyncio/test_engine_py3k.py::TextSyncDBAPI::test_sync_driver_execution
- test/ext/asyncio/test_engine_py3k.py::TextSyncDBAPI::test_sync_driver_run_sync
- "test/engine/test_pool.py::PoolEventsTest::test_checkin_event_gc[True-_exclusions0]"
- "test/engine/test_pool.py::QueuePoolTest::test_userspace_disconnectionerror_weakref_finalizer[True-_exclusions0]"
- )
- fi
-
- # upstream's test suite is horribly hacky; it relies on disabling
- # the warnings plugin and turning warnings into errors; this also
- # means that any DeprecationWarnings from third-party plugins cause
- # everything to explode
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x PYTEST_PLUGINS=
- # upstream automagically depends on xdist when it is importable
- if has_version "dev-python/pytest-xdist[${PYTHON_USEDEP}]"; then
- PYTEST_PLUGINS+=xdist.plugin
- fi
- epytest
-}
-
-python_install_all() {
- if use examples; then
- docompress -x "/usr/share/doc/${PF}/examples"
- dodoc -r examples
- fi
-
- distutils-r1_python_install_all
-}
-
-pkg_postinst() {
- optfeature "asyncio support" dev-python/greenlet
- optfeature "MySQL support" \
- dev-python/mysqlclient \
- dev-python/pymysql \
- dev-python/mysql-connector-python
- optfeature "postgresql support" dev-python/psycopg:2
-}