summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-09-30 05:10:31 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-09-30 06:48:12 -0400
commit8928da1acfffdc887ba79d34b1088fe21406e0d7 (patch)
treec7f3db023d6fbc44c37234b75d66077de5c4f99c
parentx11-misc/xbatt: force gcc -E for imake's generation (diff)
downloadgentoo-8928da1a.tar.gz
gentoo-8928da1a.tar.bz2
gentoo-8928da1a.zip
x11-misc/xbatt: fix build with clang16
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--x11-misc/xbatt/files/xbatt-1.2.1-clang16.patch8
-rw-r--r--x11-misc/xbatt/xbatt-1.3_rc1-r1.ebuild1
2 files changed, 9 insertions, 0 deletions
diff --git a/x11-misc/xbatt/files/xbatt-1.2.1-clang16.patch b/x11-misc/xbatt/files/xbatt-1.2.1-clang16.patch
new file mode 100644
index 000000000000..9a7c03157738
--- /dev/null
+++ b/x11-misc/xbatt/files/xbatt-1.2.1-clang16.patch
@@ -0,0 +1,8 @@
+https://bugs.gentoo.org/870412
+--- a/xbatt.c
++++ b/xbatt.c
+@@ -223,3 +223,3 @@
+
+-main(
++int main(
+ int argc,
diff --git a/x11-misc/xbatt/xbatt-1.3_rc1-r1.ebuild b/x11-misc/xbatt/xbatt-1.3_rc1-r1.ebuild
index 1c3072e729f7..460d865a6a04 100644
--- a/x11-misc/xbatt/xbatt-1.3_rc1-r1.ebuild
+++ b/x11-misc/xbatt/xbatt-1.3_rc1-r1.ebuild
@@ -32,6 +32,7 @@ BDEPEND="
PATCHES=(
"${FILESDIR}"/${PN}-1.2.1-implicits.patch
+ "${FILESDIR}"/${PN}-1.2.1-clang16.patch
)
src_configure() {