summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-09-28 20:44:26 +0100
committerSam James <sam@gentoo.org>2021-09-28 20:46:44 +0100
commit892f6c39ef11c8de7e7d6387956b8789487a1414 (patch)
treeb5cc31fe3a0cd295344291df9f60c297467011bf
parentdev-ruby/vagrant_cloud: add 3.0.5 (diff)
downloadgentoo-892f6c39.tar.gz
gentoo-892f6c39.tar.bz2
gentoo-892f6c39.zip
app-emulation/vagrant: add 2.2.18
Closes: https://bugs.gentoo.org/812770 Closes: https://bugs.gentoo.org/815228 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-emulation/vagrant/Manifest1
-rw-r--r--app-emulation/vagrant/vagrant-2.2.18.ebuild94
2 files changed, 95 insertions, 0 deletions
diff --git a/app-emulation/vagrant/Manifest b/app-emulation/vagrant/Manifest
index b59e046f1a2e..7dd0548ecca8 100644
--- a/app-emulation/vagrant/Manifest
+++ b/app-emulation/vagrant/Manifest
@@ -1,3 +1,4 @@
DIST vagrant-2.2.14.tar.gz 2522944 BLAKE2B 21980ab11fb7477518a40839715b6b207e9a2268e19df2ded0042a7d3d32cd45db02acfeb528c89869e54e9f4358b200f831150ada43c062513d864896eb7895 SHA512 540457c23ff52faef10774ac2d0da7a8c30682a19964f5ce805d5013eb27a6538468fcd511610d4bef539df14cbc4cf3a3dcdd9c96ba303ecf538028dc4aa659
+DIST vagrant-2.2.18.tar.gz 1620261 BLAKE2B 8938801b383373967365ca64a79f70885a61c02221eeebf75f15fa40440dfdc585f0a0d0cafe9a01484d594dc49b98397a0724776586c2c9fe4f529b6891bb26 SHA512 4694ca499136b53fc5cbab1efd47c9175293ba84521614edbe545766b93e54dc8dc11278f7170c88f3bb05a4ca0a7c52e21deca285f848578a890858b8f21b64
DIST vagrant-2.2.7.tar.gz 2173893 BLAKE2B bf905cb25a905e4fb79ce9c1fb59ad5520b5176d5681dfdc22855ca0a7520535346d2aebffe47162a1f8ca008083c94426e9de92b6d92de4373c654784605c7e SHA512 3455b74c8a867ab37ca9873187a98cdb80feb22a400c4e9f2266897da815815aaefbe0c166172b1c1dbd66aa49ccb1201dcbf904fd883ad34218d694e20d7f87
DIST vagrant-2.2.9.tar.gz 2215868 BLAKE2B 6d40827c91c86f6b11865d9949e5313c419456c573686944ecd0d1874323aa81d6f26178d5b7a16fee701c513a98b3483dbea0531d9d77dee7b7e284004e17b3 SHA512 15e230bcf336615f0d49a2c40db36f7f26a9f0f6fd42d2ce801f28afc663aadded4fa373e33f9102b21ee70d98563fc68e2b24ffa6c3eec321f58b2c42b0d260
diff --git a/app-emulation/vagrant/vagrant-2.2.18.ebuild b/app-emulation/vagrant/vagrant-2.2.18.ebuild
new file mode 100644
index 000000000000..208e7ee15372
--- /dev/null
+++ b/app-emulation/vagrant/vagrant-2.2.18.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby26 ruby27"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+RUBY_FAKEGEM_GEMSPEC="vagrant.gemspec"
+RUBY_FAKEGEM_EXTRAINSTALL="keys plugins templates version.txt"
+RUBY_FAKEGEM_TASK_DOC=""
+
+inherit bash-completion-r1 optfeature ruby-fakegem
+
+DESCRIPTION="A tool for building and distributing development environments"
+HOMEPAGE="https://vagrantup.com/"
+SRC_URI="https://github.com/hashicorp/vagrant/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ ${RDEPEND}
+ app-arch/libarchive
+ net-misc/curl
+"
+
+ruby_add_rdepend "
+ >=dev-ruby/bcrypt_pbkdf-1.0.0
+ >=dev-ruby/childprocess-4.0.0
+ >=dev-ruby/ed25519-1.2.4
+ dev-ruby/erubi
+ >=dev-ruby/hashicorp-checkpoint-0.1.5
+ >=dev-ruby/i18n-1.8:1
+ >=dev-ruby/listen-3.1
+ <dev-ruby/log4r-1.1.11
+ >=dev-ruby/mime-types-3.3:*
+ >=dev-ruby/rubyzip-2.0
+ >=dev-ruby/net-scp-3.0.0
+ >=dev-ruby/net-sftp-3.0
+ >=dev-ruby/net-ssh-6.1.0
+ dev-ruby/rest-client:2
+ >=dev-ruby/vagrant_cloud-3.0.5
+"
+
+ruby_add_bdepend "
+ >=dev-ruby/rake-12.3.3
+ test? (
+ dev-ruby/rspec
+ dev-ruby/rspec-its
+ dev-ruby/webmock
+ )
+"
+
+all_ruby_prepare() {
+ # remove bundler support
+ sed -i '/[Bb]undler/d' Rakefile || die
+ rm Gemfile || die
+ rm tasks/bundler.rake || die
+
+ sed -e ':rake\|rspec\|webmock: s:~>:>=:' \
+ -e ':bcrypt_pbkdf\|hashicorp-checkpoint\|i18n\|listen\|net-ssh\|net-scp\|net-sftp\|childprocess: s:~>:>=:' \
+ -e '/fake_ftp/ s:^#*:#:' \
+ -e '/wdm/ s:^#*:#:' \
+ -e '/winrm/ s:^#*:#:' \
+ -e '/rb-kqueue/ s:^#*:#:' \
+ -e '/ruby_dep/ s:^#*:#:' \
+ -i ${PN}.gemspec || die
+
+ sed -e "s/@VAGRANT_VERSION@/${PV}/g" "${FILESDIR}/${PN}.in" > "${PN}" || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ newbashcomp contrib/bash/completion.sh ${PN}
+
+ # provide executable similar to upstream:
+ # https://github.com/hashicorp/vagrant-installers/blob/master/substrate/modules/vagrant_installer/templates/vagrant.erb
+ dobin "${PN}"
+
+ # directory for plugins.json
+ keepdir /var/lib/vagrant
+
+ insinto /usr/share/vim/vimfiles/syntax/
+ doins contrib/vim/vagrantfile.vim
+
+ optfeature_header "Optional emulation/container backends:"
+ optfeature "VirtualBox support" app-emulation/virtualbox
+ optfeature "Docker support" app-emulation/docker
+}