summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-05 12:07:37 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-05 13:41:16 +0100
commit894b6344e23370141bee7af9139a81968cbceb7c (patch)
tree685157718fb0541d29c330245126b712c1c4fa8e
parentdev-python/scipy: Bump to 1.5.4 (diff)
downloadgentoo-894b6344.tar.gz
gentoo-894b6344.tar.bz2
gentoo-894b6344.zip
dev-python/attrs: Bump to 20.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/attrs/Manifest1
-rw-r--r--dev-python/attrs/attrs-20.3.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/attrs/Manifest b/dev-python/attrs/Manifest
index 6d295b248e2b..5acbd8eb7196 100644
--- a/dev-python/attrs/Manifest
+++ b/dev-python/attrs/Manifest
@@ -1,2 +1,3 @@
DIST attrs-20.1.0.tar.gz 160766 BLAKE2B 65170484648318b9e6466789a9d212475dd8233c2d89fdd7bdf3b24dab4fd5018f981f30a0fa0df83271a8bcc915f13b03a55e7e42da2e1d8a3a0684430107be SHA512 0be286c9263ea26fbb29a89a1c9a37577577b1147cbf440de257a3652147bcb559c8fc4118a900cef558b9f49b59074a276c8a4843f3e8829278eaae5b70e913
DIST attrs-20.2.0.tar.gz 160604 BLAKE2B 1536366a943aa2d0517e3c0aa71230c378b20e731cbac78d1c5cc96f2500fb30203ee0939e25c80f8216bcc6dc7ed1fdfc2b23ab7f5d7c712fb05f5ba65739b1 SHA512 829030d8c1fe7bffbbb8d70fc56228f4c378d85a24c89d802e51f63a78abbfa24f46f5aa8b56cb7ba26ef0bf1fb272163873c45c994145de0be45b14c6fb29cd
+DIST attrs-20.3.0.tar.gz 164523 BLAKE2B 66d2e038e485833f5033fbabe2ef9a6565e3f5f5e8530f2c70019e4f5bdfca51083ac6d0bbc9eb765f838070bc90e01db1c83ed6da113ced67300238e12b5f42 SHA512 640532c6b763fd96572e5d85e93c111bebc4c5e0ff9419fe92fb51280f03acb5f9f43339f57d30659e777d5578460675c60ec0a362f9ad433893e3624ce6a931
diff --git a/dev-python/attrs/attrs-20.3.0.ebuild b/dev-python/attrs/attrs-20.3.0.ebuild
new file mode 100644
index 000000000000..6e31251f8bf2
--- /dev/null
+++ b/dev-python/attrs/attrs-20.3.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Attributes without boilerplate"
+HOMEPAGE="
+ https://github.com/python-attrs/attrs
+ https://attrs.readthedocs.org/
+ https://pypi.org/project/attrs/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="
+ dev-python/zope-interface[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ $(python_gen_impl_dep sqlite)
+ >=dev-python/hypothesis-3.6.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-4.3.0[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest