summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-06-30 23:30:46 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-07-01 02:03:35 +0200
commit8964f5a3b1b70c9dcb403c5296fd63a2c04f315a (patch)
tree24cfce7f6a4f95789c6c1a69ab964bff2a69a06c
parentdev-python/rst-linker: require jaraco-packaging for docs (diff)
downloadgentoo-8964f5a3b1b70c9dcb403c5296fd63a2c04f315a.tar.gz
gentoo-8964f5a3b1b70c9dcb403c5296fd63a2c04f315a.tar.bz2
gentoo-8964f5a3b1b70c9dcb403c5296fd63a2c04f315a.zip
dev-db/soci: EAPI-6 bump
Package-Manager: Portage-2.3.41, Repoman-2.3.9
-rw-r--r--dev-db/soci/soci-3.2.3.ebuild39
1 files changed, 20 insertions, 19 deletions
diff --git a/dev-db/soci/soci-3.2.3.ebuild b/dev-db/soci/soci-3.2.3.ebuild
index 390012ef0f71..ba430f65be3c 100644
--- a/dev-db/soci/soci-3.2.3.ebuild
+++ b/dev-db/soci/soci-3.2.3.ebuild
@@ -1,20 +1,21 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
inherit cmake-utils
-KEYWORDS="~amd64 ~x86"
-
DESCRIPTION="Makes the illusion of embedding SQL queries in the regular C++ code"
HOMEPAGE="http://soci.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.zip"
+
LICENSE="Boost-1.0"
SLOT="0"
+KEYWORDS="~amd64 ~x86"
IUSE="boost doc +empty firebird mysql odbc oracle postgres sqlite"
-DEPEND="boost? ( dev-libs/boost )
+DEPEND="
+ boost? ( dev-libs/boost )
firebird? ( dev-db/firebird )
mysql? ( virtual/mysql )
odbc? ( dev-db/unixODBC )
@@ -22,25 +23,25 @@ DEPEND="boost? ( dev-libs/boost )
postgres? ( dev-db/postgresql:= )
sqlite? ( dev-db/sqlite:3 )
"
-RDEPEND=${DEPEND}
+RDEPEND="${DEPEND}"
src_configure() {
- local mycmakeargs="$(cmake-utils_use_with boost )
- $(cmake-utils_use empty SOCI_EMPTY)
- $(cmake-utils_use_with firebird FIREBIRD)
- $(cmake-utils_use_with mysql MYSQL)
- $(cmake-utils_use_with odbc ODBC)
- $(cmake-utils_use_with oracle ORACLE)
- $(cmake-utils_use_with postgres POSTGRESQL)
- $(cmake-utils_use_with sqlite SQLITE3)
- -DWITH_DB2=OFF" #use MYCMAKEARGS if you want enable IBM DB2 support
+ local mycmakeargs=(
+ -DWITH_BOOST=$(usex boost)
+ -DSOCI_EMPTY=$(usex empty)
+ -DWITH_FIREBIRD=$(usex firebird)
+ -DWITH_MYSQL=$(usex mysql)
+ -DWITH_ODBC=$(usex odbc)
+ -DWITH_ORACLE=$(usex oracle)
+ -DWITH_POSTGRESQL=$(usex postgres)
+ -DWITH_SQLITE3=$(usex sqlite)
+ -DWITH_DB2=OFF
+ )
+ #use MYCMAKEARGS if you want enable IBM DB2 support
cmake-utils_src_configure
}
src_install() {
+ use doc && local HTML_DOCS=( doc/. )
cmake-utils_src_install
- dodoc AUTHORS CHANGES
- if use doc; then
- dohtml -r doc/*
- fi
}