summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-09-12 13:57:15 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-09-12 13:59:46 +0200
commit8969e0ec3ebd337fccbb9523f2f71722528bafbc (patch)
tree1689beab0f6226d436090126088068a3fe977c3c
parentdev-ros/hector_pose_estimation: add missing boost dep (diff)
downloadgentoo-8969e0ec3ebd337fccbb9523f2f71722528bafbc.tar.gz
gentoo-8969e0ec3ebd337fccbb9523f2f71722528bafbc.tar.bz2
gentoo-8969e0ec3ebd337fccbb9523f2f71722528bafbc.zip
dev-ros/image_publisher: Remove old
Package-Manager: Portage-2.3.8, Repoman-2.3.3
-rw-r--r--dev-ros/image_publisher/Manifest1
-rw-r--r--dev-ros/image_publisher/files/gcc6-1.patch44
-rw-r--r--dev-ros/image_publisher/files/gcc6.patch32
-rw-r--r--dev-ros/image_publisher/image_publisher-1.12.19.ebuild28
4 files changed, 0 insertions, 105 deletions
diff --git a/dev-ros/image_publisher/Manifest b/dev-ros/image_publisher/Manifest
index b50ff7ba4d9b..f6e12d8df502 100644
--- a/dev-ros/image_publisher/Manifest
+++ b/dev-ros/image_publisher/Manifest
@@ -1,2 +1 @@
-DIST image_pipeline-1.12.19.tar.gz 130635 SHA256 fc3073428fc930523efd6ed4a86d838ab0f0ff04a312eb4188c72a854d300e97 SHA512 f0677e4a811622ffc19792af828f4766408b6a051d271950a8a096d064b043dae1457b2a6f2d59fe5c2971795db04e7abf5e0878ead1428a4da19033693829ba WHIRLPOOL ecb1cdcc07109d3781bb82e88c0fe7e91754b2dfac0bfc7f5d053e6df9ce78b95b4131a9b65715fbce1b44b0acab6f833bd9c0d4f2fb68718fee4f4bfd586c63
DIST image_pipeline-1.12.20.tar.gz 137888 SHA256 b69307689c7fb4e62464254fc24ede26c85087b51519f0b43a33e995dabe1a53 SHA512 37a45cfcc8bdb8b40477860e29f72671d423d4531156f5901128c32a6c41d27f235cdac216502d614ab7ddab5e66c2f343baaa0fd22cf83cb38e667fbbc111c5 WHIRLPOOL 8dda5d84af0929a983e6a2cb54697ee50d3036399a05bff50ae711fb4e8638e8763de407b65beb14d65b2cd48e3b200c84af95cee7da48609448f102d0bfdadc
diff --git a/dev-ros/image_publisher/files/gcc6-1.patch b/dev-ros/image_publisher/files/gcc6-1.patch
deleted file mode 100644
index 74e238b00123..000000000000
--- a/dev-ros/image_publisher/files/gcc6-1.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-commit 562332df73781c1e56ce9123542334cc1d91b143
-Author: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
-Date: Thu Oct 6 08:55:27 2016 +0200
-
- explicitly cast to std::vector<double> to make gcc6 happy
-
- With gcc6, compiling image_publisher fails with this error:
- ```
- /[...]/image_publisher/src/nodelet/image_publisher_nodelet.cpp: In member function 'virtual void image_publisher::ImagePublisherNodelet::onInit()':
- /[...]/image_publisher/src/nodelet/image_publisher_nodelet.cpp:180:43: error: ambiguous overload for 'operator=' (operand types are 'sensor_msgs::CameraInfo_<std::allocator<void> >::_D_type {aka std::vector<double>}' and 'boost::assign_detail::generic_list<int>')
- camera_info_.D = list_of(0)(0)(0)(0)(0);
- ```
-
- After adding an initial explicit type cast for the assignment,
- compiling fails further with:
- ```
- | /[...]/image_publisher/src/nodelet/image_publisher_nodelet.cpp: In member function 'virtual void image_publisher::ImagePublisherNodelet::onInit()':
- | /[...]/image_publisher/src/nodelet/image_publisher_nodelet.cpp:180:65: error: call of overloaded 'vector(boost::assign_detail::generic_list<int>&)' is ambiguous
- | camera_info_.D = std::vector<double> (list_of(0)(0)(0)(0)(0));
- ```
-
- Various sources on the internet [1, 2, 3] point to use the
- `convert_to_container` method; hence, this commit follows those
- suggestions and with that image_publisher compiles with gcc6.
-
- [1] http://stackoverflow.com/questions/16211410/ambiguity-when-using-boostassignlist-of-to-construct-a-stdvector
- [2] http://stackoverflow.com/questions/12352692/ambiguous-call-with-list-of-in-vs2010/12362548#12362548
- [3] http://stackoverflow.com/questions/13285272/using-boostassignlist-of?rq=1
-
- Signed-off-by: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
-
-diff --git a/image_publisher/src/nodelet/image_publisher_nodelet.cpp b/image_publisher/src/nodelet/image_publisher_nodelet.cpp
-index 4102d0d..26e1352 100644
---- a/image_publisher/src/nodelet/image_publisher_nodelet.cpp
-+++ b/image_publisher/src/nodelet/image_publisher_nodelet.cpp
-@@ -177,7 +177,7 @@ public:
- camera_info_.width = image_.cols;
- camera_info_.height = image_.rows;
- camera_info_.distortion_model = "plumb_bob";
-- camera_info_.D = list_of(0)(0)(0)(0)(0);
-+ camera_info_.D = list_of(0)(0)(0)(0)(0).convert_to_container<std::vector<double> >();
- camera_info_.K = list_of(1)(0)(camera_info_.width/2)(0)(1)(camera_info_.height/2)(0)(0)(1);
- camera_info_.R = list_of(1)(0)(0)(0)(1)(0)(0)(0)(1);
- camera_info_.P = list_of(1)(0)(camera_info_.width/2)(0)(0)(1)(camera_info_.height/2)(0)(0)(0)(1)(0);
diff --git a/dev-ros/image_publisher/files/gcc6.patch b/dev-ros/image_publisher/files/gcc6.patch
deleted file mode 100644
index 4815e9e682ca..000000000000
--- a/dev-ros/image_publisher/files/gcc6.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-commit 6c2d65452bd5fe62723988a1a570789921900d59
-Author: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
-Date: Fri Sep 30 15:39:47 2016 +0200
-
- address gcc6 build error
-
- With gcc6, compiling fails with `stdlib.h: No such file or directory`,
- as including '-isystem /usr/include' breaks with gcc6, cf.,
- https://gcc.gnu.org/bugzilla/show_bug.cgi?id=70129.
-
- This commit addresses this issue for this package in the same way
- it was addressed in various other ROS packages. A list of related
- commits and pull requests is at:
-
- https://github.com/ros/rosdistro/issues/12783
-
- Signed-off-by: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
-
-diff --git a/image_publisher/CMakeLists.txt b/image_publisher/CMakeLists.txt
-index 8015a45..431109c 100644
---- a/image_publisher/CMakeLists.txt
-+++ b/image_publisher/CMakeLists.txt
-@@ -8,8 +8,7 @@ generate_dynamic_reconfigure_options(cfg/ImagePublisher.cfg)
-
- catkin_package()
-
--# add the executable
--include_directories(SYSTEM ${catkin_INCLUDE_DIRS})
-+include_directories(${catkin_INCLUDE_DIRS})
-
- add_library(${PROJECT_NAME} SHARED src/nodelet/image_publisher_nodelet.cpp)
- target_link_libraries(${PROJECT_NAME} ${catkin_LIBRARIES})
diff --git a/dev-ros/image_publisher/image_publisher-1.12.19.ebuild b/dev-ros/image_publisher/image_publisher-1.12.19.ebuild
deleted file mode 100644
index 2987189745d5..000000000000
--- a/dev-ros/image_publisher/image_publisher-1.12.19.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-ROS_REPO_URI="https://github.com/ros-perception/image_pipeline"
-KEYWORDS="~amd64 ~arm"
-PYTHON_COMPAT=( python2_7 )
-ROS_SUBDIR=${PN}
-
-inherit ros-catkin
-
-DESCRIPTION="Publish an image stream from single image file or avi file."
-LICENSE="BSD"
-SLOT="0"
-IUSE=""
-
-RDEPEND="
- dev-ros/cv_bridge
- media-libs/opencv:=
- dev-ros/dynamic_reconfigure
- dev-ros/camera_info_manager
- dev-ros/image_transport
- dev-ros/nodelet
- dev-ros/roscpp
- dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
-"
-DEPEND="${RDEPEND}"
-PATCHES=( "${FILESDIR}/gcc6.patch" "${FILESDIR}/gcc6-1.patch" )