summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-02-09 22:18:15 +0100
committerConrad Kostecki <conikost@gentoo.org>2022-02-09 23:56:21 +0100
commit898681f2c77d058b4f7349a7187dd9333dc7c873 (patch)
tree687b5f279c4db06bf6a8a6d6478f175b953759a2
parentnet-irc/znc-palaver: update EAPI 7 -> 8 (diff)
downloadgentoo-898681f2c77d058b4f7349a7187dd9333dc7c873.tar.gz
gentoo-898681f2c77d058b4f7349a7187dd9333dc7c873.tar.bz2
gentoo-898681f2c77d058b4f7349a7187dd9333dc7c873.zip
net-irc/znc-palaver: drop 1.2.1
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--net-irc/znc-palaver/znc-palaver-1.2.1.ebuild60
1 files changed, 0 insertions, 60 deletions
diff --git a/net-irc/znc-palaver/znc-palaver-1.2.1.ebuild b/net-irc/znc-palaver/znc-palaver-1.2.1.ebuild
deleted file mode 100644
index a39dad1cfee9..000000000000
--- a/net-irc/znc-palaver/znc-palaver-1.2.1.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit python-single-r1 toolchain-funcs
-
-DESCRIPTION="A ZNC module which provides push notifications to Palaver"
-HOMEPAGE="https://github.com/cocodelabs/znc-palaver"
-SRC_URI="https://github.com/cocodelabs/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="test"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- ${PYTHON_DEPS}
- net-irc/znc:=[ssl]"
-
-BDEPEND="
- ${RDEPEND}
- $(python_gen_cond_dep '
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- dev-python/semantic_version[${PYTHON_USEDEP}]
- ')
-"
-
-DOCS=( "CHANGELOG.md" "README.md" )
-
-PATCHES=(
- "${FILESDIR}/${P}-python310.patch"
- "${FILESDIR}/${P}-xunit2.patch"
-)
-
-src_compile() {
- tc-export CXX
-
- # Building znc modules by 'znc-buildmod'
- # does not support multiple threads.
- emake -j1
-}
-
-src_test() {
- default
-
- emake test-integration
-}
-
-src_install() {
- insinto /usr/$(get_libdir)/znc
- doins palaver.so
-
- einstalldocs
-}