summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2023-10-28 12:40:10 +0200
committerUlrich Müller <ulm@gentoo.org>2023-11-21 18:45:41 +0100
commit89a3c59b2bf1b84560c3e2c4f22dbed511855cd5 (patch)
tree4dd50c07c4a5d24a98a538f10af831c6ace39ff6
parentnet-p2p/arti: add 1.1.10 (diff)
downloadgentoo-89a3c59b2bf1b84560c3e2c4f22dbed511855cd5.tar.gz
gentoo-89a3c59b2bf1b84560c3e2c4f22dbed511855cd5.tar.bz2
gentoo-89a3c59b2bf1b84560c3e2c4f22dbed511855cd5.zip
app-editors/yudit: improve ebuild, fix #729260
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://bugs.gentoo.org/729260 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
-rw-r--r--app-editors/yudit/yudit-3.1.0-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-editors/yudit/yudit-3.1.0-r1.ebuild b/app-editors/yudit/yudit-3.1.0-r1.ebuild
new file mode 100644
index 000000000000..b28086e41aeb
--- /dev/null
+++ b/app-editors/yudit/yudit-3.1.0-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Free (Y)unicode text editor for all unices"
+HOMEPAGE="https://www.yudit.org/"
+SRC_URI="https://yudit.org/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="x11-libs/libX11"
+DEPEND="${RDEPEND}"
+BDEPEND="sys-devel/gettext"
+
+DOCS=( {BUGS,CHANGELOG,NEWS,TODO}.TXT )
+
+src_prepare() {
+ default
+ # Don't strip binaries, let portage do that.
+ # Don't call ar / ranlib directly
+ sed -i \
+ -e "/^INSTALL_PROGRAM/s| -s||" \
+ -e "s|ar cr|$(tc-getAR) cr|g" \
+ -e "s|ranlib|$(tc-getRANLIB)|g" \
+ Makefile.conf.in || die "sed failed"
+}