summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2021-03-09 15:57:12 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-03-21 22:05:59 +0100
commit89b159a4b45f5b7b2e2877a21ac30a83fd96f596 (patch)
tree206d5b1c1b431056be817201322ae9ad10fccb39
parentapp-text/tidy-html5: version bump. (diff)
downloadgentoo-89b159a4b45f5b7b2e2877a21ac30a83fd96f596.tar.gz
gentoo-89b159a4b45f5b7b2e2877a21ac30a83fd96f596.tar.bz2
gentoo-89b159a4b45f5b7b2e2877a21ac30a83fd96f596.zip
app-text/lcdf-typetools: EAPI 7
Bug: https://bugs.gentoo.org/757561 Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Closes: https://github.com/gentoo/gentoo/pull/19846 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--app-text/lcdf-typetools/lcdf-typetools-2.108-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-text/lcdf-typetools/lcdf-typetools-2.108-r1.ebuild b/app-text/lcdf-typetools/lcdf-typetools-2.108-r1.ebuild
new file mode 100644
index 000000000000..f0df24089ef2
--- /dev/null
+++ b/app-text/lcdf-typetools/lcdf-typetools-2.108-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs flag-o-matic
+
+DESCRIPTION="Font utilities for eg manipulating OTF"
+HOMEPAGE="https://lcdf.org/type/#typetools"
+SRC_URI="https://lcdf.org/type/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="+kpathsea"
+
+RDEPEND="kpathsea? ( virtual/tex-base dev-libs/kpathsea )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ use kpathsea && has_version 'dev-libs/kpathsea' && append-cppflags "$($(tc-getPKG_CONFIG) --cflags kpathsea)"
+ econf $(use_with kpathsea)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc NEWS.md README.md ONEWS
+}