summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Karbowski <slashbeast@gentoo.org>2023-03-01 23:49:11 +0100
committerPiotr Karbowski <slashbeast@gentoo.org>2023-03-01 23:49:35 +0100
commit89b2967787393404baf33efaed9c7483bc1e0672 (patch)
tree328dc695b738bfe9056165a7f9919052052cc68f
parentsys-apps/accountsservice: add missing glib-utils build dependency (diff)
downloadgentoo-89b29677.tar.gz
gentoo-89b29677.tar.bz2
gentoo-89b29677.zip
sys-apps/bubblewrap: 0.8.0 version bump.
Signed-off-by: Piotr Karbowski <slashbeast@gentoo.org>
-rw-r--r--sys-apps/bubblewrap/Manifest1
-rw-r--r--sys-apps/bubblewrap/bubblewrap-0.8.0.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/sys-apps/bubblewrap/Manifest b/sys-apps/bubblewrap/Manifest
index 2734051b198c..a40e824b70fd 100644
--- a/sys-apps/bubblewrap/Manifest
+++ b/sys-apps/bubblewrap/Manifest
@@ -1 +1,2 @@
DIST bubblewrap-0.7.0.tar.xz 147700 BLAKE2B 379feff513a509e6e00c933ca6bafdeef43827e406fbf31e56c1d16feb099a887f88125fb52d038e78b1604c504bdba771aeaeb3274e8d11163492f00fe9633c SHA512 3d163eecd79774e02d082141d027b7ac13f7d3a29c22f6513203e1088f53d53d8dde50e36fc4c8a34e8cde2f3e2a692e00b741f4bee2cc2bb21b9deb600271b5
+DIST bubblewrap-0.8.0.tar.xz 149088 BLAKE2B 5853cf42a7ab653540ec5134866c6f2459aa101e9eea724a4f283405cbcae2beb3551b7c1a7aa93d82016d4eb0d12f9c97c47df53a6d9b589db40483696253de SHA512 1cbc33f3c834ff83f4c1808d3ec2555921277d495f903ad152cbd5065a6e100c5420b4b5c62386bb2d303eb1734e074b09625013e55e3bd8631cfb3582d70e1c
diff --git a/sys-apps/bubblewrap/bubblewrap-0.8.0.ebuild b/sys-apps/bubblewrap/bubblewrap-0.8.0.ebuild
new file mode 100644
index 000000000000..fa95d51552b8
--- /dev/null
+++ b/sys-apps/bubblewrap/bubblewrap-0.8.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-info meson
+
+DESCRIPTION="Unprivileged sandboxing tool, namespaces-powered chroot-like solution"
+HOMEPAGE="https://github.com/containers/bubblewrap/"
+SRC_URI="https://github.com/containers/${PN}/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+IUSE="selinux suid"
+
+RDEPEND="
+ sys-libs/libseccomp
+ sys-libs/libcap
+ selinux? ( >=sys-libs/libselinux-2.1.9 )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-text/docbook-xml-dtd:4.3
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ virtual/pkgconfig
+"
+
+# tests require root privileges
+RESTRICT="test"
+
+pkg_setup() {
+ if [[ ${MERGE_TYPE} != buildonly ]]; then
+ CONFIG_CHECK="~UTS_NS ~IPC_NS ~USER_NS ~PID_NS ~NET_NS"
+ linux-info_pkg_setup
+ fi
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dbash_completion=enabled
+ -Dman=enabled
+ -Dtests=false
+ -Dzsh_completion=enabled
+ $(meson_feature selinux)
+ )
+
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ if use suid; then
+ chmod u+s "${ED}"/usr/bin/bwrap
+ fi
+}