summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-05 05:56:06 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-05 06:55:42 +0200
commit89b7591d827576fe9fcc0ae74216adfcf995716c (patch)
treefa1d569a532a254c454b7563791610a3cfde3f24
parentdev-python/boto3: Bump to 1.26.127 (diff)
downloadgentoo-89b7591d827576fe9fcc0ae74216adfcf995716c.tar.gz
gentoo-89b7591d827576fe9fcc0ae74216adfcf995716c.tar.bz2
gentoo-89b7591d827576fe9fcc0ae74216adfcf995716c.zip
app-admin/awscli: Bump to 1.27.127
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.27.127.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 6d85cebe5e41..c4a9e9ab6c52 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -1,2 +1,3 @@
DIST aws-cli-1.27.123.gh.tar.gz 2414392 BLAKE2B 4df3e98062e61931efc59168eb6dbe6b50f2bd50ef6d5d810bf2d98f08058f69c8965726662f90e8289e94408e916e700acc2d62512d3b3033210eb615bbb8c4 SHA512 bfe6fe1a2fd9209090957faef600b40acd7c4bbf9304089a2844ac736d782a0c53687dd1073faf9e05c8e23c6dd1b6d7930e009dc0ea7765000489130d2a5410
DIST aws-cli-1.27.126.gh.tar.gz 2415804 BLAKE2B f6c9c76320ce2bd7c03009d01e569a4552c329148323d4d7d302b3f4c9dce7f8e6743f427f9308c155917abcf228c5b35eeb15fd06b6602ca26f5f7c34e0cbd6 SHA512 6dd52530d9f35bfcbcc3b4a20b9a45881eea79a274b6fd9a3b2b2a5d6d337dbd3bf9efbe931417f43a7705b0f6359783a0fcf16dc025006cb853fe4fbc297630
+DIST aws-cli-1.27.127.gh.tar.gz 2416842 BLAKE2B 6d1917695f9404a0edf1e9d1720606478e904615e46c775a5b65bab207a1b0ebfd1741daa2202e4567c0d4aa0d0eb6bfaf89210a6ccce542c7ee2c556c21c3b3 SHA512 32ac6f8e00434047acf46cd0dad80618e7c1926fa02cdc365005eccb3744f8ea2d67e11c7155a0ce88e6388668ec3aa0cd0bad33df8a7540bfd0cc1c9dcd52af
diff --git a/app-admin/awscli/awscli-1.27.127.ebuild b/app-admin/awscli/awscli-1.27.127.ebuild
new file mode 100644
index 000000000000..62c19f3a63fb
--- /dev/null
+++ b/app-admin/awscli/awscli-1.27.127.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit bash-completion-r1 distutils-r1 multiprocessing
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# botocore is x.(y+2).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ tests/functional/eks/test_kubeconfig.py::TestKubeconfigLoader::test_load_simple
+ tests/unit/customizations/eks/test_update_kubeconfig.py::TestKubeconfigSelector::test_choose_env_only
+ tests/unit/customizations/eks/test_update_kubeconfig.py::TestKubeconfigSelector::test_choose_existing
+ tests/unit/customizations/eks/test_kubeconfig.py::TestKubeconfigValidator::test_valid
+ )
+
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)" --forked
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}