summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-09-05 13:59:07 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-09-05 14:11:19 +0200
commit89cf15aeea0f2e5363c2c98cb1a6479799facb58 (patch)
tree4472ed72495bb4df4c72522f6bbaadcdc1edf24a
parentdev-python/spyder-unittest: drop 0.5.0 (diff)
downloadgentoo-89cf15aeea0f2e5363c2c98cb1a6479799facb58.tar.gz
gentoo-89cf15aeea0f2e5363c2c98cb1a6479799facb58.tar.bz2
gentoo-89cf15aeea0f2e5363c2c98cb1a6479799facb58.zip
dev-python/spyder-line-profiler: re-add package, add 0.3.1
This reverts commit 03a02eeac7ed5c2588bc6e5a407587fc24287e60. Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
-rw-r--r--dev-python/spyder-line-profiler/Manifest1
-rw-r--r--dev-python/spyder-line-profiler/metadata.xml12
-rw-r--r--dev-python/spyder-line-profiler/spyder-line-profiler-0.3.1.ebuild34
-rw-r--r--profiles/arch/amd64/x32/package.mask1
4 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/spyder-line-profiler/Manifest b/dev-python/spyder-line-profiler/Manifest
new file mode 100644
index 000000000000..80567234d77f
--- /dev/null
+++ b/dev-python/spyder-line-profiler/Manifest
@@ -0,0 +1 @@
+DIST spyder-line-profiler-0.3.1.gh.tar.gz 44042 BLAKE2B a98c5770b44b3e11d2261b371e5a806087ebcb347b54745b5bdfe5c4fe3051ff862c79e96ab9a0048e83217cba65fd48a6368bf3e1d1a3f9ab09d2dd69f8ec7c SHA512 96ddc1817adfd58362ea766b95cd58ad521c1333a6bafe9fef1e117ef7ef602bc7e7bced3990d19b85c2882253d81d27940ab409a9daacf588513a405ae4d8fb
diff --git a/dev-python/spyder-line-profiler/metadata.xml b/dev-python/spyder-line-profiler/metadata.xml
new file mode 100644
index 000000000000..7cf2dd3db140
--- /dev/null
+++ b/dev-python/spyder-line-profiler/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>andrewammerlaan@gentoo.org</email>
+ <name>Andrew Ammerlaan</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">spyder-line-profiler</remote-id>
+ </upstream>
+ <stabilize-allarches/>
+</pkgmetadata>
diff --git a/dev-python/spyder-line-profiler/spyder-line-profiler-0.3.1.ebuild b/dev-python/spyder-line-profiler/spyder-line-profiler-0.3.1.ebuild
new file mode 100644
index 000000000000..dc37126b66a1
--- /dev/null
+++ b/dev-python/spyder-line-profiler/spyder-line-profiler-0.3.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Plugin to run the python line profiler from within the spyder editor"
+HOMEPAGE="https://github.com/spyder-ide/spyder-line-profiler"
+SRC_URI="https://github.com/spyder-ide/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/line_profiler[${PYTHON_USEDEP}]
+ dev-python/qtawesome[${PYTHON_USEDEP}]
+ >=dev-python/spyder-5.2.0[${PYTHON_USEDEP}]
+ <dev-python/spyder-6.0.0[${PYTHON_USEDEP}]
+"
+
+DEPEND="test? (
+ dev-python/pytest-qt[${PYTHON_USEDEP}]
+)"
+
+distutils_enable_tests pytest
+
+python_test() {
+ virtx epytest
+}
diff --git a/profiles/arch/amd64/x32/package.mask b/profiles/arch/amd64/x32/package.mask
index 24238bc3899a..143e490dc563 100644
--- a/profiles/arch/amd64/x32/package.mask
+++ b/profiles/arch/amd64/x32/package.mask
@@ -55,6 +55,7 @@ dev-lang/typescript
dev-python/spyder
dev-python/spyder-terminal
dev-python/spyder-unittest
+dev-python/spyder-line-profiler
dev-util/kdevelop:5
dev-util/kdevelop-php:5
dev-util/kdevelop-python:5