summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-05-27 15:37:59 +0200
committerPacho Ramos <pacho@gentoo.org>2018-05-27 15:37:59 +0200
commit89d30fa4eef6bc82bd1315af9128fc5b07494a05 (patch)
tree8ce5a94753d2b7a10fd7954b391a05a3659de2be
parentnet-mail/qtools: Reduce DESCRIPTION size a bit (diff)
downloadgentoo-89d30fa4.tar.gz
gentoo-89d30fa4.tar.bz2
gentoo-89d30fa4.zip
dev-python/enable: Run tests as upstream wants and restrict
until fixed (#654090, https://github.com/enthought/enable/issues/303) Package-Manager: Portage-2.3.38, Repoman-2.3.9
-rw-r--r--dev-python/enable/enable-4.7.1.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/dev-python/enable/enable-4.7.1.ebuild b/dev-python/enable/enable-4.7.1.ebuild
index 1672c3a01efa..afe2cd13e91b 100644
--- a/dev-python/enable/enable-4.7.1.ebuild
+++ b/dev-python/enable/enable-4.7.1.ebuild
@@ -17,6 +17,8 @@ SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="doc examples test"
+RESTRICT="test" # Until https://github.com/enthought/enable/issues/303 is solved
+
RDEPEND="
dev-python/apptools[${PYTHON_USEDEP}]
dev-python/kiwisolver[${PYTHON_USEDEP}]
@@ -34,6 +36,7 @@ DEPEND="${RDEPEND}
dev-python/cython[${PYTHON_USEDEP}]
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
test? (
+ dev-python/coverage[${PYTHON_USEDEP}]
dev-python/fonttools[${PYTHON_USEDEP}]
dev-python/hypothesis[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
@@ -61,9 +64,9 @@ python_compile_all() {
python_test() {
pushd "${BUILD_DIR}"/lib > /dev/null
- # https://github.com/enthought/enable/issues/158
- PYTHONPATH=.:kiva \
- virtx nosetests --verbose
+ # https://github.com/enthought/enable/issues/303
+ virtx coverage run -m nose.core enable -v
+ virtx coverage run -a -m nose.core kiva -v
popd > /dev/null
}