summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-03-29 10:54:22 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2018-03-29 10:54:22 -0500
commit89e514ba7beecfb5cc394f5e46833d71ebcd8584 (patch)
treee643b773c5b253f356b4bf3320eb4455ffc5152d
parentdev-python/python-magnumclient: 2.9.0 bup (diff)
downloadgentoo-89e514ba.tar.gz
gentoo-89e514ba.tar.bz2
gentoo-89e514ba.zip
dev-python/voluptuous: 0.11.1 bup
Closes: https://bugs.gentoo.org/651916 Package-Manager: Portage-2.3.26, Repoman-2.3.7
-rw-r--r--dev-python/voluptuous/Manifest1
-rw-r--r--dev-python/voluptuous/voluptuous-0.11.1.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/voluptuous/Manifest b/dev-python/voluptuous/Manifest
index 03bad7d2660b..84d8e1a5221a 100644
--- a/dev-python/voluptuous/Manifest
+++ b/dev-python/voluptuous/Manifest
@@ -1,2 +1,3 @@
DIST voluptuous-0.10.5.tar.gz 41436 BLAKE2B a768e519157ed6999a67e7c759588c4558d3e694e4c5d4a1da0567737d249664e985661b57f9f8595fd7cf5f1b0d05d511616d6d44604443b948bd414b334412 SHA512 2024121c56a91cc3bf5102ca68f8347461b2041da9a352eade0e0ce3657d9a477a60a7a5823e8f3628eee7b327840b5c4eba13c106ea49ea91a553d6b5edd363
+DIST voluptuous-0.11.1.tar.gz 44346 BLAKE2B c0715293fbde6ce9008916d6e016d52920eda1906dc2ec292deee4b6b9f596f2d50592486b5a89df6a90e0512973e12cd69482e55f6c3a96ea0cc4b3e52bc77d SHA512 7e2f3ea122f739944a7820a536551abc45df9847a0c3daf5527eabd781b904706ea708c885d724828cfdaaac66774d2f8e7b42d3376de1c78ef2be9f535fd58f
DIST voluptuous-0.9.3.tar.gz 34097 BLAKE2B 801e11f3318ca091909a0b9fd6085bbbf2d85e6a492bfe957868a8efccf98eb1f705aff8beacd8189381d814f20b1a34cc783098ada17b27794ec663c627a995 SHA512 1c82f9fdca1751fb3e5fa1a0c956e40e3c5ba76623a97f38dee7511c4dac430432f8f0469e1b08d6057056905643f98cc5b19c040386eb5c897dec1940c4eb45
diff --git a/dev-python/voluptuous/voluptuous-0.11.1.ebuild b/dev-python/voluptuous/voluptuous-0.11.1.ebuild
new file mode 100644
index 000000000000..3b1c08000c52
--- /dev/null
+++ b/dev-python/voluptuous/voluptuous-0.11.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python data validation library."
+HOMEPAGE="https://github.com/alecthomas/voluptuous"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+python_test() {
+ unset PYTHONPATH
+ nosetests -v || die "Tests failed"
+}