summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-07-24 11:34:20 +0200
committerDavid Seifert <soap@gentoo.org>2022-07-24 11:34:20 +0200
commit89f39879b9de48f76d246e3c7881004de6b4d835 (patch)
tree6ed80f2df3c5953db3b09837239bc77d5d2f4365
parentdev-python/seaborn: Stabilize 0.11.2 amd64, #859274 (diff)
downloadgentoo-89f39879b9de48f76d246e3c7881004de6b4d835.tar.gz
gentoo-89f39879b9de48f76d246e3c7881004de6b4d835.tar.bz2
gentoo-89f39879b9de48f76d246e3c7881004de6b4d835.zip
media-gfx/graphviz: drop 4.0.0-r1
Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--media-gfx/graphviz/Manifest1
-rw-r--r--media-gfx/graphviz/files/graphviz-4.0.0-clang-printf-alike.patch221
-rw-r--r--media-gfx/graphviz/graphviz-4.0.0-r1.ebuild221
3 files changed, 0 insertions, 443 deletions
diff --git a/media-gfx/graphviz/Manifest b/media-gfx/graphviz/Manifest
index 37f8b492e946..96de3755e78f 100644
--- a/media-gfx/graphviz/Manifest
+++ b/media-gfx/graphviz/Manifest
@@ -1,3 +1,2 @@
DIST graphviz-2.50.0.tar.xz 23031008 BLAKE2B a1789368a77384366bf813466d4a733765ffc0a04660cfcc002c643264780425b449087306b143cfddd70d2feabb67e82b6c04217684aba175824c3e83062085 SHA512 2b035559da20bad35e046bfa1b2c8ce1b395ff9b812f33bcf612d7f7c65ff9a226c9b209553b4283825330683fb925516563943de7922c2f6434baaf3c3b5ee2
-DIST graphviz-4.0.0.tar.xz 21494432 BLAKE2B b188feb5c6bad2537f7d404c330c314de38f6f274d72ce84040524d6be209642686161939a210f41e446dc37619266864353f7e1829d172c97e559632ba17971 SHA512 34e3e720152cb6a8f0d266f37ae1f66d432b89f44309f172d7abfcf8eba611a16e41250faa3eac64bf94e5e721a242ad5093ef8905238b61d6ad869b7853b9d2
DIST graphviz-5.0.0.tar.xz 21495572 BLAKE2B b28cbc5a20b202441ed7e98ebbb85b878f9362d1f95816ca89f7aedd62302c77974efc3b63e2ab8b577da59946ca63c7607706da2e79afcae9089f8c2743cd4a SHA512 51576c0d0405aa2005e908b57c3bac5e30069e6efb355b467a35a46559b002b34eaec77c35b6d41c635d6d874351da7261a11cf0f857cea72ff7259d5f6c860d
diff --git a/media-gfx/graphviz/files/graphviz-4.0.0-clang-printf-alike.patch b/media-gfx/graphviz/files/graphviz-4.0.0-clang-printf-alike.patch
deleted file mode 100644
index ef213bccd8ab..000000000000
--- a/media-gfx/graphviz/files/graphviz-4.0.0-clang-printf-alike.patch
+++ /dev/null
@@ -1,221 +0,0 @@
-diff --git a/CHANGELOG.md b/CHANGELOG.md
-index f38cc8ff5..4f1a127a2 100644
---- a/CHANGELOG.md
-+++ b/CHANGELOG.md
-@@ -6,6 +6,11 @@ and this project adheres to [Semantic Versioning](https://semver.org/spec/v2.0.0
-
- ## [Unreleased (4.0.1)]
-
-+### Fixed
-+
-+- **Breaking**: The 4.0.0 change replacing the `Agiodisc_t` struct member
-+ `putstr` by `printf` has been reverted
-+
- ## [4.0.0] – 2022-05-29
-
- ### Changed
-diff --git a/cmd/gvpr/gvprmain.c b/cmd/gvpr/gvprmain.c
-index 188cfdf94..92872f8cd 100644
---- a/cmd/gvpr/gvprmain.c
-+++ b/cmd/gvpr/gvprmain.c
-@@ -47,14 +47,17 @@ static int iofread(void *chan, char *buf, int bufsize)
- return (int)fread(buf, 1, (size_t)bufsize, chan);
- }
-
-+static int ioputstr(void *chan, const char *str)
-+{
-+ return fputs(str, chan);
-+}
-+
- static int ioflush(void *chan)
- {
- return fflush(chan);
- }
-
--typedef int (*printfn)(void *chan, const char *format, ...);
--
--static Agiodisc_t gprIoDisc = { iofread, (printfn)fprintf, ioflush };
-+static Agiodisc_t gprIoDisc = { iofread, ioputstr, ioflush };
-
- static Agdisc_t gprDisc = { &AgMemDisc, &AgIdDisc, &gprIoDisc };
-
-diff --git a/lib/cgraph/cgraph.3 b/lib/cgraph/cgraph.3
-index ed7392c06..67e35c2e9 100644
---- a/lib/cgraph/cgraph.3
-+++ b/lib/cgraph/cgraph.3
-@@ -487,14 +487,14 @@ The I/O discipline provides an abstraction for the reading and writing of graphs
- .P0
- struct Agiodisc_s {
- int (*fread)(void *chan, char *buf, int bufsize);
-- int (*printf)(void *chan, const char *format, ...);
-+ int (*putstr)(void *chan, char *str);
- int (*flush)(void *chan); /* sync */
- } ;
- .P1
- Normally, the \fBFILE\fP structure and its related functions are used for I/O. At times, though,
- an application may need to use a totally different type of character source. The associated
- state or stream information is provided by the \fIchan\fP argument to \fBagread\fP or \fBagwrite\fP.
--The discipline function \fIfread\fP and \fIprintf\fP provide the corresponding functions for
-+The discipline function \fIfread\fP and \fIputstr\fP provide the corresponding functions for
- read and writing.
-
- .SH "MEMORY DISCIPLINE"
-diff --git a/lib/cgraph/cgraph.h b/lib/cgraph/cgraph.h
-index 7b005c442..cbec3bbe6 100644
---- a/lib/cgraph/cgraph.h
-+++ b/lib/cgraph/cgraph.h
-@@ -169,7 +169,7 @@ struct Agiddisc_s { /* object ID allocator */
-
- struct Agiodisc_s {
- int (*afread) (void *chan, char *buf, int bufsize);
-- int (*printf)(void *chan, const char *format, ...);
-+ int (*putstr) (void *chan, const char *str);
- int (*flush) (void *chan); /* sync */
- /* error messages? */
- };
-diff --git a/lib/cgraph/io.c b/lib/cgraph/io.c
-index d8b136804..66c605ae6 100644
---- a/lib/cgraph/io.c
-+++ b/lib/cgraph/io.c
-@@ -24,15 +24,17 @@ static int iofread(void *chan, char *buf, int bufsize)
- }
-
- /* default IO methods */
-+static int ioputstr(void *chan, const char *str)
-+{
-+ return fputs(str, chan);
-+}
-
- static int ioflush(void *chan)
- {
- return fflush(chan);
- }
-
--typedef int (*printfn)(void *chan, const char *format, ...);
--
--Agiodisc_t AgIoDisc = { iofread, (printfn)fprintf, ioflush };
-+Agiodisc_t AgIoDisc = { iofread, ioputstr, ioflush };
-
- typedef struct {
- const char *data;
-@@ -78,7 +80,7 @@ static Agraph_t *agmemread0(Agraph_t *arg_g, const char *cp)
- rdr_t rdr;
- Agdisc_t disc;
-
-- memIoDisc.printf = AgIoDisc.printf;
-+ memIoDisc.putstr = AgIoDisc.putstr;
- memIoDisc.flush = AgIoDisc.flush;
- rdr.data = cp;
- rdr.len = strlen(cp);
-diff --git a/lib/cgraph/write.c b/lib/cgraph/write.c
-index e14f7d835..9e72d2c5c 100644
---- a/lib/cgraph/write.c
-+++ b/lib/cgraph/write.c
-@@ -26,7 +26,7 @@ typedef void iochan_t;
-
- static int ioput(Agraph_t * g, iochan_t * ofile, char *str)
- {
-- return AGDISC(g, io)->printf(ofile, "%s", str);
-+ return AGDISC(g, io)->putstr(ofile, str);
-
- }
-
-diff --git a/lib/gvpr/compile.c b/lib/gvpr/compile.c
-index a7fe27bf5..3704f51d9 100644
---- a/lib/gvpr/compile.c
-+++ b/lib/gvpr/compile.c
-@@ -66,14 +66,17 @@ static int iofread(void *chan, char *buf, int bufsize)
- return (int)read(sffileno(chan), buf, bufsize);
- }
-
-+static int ioputstr(void *chan, const char *str)
-+{
-+ return sfputr(chan, str, -1);
-+}
-+
- static int ioflush(void *chan)
- {
- return sfsync(chan);
- }
-
--typedef int (*printfn)(void *chan, const char *format, ...);
--
--static Agiodisc_t gprIoDisc = { iofread, (printfn)sfprintf, ioflush };
-+static Agiodisc_t gprIoDisc = { iofread, ioputstr, ioflush };
-
- #ifdef GVDLL
- static Agdisc_t gprDisc = { 0, 0, &gprIoDisc };
-diff --git a/plugin/core/gvrender_core_dot.c b/plugin/core/gvrender_core_dot.c
-index c45563460..63eb5e535 100644
---- a/plugin/core/gvrender_core_dot.c
-+++ b/plugin/core/gvrender_core_dot.c
-@@ -511,7 +511,7 @@ static void xdot_end_graph(graph_t* g)
- textflags[EMIT_GLABEL] = 0;
- }
-
--typedef int (*printfn)(void *chan, const char *format, ...);
-+typedef int (*putstrfn) (void *chan, const char *str);
- typedef int (*flushfn) (void *chan);
- static void dot_end_graph(GVJ_t *job)
- {
-@@ -521,7 +521,7 @@ static void dot_end_graph(GVJ_t *job)
-
- if (io.afread == NULL) {
- io.afread = AgIoDisc.afread;
-- io.printf = (printfn)gvprintf;
-+ io.putstr = (putstrfn)gvputs;
- io.flush = (flushfn)gvflush;
- }
-
-diff --git a/plugin/core/gvrender_core_json.c b/plugin/core/gvrender_core_json.c
-index bab5d64af..88715a93a 100644
---- a/plugin/core/gvrender_core_json.c
-+++ b/plugin/core/gvrender_core_json.c
-@@ -693,7 +693,7 @@ static void write_graph(Agraph_t * g, GVJ_t * job, int top, state_t* sp)
- gvputs(job, "}");
- }
-
--typedef int (*printfn)(void *chan, const char *format, ...);
-+typedef int (*putstrfn) (void *chan, const char *str);
- typedef int (*flushfn) (void *chan);
-
- static void json_end_graph(GVJ_t *job)
-@@ -704,7 +704,7 @@ static void json_end_graph(GVJ_t *job)
-
- if (io.afread == NULL) {
- io.afread = AgIoDisc.afread;
-- io.printf = (printfn)gvprintf;
-+ io.putstr = (putstrfn)gvputs;
- io.flush = (flushfn)gvflush;
- }
-
-diff --git a/tclpkg/tcldot/tcldot.c b/tclpkg/tcldot/tcldot.c
-index 335d8e469..b747124cf 100644
---- a/tclpkg/tcldot/tcldot.c
-+++ b/tclpkg/tcldot/tcldot.c
-@@ -163,7 +163,7 @@ int Tcldot_Init(Tcl_Interp * interp)
- /* build disciplines dynamically so we can selectively replace functions */
-
- ictx->myioDisc.afread = NULL; /* set in dotread() or dotstring() according to need */
-- ictx->myioDisc.printf = AgIoDisc.printf; /* no change */
-+ ictx->myioDisc.putstr = AgIoDisc.putstr; /* no change */
- ictx->myioDisc.flush = AgIoDisc.flush; /* no change */
-
- ictx->mydisc.mem = &AgMemDisc; /* no change */
-diff --git a/lib/common/output.c b/lib/common/output.c
-index c91dfe41e..648409c5a 100644
---- a/lib/common/output.c
-+++ b/lib/common/output.c
-@@ -80,11 +80,11 @@ void write_plain(GVJ_t *job, graph_t *g,
- bezier bz;
- pointf pt;
- char *lbl;
- char* fillcolor;
-
-- print = g->clos->disc.io->printf;
-+ print = g->clos->disc.io->putstr;
- // setup_graph(job, g);
- setYInvert(g);
- pt = GD_bb(g).UR;
- print(f, "graph %.5g %.5g %.5g\n", job->zoom, PS2INCH(pt.x), PS2INCH(pt.y));
- for (n = agfstnode(g); n; n = agnxtnode(g, n)) {
diff --git a/media-gfx/graphviz/graphviz-4.0.0-r1.ebuild b/media-gfx/graphviz/graphviz-4.0.0-r1.ebuild
deleted file mode 100644
index 53c156b50c4b..000000000000
--- a/media-gfx/graphviz/graphviz-4.0.0-r1.ebuild
+++ /dev/null
@@ -1,221 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..11} )
-inherit python-single-r1
-
-DESCRIPTION="Open Source Graph Visualization Software"
-HOMEPAGE="https://www.graphviz.org/ https://gitlab.com/graphviz/graphviz/"
-# unfortunately upstream uses an "artifact" store for the pre-generated
-# tarball now, which makes predictable URLs impossible.
-SRC_URI="https://gitlab.com/api/v4/projects/4207231/packages/generic/graphviz-releases/${PV}/${P}.tar.xz"
-
-LICENSE="CPL-1.0"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris"
-IUSE="+cairo devil doc examples gtk2 gts guile lasi nls pdf perl postscript python qt5 ruby svg tcl webp X"
-
-REQUIRED_USE="
- !cairo? ( !X !gtk2 !postscript !lasi )
- pdf? ( cairo )
- python? ( ${PYTHON_REQUIRED_USE} )"
-
-# Requires ksh, tests against installed package, missing files and directory
-RESTRICT="test"
-
-RDEPEND="
- >=dev-libs/expat-2
- >=dev-libs/glib-2.11.1:2
- dev-libs/libltdl:0
- >=media-libs/fontconfig-2.3.95
- >=media-libs/freetype-2.1.10
- >=media-libs/gd-2.0.34:=[fontconfig,jpeg,png,truetype,zlib]
- media-libs/libjpeg-turbo:=
- >=media-libs/libpng-1.2:0=
- sys-libs/zlib
- virtual/libiconv
- cairo? (
- >=x11-libs/cairo-1.1.10[svg]
- >=x11-libs/pango-1.12
- )
- devil? ( media-libs/devil[png,jpeg] )
- gtk2? (
- x11-libs/gdk-pixbuf:2
- x11-libs/gtk+:2
- )
- gts? ( sci-libs/gts )
- guile? ( dev-scheme/guile )
- lasi? ( media-libs/lasi )
- pdf? ( app-text/poppler )
- perl? ( dev-lang/perl:= )
- postscript? ( app-text/ghostscript-gpl )
- python? ( ${PYTHON_DEPS} )
- qt5? (
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtprintsupport:5
- dev-qt/qtwidgets:5
- )
- ruby? ( dev-lang/ruby:* )
- svg? ( gnome-base/librsvg )
- tcl? ( >=dev-lang/tcl-8.3:0= )
- webp? ( media-libs/libwebp:= )
- X? ( x11-libs/libX11 )"
-DEPEND="${RDEPEND}
- X? ( x11-base/xorg-proto )"
-BDEPEND="
- sys-devel/flex
- sys-devel/libtool
- virtual/pkgconfig
- doc? (
- app-text/ghostscript-gpl
- sys-apps/groff
- )
- guile? (
- dev-lang/swig
- dev-scheme/guile
- )
- nls? ( >=sys-devel/gettext-0.14.5 )
- perl? ( dev-lang/swig )
- python? ( dev-lang/swig )
- ruby? ( dev-lang/swig )
- tcl? ( dev-lang/swig )"
-
-# Dependency description / Maintainer-Info:
-
-# Rendering is done via the following plugins (/plugins):
-# - core, dot_layout, neato_layout, gd , dot
-# the ones which are always compiled in, depend on zlib, gd
-# - gtk
-# Directly depends on gtk-2.
-# needs 'pangocairo' enabled in graphviz configuration
-# gtk-2 depends on pango, cairo and libX11 directly.
-# - gdk-pixbuf
-# Directly depends on gtk-2 and gdk-pixbuf.
-# needs 'pangocairo' enabled in graphviz configuration
-# - ming
-# flash plugin via -Tswf requires media-libs/ming-0.4. Disabled as it's
-# incomplete.
-# - cairo/pango:
-# Needs pango for text layout, uses cairo methods to draw stuff
-# - xlib:
-# needs cairo+pango,
-# can make use of gnomeui and inotify support (??? unsure),
-# needs libXaw for UI
-# UI also links directly against libX11, libXmu, and libXt
-# and uses libXpm if available so we make sure it always is
-
-# There can be swig-generated bindings for the following languages (/tclpkg/gv):
-# - c-sharp (disabled)
-# - scheme (enabled via guile) ... no longer broken on ~x86
-# - go (disabled)
-# - io (disabled)
-# - lua (enabled via lua)
-# - ocaml (enabled via ocaml)
-# - perl (enabled via perl) *1
-# - php (enabled via php) *2
-# - python (enabled via python) *1
-# - ruby (enabled via ruby) *1
-# - tcl (enabled via tcl)
-# *1 = The ${P}-bindings.patch takes care that those bindings are installed to the right location
-# *2 = Those bindings don't build because the paths for the headers/libs aren't
-# detected correctly and/or the options passed to swig are wrong (-php instead of -php4/5)
-
-# There are several other tools in /tclpkg:
-# gdtclft, tcldot, tclhandle, tclpathplan, tclstubs ; enabled with: --with-tcl
-# tkspline, tkstubs ; enabled with: --with-tk
-
-# And the commands (/cmd):
-# - dot, gvedit, gvpr, smyrna, tools/* :)
-# sci-libs/gts can be used for some of these
-# - gvedit (via 'qt5'):
-# based on ./configure it needs qt-core and qt-gui only
-# - smyrna : experimental opengl front-end (via 'smyrna')
-# currently disabled -- it segfaults a lot
-# needs x11-libs/gtkglext, gnome-base/libglade, media-libs/freeglut
-# sci-libs/gts, x11-libs/gtk. Also needs 'gtk','glade','glut','gts' and 'png'
-# with flags enabled at configure time
-
-PATCHES=(
- # backport, remove on bump (bug #853175)
- "${FILESDIR}"/${P}-clang-printf-alike.patch
-)
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
-src_configure() {
- local myconf=(
- # Speeds up the libltdl configure
- --cache-file="${S}"/config.cache
- --enable-ltdl
- $(use_enable doc man-pdfs)
- $(use_with cairo pangocairo)
- $(use_with examples demos '$(docdir)/examples')
- $(use_with devil)
- $(use_with gtk2 gdk)
- $(use_with gtk2 gdk-pixbuf)
- $(use_with gtk2)
- $(use_with gts)
- $(use_with qt5 qt)
- $(use_with lasi)
- $(use_with pdf poppler)
- $(use_with postscript ghostscript)
- $(use_with svg rsvg)
- $(use_with webp)
- $(use_with X x)
- --with-digcola
- --with-fontconfig
- --with-freetype2
- --with-ipsepcola
- --with-libgd
- --with-sfdp
- --without-ming
- # new/experimental features, to be tested, disable for now
- --without-ipsepcola
- --without-smyrna
- --without-visio
- # Bindings:
- $(use_enable guile)
- $(use_enable perl)
- $(use_enable python python3)
- $(use_enable ruby)
- $(use_enable tcl)
- --disable-go
- --disable-io
- --disable-lua
- --disable-java
- --disable-ocaml
- --disable-php
- --disable-python
- --disable-r
- --disable-sharp
- # libtool file collision, bug #276609
- --without-included-ltdl
- --disable-ltdl-install
- )
- econf "${myconf[@]}"
-}
-
-src_install() {
- default
-
- find "${ED}" -name '*.la' -delete || die
-
- use python && python_optimize \
- "${D}"$(python_get_sitedir) \
- "${ED}"/usr/$(get_libdir)/graphviz/python3
-}
-
-pkg_postinst() {
- # We need to register all plugins before they become usable
- dot -c || die
-}
-
-pkg_postrm() {
- # Remove cruft, bug #547344
- rm -rf "${EROOT}"/usr/$(get_libdir)/graphviz/config{,6} || die
-}