summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-01-21 13:46:41 -0500
committerSam James <sam@gentoo.org>2024-01-22 05:54:50 +0000
commit8a04cb92c7caaff1db47d2253d96469af42ea0b1 (patch)
treec0ebb0eb056d66d65f81ffe14d6274f87c9cbe97
parentnet-p2p/qbittorrent: remove geoip dependency (diff)
downloadgentoo-8a04cb92.tar.gz
gentoo-8a04cb92.tar.bz2
gentoo-8a04cb92.zip
net-p2p/qbittorrent: add comment explaining why cmake_src_test isn't used
Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-p2p/qbittorrent/qbittorrent-4.5.5-r2.ebuild2
-rw-r--r--net-p2p/qbittorrent/qbittorrent-4.6.2-r1.ebuild2
-rw-r--r--net-p2p/qbittorrent/qbittorrent-9999.ebuild2
3 files changed, 6 insertions, 0 deletions
diff --git a/net-p2p/qbittorrent/qbittorrent-4.5.5-r2.ebuild b/net-p2p/qbittorrent/qbittorrent-4.5.5-r2.ebuild
index f01ecb3233cc..59e8d99bcc36 100644
--- a/net-p2p/qbittorrent/qbittorrent-4.5.5-r2.ebuild
+++ b/net-p2p/qbittorrent/qbittorrent-4.5.5-r2.ebuild
@@ -124,6 +124,8 @@ src_compile() {
src_test() {
my_src_test() {
+ # cmake does not detect tests by default, if you use enable_testing
+ # in a subdirectory instead of the root CMakeLists.txt
cd "${BUILD_DIR}"/test || die
edo ctest .
}
diff --git a/net-p2p/qbittorrent/qbittorrent-4.6.2-r1.ebuild b/net-p2p/qbittorrent/qbittorrent-4.6.2-r1.ebuild
index aea6929464d7..1c8f0230fd60 100644
--- a/net-p2p/qbittorrent/qbittorrent-4.6.2-r1.ebuild
+++ b/net-p2p/qbittorrent/qbittorrent-4.6.2-r1.ebuild
@@ -120,6 +120,8 @@ src_compile() {
src_test() {
my_src_test() {
+ # cmake does not detect tests by default, if you use enable_testing
+ # in a subdirectory instead of the root CMakeLists.txt
cd "${BUILD_DIR}"/test || die
edo ctest .
}
diff --git a/net-p2p/qbittorrent/qbittorrent-9999.ebuild b/net-p2p/qbittorrent/qbittorrent-9999.ebuild
index b5ae2f148965..3bb8284e631e 100644
--- a/net-p2p/qbittorrent/qbittorrent-9999.ebuild
+++ b/net-p2p/qbittorrent/qbittorrent-9999.ebuild
@@ -124,6 +124,8 @@ src_compile() {
src_test() {
my_src_test() {
+ # cmake does not detect tests by default, if you use enable_testing
+ # in a subdirectory instead of the root CMakeLists.txt
cd "${BUILD_DIR}"/test || die
edo ctest .
}