summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-12-25 18:00:16 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-12-25 18:03:57 +0100
commit8a1516a2bb03f11e674e0277c43a120a679ef2df (patch)
treeaa692791f66981eb69e57a701699046115318ae2
parentdev-libs/appstream: add 1.0.1 (diff)
downloadgentoo-8a1516a2.tar.gz
gentoo-8a1516a2.tar.bz2
gentoo-8a1516a2.zip
dev-libs/appstream: drop 1.0.0
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--dev-libs/appstream/Manifest1
-rw-r--r--dev-libs/appstream/appstream-1.0.0.ebuild78
-rw-r--r--profiles/package.mask1
3 files changed, 0 insertions, 80 deletions
diff --git a/dev-libs/appstream/Manifest b/dev-libs/appstream/Manifest
index 5f248a2265b1..e2625cca5e7c 100644
--- a/dev-libs/appstream/Manifest
+++ b/dev-libs/appstream/Manifest
@@ -1,4 +1,3 @@
DIST AppStream-0.15.6.tar.xz 2517688 BLAKE2B 09519205c7dfc5f0715b9d5ae7e99a67673ab499f1e2cb39815edde64defc1aa5059215575278bbcfc4482cd385a79e081c70f6acea3c446c5869dc6b2e18f6c SHA512 7426bc89e22b751de7b3e27d7c07eb1c373f4439f9966868ce5ea410d209b8c5292e03695a34b7a49bfa61e2e62265c7f7cdffc0be871c950193c933f65757ef
DIST AppStream-0.16.4.tar.xz 2570176 BLAKE2B ac051b846fd1c7b0cbb3429e0b4c3f81027cddb35ee6bcd5e9d38a09d937abcc37ac4908f68ec55404ae852fd146b4e749832d3ac96443458e86cfe506a6fed4 SHA512 e3a9fc423fe5a2baaaa002871566f320ecd6dbd3a01ab24221afe9b93a69e9afb6bed6d7772c434376501803dc7b2c80b79eda849fcaf4748f9f24a5908a22a8
-DIST AppStream-1.0.0.tar.xz 2683916 BLAKE2B a5c21cb05dcf50cf78f1c51c1055d0749ee680685a42a88300bd6d218284c7bbb34d3aa65b145120c8f930bca98ce927a1cf3d5ba4c393a16511c8be5946d81d SHA512 273f1bbb64794691f04bee0cff782670465c6da238beec040af71a99395afdc8a85a6712c77777ff7c7ca872db6b2c8549782b7773d882e5ed7e9aa2a880f04c
DIST AppStream-1.0.1.tar.xz 2686244 BLAKE2B fae90075737e2ef29f26f3428f2708d205974ceb49c4e1af8b69f14d5f388fd0dee2a69ab6f26bf83618d1ab5a5d439400f78da43206a4c7c0fa56f5000bf363 SHA512 9e7d275910778ad119ac6029f61104619857a61582ec1022cea3a852cd8794b191aefadbde61d21801607ba5d5d0bed0e636ce8807af5c6d5b1e3c4c753842ab
diff --git a/dev-libs/appstream/appstream-1.0.0.ebuild b/dev-libs/appstream/appstream-1.0.0.ebuild
deleted file mode 100644
index ba6c4e52a5a4..000000000000
--- a/dev-libs/appstream/appstream-1.0.0.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit meson xdg-utils
-
-if [[ ${PV} == *9999* ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/ximion/${PN}"
-else
- MY_PN="AppStream"
- SRC_URI="https://www.freedesktop.org/software/appstream/releases/${MY_PN}-${PV}.tar.xz"
- KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
- S="${WORKDIR}/${MY_PN}-${PV}"
-fi
-
-DESCRIPTION="Cross-distro effort for providing metadata for software in the Linux ecosystem"
-HOMEPAGE="https://www.freedesktop.org/wiki/Distributions/AppStream/"
-
-LICENSE="LGPL-2.1+ GPL-2+"
-# check as_api_level
-SLOT="0/5"
-IUSE="apt doc +introspection qt6 systemd test"
-RESTRICT="test" # bug 691962
-
-RDEPEND="
- app-arch/zstd:=
- >=dev-libs/glib-2.62:2
- dev-libs/libxml2:2
- >=dev-libs/libxmlb-0.3.14:=
- dev-libs/libyaml
- dev-libs/snowball-stemmer:=
- >=net-misc/curl-7.62
- introspection? ( >=dev-libs/gobject-introspection-1.56:= )
- qt6? ( dev-qt/qtbase:6 )
- systemd? ( sys-apps/systemd:= )
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- dev-libs/appstream-glib
- dev-libs/libxslt
- dev-util/itstool
- >=sys-devel/gettext-0.19.8
- doc? ( app-text/docbook-xml-dtd:4.5 )
- test? ( dev-qt/qttools:6[linguist] )
-"
-
-PATCHES=( "${FILESDIR}"/${PN}-1.0.0-disable-Werror-flags.patch ) # bug 733774
-
-src_prepare() {
- default
- sed -e "/^as_doc_target_dir/s/appstream/${PF}/" -i docs/meson.build || die
- if ! use test; then
- sed -e "/^subdir.*tests/s/^/#DONT /" -i {,qt/}meson.build || die # bug 675944
- fi
-}
-
-src_configure() {
- xdg_environment_reset
-
- local emesonargs=(
- -Dapidocs=false
- -Ddocs=false
- -Dcompose=false
- -Dmaintainer=false
- -Dstatic-analysis=false
- -Dstemming=true
- -Dvapi=false
- -Dapt-support=$(usex apt true false)
- -Dinstall-docs=$(usex doc true false)
- -Dgir=$(usex introspection true false)
- -Dqt=$(usex qt6 true false)
- -Dsystemd=$(usex systemd true false)
- )
-
- meson_src_configure
-}
diff --git a/profiles/package.mask b/profiles/package.mask
index 9f60f7e42d95..c78cfe32f02d 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -265,7 +265,6 @@ dev-python/ruamel-std-pathlib
~kde-apps/libkexiv2-24.01.85
~kde-apps/spectacle-24.01.85
~kde-misc/kio-fuse-5.1.0
-~dev-libs/appstream-1.0.0
~dev-libs/appstream-1.0.1
~dev-libs/kdiagram-3.0.0
~dev-libs/kirigami-addons-0.11.76_p20231222