summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-22 17:17:02 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-22 17:17:02 +0200
commit8a2da7a2a9cbdf94ba0e7001d5605cd4416632b2 (patch)
tree45733046b536cc445c4eba7efee775329e6316bf
parentdev-ros/bondpy: Initial import. Ebuild by me. (diff)
downloadgentoo-8a2da7a2a9cbdf94ba0e7001d5605cd4416632b2.tar.gz
gentoo-8a2da7a2a9cbdf94ba0e7001d5605cd4416632b2.tar.bz2
gentoo-8a2da7a2a9cbdf94ba0e7001d5605cd4416632b2.zip
dev-ros/test_bond: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
-rw-r--r--dev-ros/test_bond/Manifest1
-rw-r--r--dev-ros/test_bond/metadata.xml5
-rw-r--r--dev-ros/test_bond/test_bond-1.7.16.ebuild24
-rw-r--r--dev-ros/test_bond/test_bond-9999.ebuild24
4 files changed, 54 insertions, 0 deletions
diff --git a/dev-ros/test_bond/Manifest b/dev-ros/test_bond/Manifest
new file mode 100644
index 000000000000..0d7a60a51eaa
--- /dev/null
+++ b/dev-ros/test_bond/Manifest
@@ -0,0 +1 @@
+DIST bond_core-1.7.16.tar.gz 25327 SHA256 177dc78ef9cf3cd9f48fe5aca4742f504956c71641c75048b7559af0e2aacd53 SHA512 1c35776782edfb7397845fde0ef3fcaac6179f1c55637fd5209303feb1755f13bff85e6cf36a2dd2671c18d5b433cb8e9ede04df923f742e22934b19d044e06e WHIRLPOOL 56fd05d2c6c8f5fb9fa8b47f2da939e16f79f39937febbf588137d5dd411c03f0c30edb3e70b50ed4c6b7c1ce8a0f1cd8c1922038c20495e62a57c80d0958864
diff --git a/dev-ros/test_bond/metadata.xml b/dev-ros/test_bond/metadata.xml
new file mode 100644
index 000000000000..c42ea5b15cf6
--- /dev/null
+++ b/dev-ros/test_bond/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>
diff --git a/dev-ros/test_bond/test_bond-1.7.16.ebuild b/dev-ros/test_bond/test_bond-1.7.16.ebuild
new file mode 100644
index 000000000000..9ea825ecc3f7
--- /dev/null
+++ b/dev-ros/test_bond/test_bond-1.7.16.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/bond_core"
+KEYWORDS="~amd64 ~arm"
+CATKIN_HAS_MESSAGES=yes
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Tests for bond, bondpy and bondcpp"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/bondcpp
+ dev-ros/bondpy[${PYTHON_USEDEP}]
+ dev-ros/rostest[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/test_bond/test_bond-9999.ebuild b/dev-ros/test_bond/test_bond-9999.ebuild
new file mode 100644
index 000000000000..9ea825ecc3f7
--- /dev/null
+++ b/dev-ros/test_bond/test_bond-9999.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/bond_core"
+KEYWORDS="~amd64 ~arm"
+CATKIN_HAS_MESSAGES=yes
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Tests for bond, bondpy and bondcpp"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/bondcpp
+ dev-ros/bondpy[${PYTHON_USEDEP}]
+ dev-ros/rostest[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"