summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-05 04:39:20 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-05 04:47:37 +0100
commit8a2fee9e26fc785e3b8c735012abdbebb2f67d09 (patch)
treefe65ff267300ab69f0adf2cf880d8cc08357b917
parentdev-python/linkify-it-py: Bump to 2.0.3 (diff)
downloadgentoo-8a2fee9e26fc785e3b8c735012abdbebb2f67d09.tar.gz
gentoo-8a2fee9e26fc785e3b8c735012abdbebb2f67d09.tar.bz2
gentoo-8a2fee9e26fc785e3b8c735012abdbebb2f67d09.zip
dev-python/path: Bump to 16.10.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/path/Manifest1
-rw-r--r--dev-python/path/path-16.10.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/path/Manifest b/dev-python/path/Manifest
index 0737215de8da..3f372545aca1 100644
--- a/dev-python/path/Manifest
+++ b/dev-python/path/Manifest
@@ -1 +1,2 @@
+DIST path-16.10.0.tar.gz 49271 BLAKE2B 36762e0b50d74b07db14ca01c6d94577f24b36c007eda58de4b63197cd91f869efbdc5ac1ceb270f1fc5e5a07c4c87f6cabd10cbac5fac74681f73451a3f73e1 SHA512 a5dfa964f5ffd4c2aa27733716b67437f02fd6dedc8c574bb87a9a3ac64eb60d27c3a05217aa4859293ebd96bdd17cdb1a04ea21c6ad35b7b22f05725826c057
DIST path-16.9.0.tar.gz 48850 BLAKE2B 0c5edc6538cb22543dd810a535840a235b66c51415284f00338bd1e84e63847d09235e55dd3d40a71f3b02f54d18cbbf4fa1e5a0356798cee3383666a26a441c SHA512 2d4c8e3923bc712c7901328a0406ce05c6c157664dfacb5a563a1b214ce561215398b31494865c99a77ed09c3ef63bb04a36d57a60e7c0e3dea05b1dacfdecf7
diff --git a/dev-python/path/path-16.10.0.ebuild b/dev-python/path/path-16.10.0.ebuild
new file mode 100644
index 000000000000..5346cd3c6d67
--- /dev/null
+++ b/dev-python/path/path-16.10.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A module wrapper for os.path"
+HOMEPAGE="
+ https://github.com/jaraco/path/
+ https://pypi.org/project/path/
+"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~x64-macos"
+
+RDEPEND="
+ dev-python/appdirs[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # unreliable, not really meaningful for end users
+ test_path.py::TestPerformance
+)