summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKristian Fiskerstrand <k_f@gentoo.org>2016-08-07 16:47:31 +0200
committerKristian Fiskerstrand <k_f@gentoo.org>2016-08-07 16:55:12 +0200
commit8a311ff7295d65c92ea69d21d33696c6e4c8dbb9 (patch)
tree9be6021846e56475228266724e2012882a7b8f0f
parentapp-emulation/qemu: Drop a -Werror when it could cause a false positive (diff)
downloadgentoo-8a311ff7295d65c92ea69d21d33696c6e4c8dbb9.tar.gz
gentoo-8a311ff7295d65c92ea69d21d33696c6e4c8dbb9.tar.bz2
gentoo-8a311ff7295d65c92ea69d21d33696c6e4c8dbb9.zip
net-misc/sks: Version bump to 1.1.6
Package-Manager: portage-2.3.0
-rw-r--r--net-misc/sks/Manifest1
-rw-r--r--net-misc/sks/sks-1.1.6.ebuild115
2 files changed, 116 insertions, 0 deletions
diff --git a/net-misc/sks/Manifest b/net-misc/sks/Manifest
index d751a70d1851..7d543a7072df 100644
--- a/net-misc/sks/Manifest
+++ b/net-misc/sks/Manifest
@@ -1 +1,2 @@
DIST sks-1.1.5.tgz 362941 SHA256 92a7f113f0ba7a28d51d7ced60a984d042d8524c651dc3fcafe9d11cc32981a0 SHA512 1fc1248281b4eb6bd0bafad7f3d1600ee86905614ee5c644d532059f972040c2673bee780a414e50e9287fc74fd140ac85db9629d502cff989981904acd3710c WHIRLPOOL 4281b40d72e7370b7c848d683beff2f4bd705a06139a25b27efe5be8a521df9fb870bdeeea97ac3617d542b64fd9c539f90d8f695cea1fec2bdcf267a2d3dc1f
+DIST sks-1.1.6.tgz 359499 SHA256 22312dbec6dfd372932075b0b0b1d04f772059a9520faa4937feafc737d5a632 SHA512 f7c54194274834840b9701bf827b81add0f807dd4c6019968a6b0c755c9117519433ebb1161da38d23c465b163dd31a766700023afa13174e4dc82542fa98099 WHIRLPOOL 85714515275c21821ff3bc429d00546f1f3b1cf6b8193edd1b26295ec07861ed1ed8b123deb811b6b915d761e977662398e7509581d8fe0e32d47ea6dd09388a
diff --git a/net-misc/sks/sks-1.1.6.ebuild b/net-misc/sks/sks-1.1.6.ebuild
new file mode 100644
index 000000000000..80ee291ae49f
--- /dev/null
+++ b/net-misc/sks/sks-1.1.6.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit multilib user readme.gentoo systemd
+
+DESCRIPTION="An OpenPGP keyserver which is decentralized with highly reliable synchronization"
+HOMEPAGE="https://bitbucket.org/skskeyserver/sks-keyserver"
+SRC_URI="https://bitbucket.org/skskeyserver/sks-keyserver/downloads/${P}.tgz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="optimize test"
+DOC_CONTENTS="To get sks running, first build the database,
+start the databse, import atleast one key, then
+run a cleandb. See the sks man page for more information
+Typical DB_CONFIG file and sksconf has been installed
+in /var/lib/sks and can be used as templates by renaming
+to remove the .typical extension. The DB_CONFIG file has
+to be in place before doing the database build, or the BDB
+environment has to be manually cleared from both KDB and PTree.
+The same applies if you are upgrading to this version with an existing KDB/Ptree,
+using another version of BDB than 4.8; you need to clear the environment
+using e.g. db4.6_recover -h . and db4.6_checkpoint -1h . in both KDB and PTree
+Additionally a sample web interface has been installed as
+web.typical in /var/lib/sks that can be used by renaming it to web
+Important: It is strongly recommended to set up SKS behind a
+reverse proxy. Instructions on properly configuring SKS can be
+found at https://bitbucket.org/skskeyserver/sks-keyserver/wiki/Peering"
+
+DEPEND=">=dev-lang/ocaml-4.0
+ dev-ml/camlp4
+ dev-ml/cryptokit
+ sys-libs/db:4.8"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ ebegin "Creating named group and user"
+ enewgroup sks
+ enewuser sks -1 -1 /var/lib/sks sks
+}
+
+src_prepare() {
+ cp Makefile.local.unused Makefile.local || die
+ sed -i \
+ -e "s:^BDBLIB=.*$:BDBLIB=-L/usr/$(get_libdir):g" \
+ -e "s:^BDBINCLUDE=.*$:BDBINCLUDE=-I/usr/include/db4.8/:g" \
+ -e "s:^LIBDB=.*$:LIBDB=-ldb-4.8:g" \
+ -e "s:^PREFIX=.*$:PREFIX=${D}/usr:g" \
+ -e "s:^MANDIR=.*$:MANDIR=${D}/usr/share/man:g" \
+ Makefile.local || die
+ sed -i \
+ -e 's:^CAMLINCLUDE= -I lib -I bdb$:CAMLINCLUDE= -I lib -I bdb -I +cryptokit:g' \
+ -e 's:-Werror-implicit-function-declaration::g' \
+ Makefile bdb/Makefile || die
+ sed -i \
+ -e 's:/usr/sbin/sks:/usr/bin/sks:g' \
+ sks_build.sh || die
+}
+
+src_compile() {
+ emake dep
+ # sks build fails with paralell build in module Bdb
+ emake -j1 all
+ if use optimize; then
+ emake all.bc
+ fi
+}
+
+src_test() {
+ ./sks unit_test || die
+}
+
+src_install() {
+ if use optimize; then
+ emake install.bc
+ dosym /usr/bin/sks.bc usr/bin/sks
+ dosym /usr/bin/sks_add_mail.bc usr/bin/sks_add_mail
+ else
+ emake install
+ fi
+
+ dodoc README.md
+
+ newinitd "${FILESDIR}/sks-db.initd" sks-db
+ newinitd "${FILESDIR}/sks-recon.initd" sks-recon
+ newconfd "${FILESDIR}/sks.confd" sks
+ systemd_dounit "${FILESDIR}"/sks-db.service
+ systemd_dounit "${FILESDIR}"/sks-recon.service
+
+ dodir "/var/lib/sks/web.typical"
+ insinto /var/lib/sks
+ newins sampleConfig/DB_CONFIG DB_CONFIG.typical
+ newins sampleConfig/sksconf.typical sksconf.typical
+ insinto /var/lib/sks/web.typical
+ doins sampleWeb/HTML5/*
+
+ keepdir /var/lib/sks
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+
+ if [[ -n ${REPLACING_VERSIONS} ]]; then
+ einfo "Note when upgrading from versions of SKS earlier than 1.1.4"
+ einfo "The default values for pagesize settings have changed. To continue"
+ einfo "using an existing DB without rebuilding, explicit settings have to be"
+ einfo "added to the sksconf file."
+ einfo "pagesize: 4"
+ einfo "ptree_pagesize: 1"
+ fi;
+}