summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2021-07-13 01:16:00 +0200
committerThomas Deutschmann <whissi@gentoo.org>2021-07-13 01:31:52 +0200
commit8a3b0f3b569543a5d356973cb3fcea0ca280e5e7 (patch)
tree58f52fc10649fb7afe29c4a719482f99a5e2bad5
parentwww-client/firefox: downgrading ewarn to einfo in llvm_check_deps (diff)
downloadgentoo-8a3b0f3b.tar.gz
gentoo-8a3b0f3b.tar.bz2
gentoo-8a3b0f3b.zip
www-client/firefox: check for SECCOMP support in kernel
Bug: https://bugs.gentoo.org/790398 Package-Manager: Portage-3.0.21, Repoman-3.0.3 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
-rw-r--r--www-client/firefox/firefox-78.12.0.ebuild8
-rw-r--r--www-client/firefox/firefox-90.0.ebuild8
2 files changed, 12 insertions, 4 deletions
diff --git a/www-client/firefox/firefox-78.12.0.ebuild b/www-client/firefox/firefox-78.12.0.ebuild
index 36a8533d36ed..3e0e8d7fc1ea 100644
--- a/www-client/firefox/firefox-78.12.0.ebuild
+++ b/www-client/firefox/firefox-78.12.0.ebuild
@@ -37,8 +37,8 @@ MOZ_P="${MOZ_PN}-${MOZ_PV}"
MOZ_PV_DISTFILES="${MOZ_PV}${MOZ_PV_SUFFIX}"
MOZ_P_DISTFILES="${MOZ_PN}-${MOZ_PV_DISTFILES}"
-inherit autotools check-reqs desktop flag-o-matic gnome2-utils llvm \
- multiprocessing pax-utils python-any-r1 toolchain-funcs \
+inherit autotools check-reqs desktop flag-o-matic gnome2-utils linux-info \
+ llvm multiprocessing pax-utils python-any-r1 toolchain-funcs \
virtualx xdg
MOZ_SRC_BASE_URI="https://archive.mozilla.org/pub/${MOZ_PN}/releases/${MOZ_PV}"
@@ -475,6 +475,10 @@ pkg_setup() {
# Ensure we use C locale when building, bug #746215
export LC_ALL=C
fi
+
+ CONFIG_CHECK="~SECCOMP"
+ WARNING_SECCOMP="CONFIG_SECCOMP not set! This system will be unable to play DRM-protected content."
+ linux-info_pkg_setup
}
src_unpack() {
diff --git a/www-client/firefox/firefox-90.0.ebuild b/www-client/firefox/firefox-90.0.ebuild
index 9ecfb11e4d5e..b2acecd2054c 100644
--- a/www-client/firefox/firefox-90.0.ebuild
+++ b/www-client/firefox/firefox-90.0.ebuild
@@ -37,8 +37,8 @@ MOZ_P="${MOZ_PN}-${MOZ_PV}"
MOZ_PV_DISTFILES="${MOZ_PV}${MOZ_PV_SUFFIX}"
MOZ_P_DISTFILES="${MOZ_PN}-${MOZ_PV_DISTFILES}"
-inherit autotools check-reqs desktop flag-o-matic gnome2-utils llvm \
- multiprocessing pax-utils python-any-r1 toolchain-funcs \
+inherit autotools check-reqs desktop flag-o-matic gnome2-utils linux-info \
+ llvm multiprocessing pax-utils python-any-r1 toolchain-funcs \
virtualx xdg
MOZ_SRC_BASE_URI="https://archive.mozilla.org/pub/${MOZ_PN}/releases/${MOZ_PV}"
@@ -474,6 +474,10 @@ pkg_setup() {
# Ensure we use C locale when building, bug #746215
export LC_ALL=C
fi
+
+ CONFIG_CHECK="~SECCOMP"
+ WARNING_SECCOMP="CONFIG_SECCOMP not set! This system will be unable to play DRM-protected content."
+ linux-info_pkg_setup
}
src_unpack() {