summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Schuerch <nativemad@gentoo.org>2022-06-24 11:32:13 +0200
committerAndreas Schuerch <nativemad@gentoo.org>2022-06-25 11:02:41 +0200
commit8a5a743db0744a96d1eb0f79a6d2ae0b14a91371 (patch)
treec99a5a7aef64bf7b06073c277e48ca14f27dd96a
parentnet-libs/nghttp2: x86 stable wrt bug #854057 (diff)
downloadgentoo-8a5a743db0744a96d1eb0f79a6d2ae0b14a91371.tar.gz
gentoo-8a5a743db0744a96d1eb0f79a6d2ae0b14a91371.tar.bz2
gentoo-8a5a743db0744a96d1eb0f79a6d2ae0b14a91371.zip
net-dns/dnsdist: add 1.7.2
Signed-off-by: Andreas Schuerch <nativemad@gentoo.org>
-rw-r--r--net-dns/dnsdist/Manifest1
-rw-r--r--net-dns/dnsdist/dnsdist-1.7.2.ebuild84
2 files changed, 85 insertions, 0 deletions
diff --git a/net-dns/dnsdist/Manifest b/net-dns/dnsdist/Manifest
index f53ad9476dcf..8f59268f9465 100644
--- a/net-dns/dnsdist/Manifest
+++ b/net-dns/dnsdist/Manifest
@@ -3,3 +3,4 @@ DIST dnsdist-1.6.0.tar.bz2 1328707 BLAKE2B d093142875882cacaa456d76d42e703e45577
DIST dnsdist-1.6.1.tar.bz2 1328069 BLAKE2B a9e9c0cb35ebc2ecd93d7fa0d6d3961b02d711da2df56240335786a5d2e529d4a7e8716f578b6e935edd3bc79dfed767d358b9feaff32dd9cd65993ef0b97b71 SHA512 68e114eeb1a7ae8a4ce52a7de31095c46d0ba8f572676a8ef1e858b97da199c04ec88656c7642160ba07b7db325cc2a49cd91794da8dd2e81a5301d089c34f90
DIST dnsdist-1.7.0.tar.bz2 1392585 BLAKE2B 3766da5f63df6390f555307d665efcbb2ad1462abae3af44503479d4c6ae6453e43527d2bcac718fabeb8b60ec989f264860532b480c465afc440405f9efac74 SHA512 abaed7aaa18f4acaf220dc938da6896e521373b1da3b6b9c4114467dd5d8b0e6cd9809534edbc6ba5b789ed8387fb47317c47bd4e00e66a6ccb035f6dd6068af
DIST dnsdist-1.7.1.tar.bz2 1392179 BLAKE2B 48189da6bceb1723b19bab7c42ec8cd834f3ef6d822b5da23fe2f4e02ec825d1566bce472f522fa9ac0b027d36f3089ce7c0c7eb1c7e1161c050dc50305dfdb6 SHA512 eee44a9994c6cab84977cad58539ca59882149d6898dfeed9e4190f06ddbc280b836bf426d22e6980d8acae1437290bddcc5166af165b6eb48c77c669281a310
+DIST dnsdist-1.7.2.tar.bz2 1391588 BLAKE2B cf2a9853be4c896b3909f871fad771d4298eb2586702a8a85eff2c612d275214cdad82e93961f4cfd58300f5629f06569c51a2c4f15de58188a69116bd5275de SHA512 2048ac0f861547fb103da1a128fd39a35ed689ccbf3c080232a3bd0550c9e7c7e01c95864d61e065e341a9f4111c974d2db2aba73eb8f7cba9bf8273da39b8a6
diff --git a/net-dns/dnsdist/dnsdist-1.7.2.ebuild b/net-dns/dnsdist/dnsdist-1.7.2.ebuild
new file mode 100644
index 000000000000..99404bcecece
--- /dev/null
+++ b/net-dns/dnsdist/dnsdist-1.7.2.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+
+inherit flag-o-matic lua-single
+
+DESCRIPTION="A highly DNS-, DoS- and abuse-aware loadbalancer"
+HOMEPAGE="https://dnsdist.org"
+
+SRC_URI="https://downloads.powerdns.com/releases/${P}.tar.bz2"
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="dnscrypt dnstap doh gnutls +lmdb regex remote-logging snmp +ssl systemd test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="${LUA_REQUIRED_USE}
+ dnscrypt? ( ssl )
+ gnutls? ( ssl )
+ doh? ( ssl !gnutls )"
+
+RDEPEND="acct-group/dnsdist
+ acct-user/dnsdist
+ >=dev-libs/boost-1.35:=
+ dev-libs/libedit:=
+ >=dev-libs/protobuf-3:=
+ dnscrypt? ( dev-libs/libsodium:= )
+ dnstap? ( dev-libs/fstrm:= )
+ doh? ( www-servers/h2o:=[libh2o] )
+ lmdb? ( dev-db/lmdb:= )
+ regex? ( dev-libs/re2:= )
+ snmp? ( net-analyzer/net-snmp:= )
+ ssl? (
+ gnutls? ( net-libs/gnutls:= )
+ !gnutls? ( dev-libs/openssl:= )
+ )
+ systemd? ( sys-apps/systemd:0= )
+ ${LUA_DEPS}
+ net-libs/nghttp2
+"
+
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ # bug #822855
+ append-lfs-flags
+
+ econf \
+ --sysconfdir=/etc/dnsdist \
+ --with-lua="${ELUA}" \
+ $(use_enable doh dns-over-https) \
+ $(use_enable dnscrypt) \
+ $(use_enable dnstap) \
+ $(use_with lmdb ) \
+ $(use_with regex re2) \
+ $(use_with snmp net-snmp) \
+ $(use ssl && { echo "--enable-dns-over-tls" && use_with gnutls && use_with !gnutls libssl;} || echo "--without-gnutls --without-libssl") \
+ $(use_enable systemd) \
+ $(use_enable test unit-tests)
+ sed 's/hardcode_libdir_flag_spec_CXX='\''$wl-rpath $wl$libdir'\''/hardcode_libdir_flag_spec_CXX='\''$wl-rpath $wl\/$libdir'\''/g' \
+ -i "${S}/configure"
+}
+
+src_install() {
+ default
+
+ insinto /etc/dnsdist
+ doins "${FILESDIR}"/dnsdist.conf.example
+
+ newconfd "${FILESDIR}"/dnsdist.confd ${PN}
+ newinitd "${FILESDIR}"/dnsdist.initd ${PN}
+}
+
+pkg_postinst() {
+ elog "dnsdist provides multiple instances support. You can create more instances"
+ elog "by symlinking the dnsdist init script to another name."
+ elog
+ elog "The name must be in the format dnsdist.<suffix> and dnsdist will use the"
+ elog "/etc/dnsdist/dnsdist-<suffix>.conf configuration file instead of the default."
+}