summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2022-07-07 11:08:15 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2022-07-07 11:10:07 -0500
commit8a73c962e5bc4775fcb67e732eebb15468fa7aa6 (patch)
tree2c7650e1ba5019ce94024505072ba645d34a298c
parentapp-crypt/certbot: 1.29.0 stable amd64/x86 (diff)
downloadgentoo-8a73c962.tar.gz
gentoo-8a73c962.tar.bz2
gentoo-8a73c962.zip
app-crypt/certbot-apache: 1.29.0 bump
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
-rw-r--r--app-crypt/certbot-apache/Manifest1
-rw-r--r--app-crypt/certbot-apache/certbot-apache-1.29.0.ebuild33
-rw-r--r--app-crypt/certbot-apache/certbot-apache-9999.ebuild4
3 files changed, 36 insertions, 2 deletions
diff --git a/app-crypt/certbot-apache/Manifest b/app-crypt/certbot-apache/Manifest
index 8476da658e84..8bbdc6f80c7f 100644
--- a/app-crypt/certbot-apache/Manifest
+++ b/app-crypt/certbot-apache/Manifest
@@ -1,2 +1,3 @@
DIST certbot-1.27.0.tar.gz 1366469 BLAKE2B e9ec47520e027a9d348e861ea7d070eff4857301be0d42be6965e4159d85ef60866aa70de76edd5e68b0d40d9544075aa28e9aa07a8e04dfbf3e1a7dd77fd1de SHA512 5db7836ae2eda27c088476c149e736ce7f41b85d871cf563c69e021dd8af2d64ed85c1482049edf0dffe6fd0c9591d66be3e22fbf617068600e12691c4802e5e
DIST certbot-1.28.0.tar.gz 1367671 BLAKE2B 01fda6c068217e32273b2c1ac97faa099f98da687d41796e1c98971ed6779ab4ff78e3309b7a6f82b9b0a891c5f00b5201bb3ce1bc879e5acbab3ccc4988ec31 SHA512 888f51dfcf4712b70ce7c99abfc52106384dcba2eef486db8b033bfcca3043bd0beaadce1c1e59f19c3a58b7fe454b2b64774de2e23f5d93579b3e1be1a7c08b
+DIST certbot-1.29.0.tar.gz 1367853 BLAKE2B c0d8d2c05a061b2d50564a97bf17ae883bd443321bf99cea13fbae196c7ec876231d803d5389e524997dd8632035d5ad60b1a99b025a22a65d0865d564cfafc5 SHA512 755781e12e0e4cdb41aa16d90ab6a334ef41a98630e08127a867c8e8813ee45ebd3f6f54168fe747900f6ab59539e414ffed7891c05746b3a7af2e2a96a8d522
diff --git a/app-crypt/certbot-apache/certbot-apache-1.29.0.ebuild b/app-crypt/certbot-apache/certbot-apache-1.29.0.ebuild
new file mode 100644
index 000000000000..4a5e9753518c
--- /dev/null
+++ b/app-crypt/certbot-apache/certbot-apache-1.29.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ inherit git-r3
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/${PN%-apache}/${PN%-apache}/archive/v${PV}.tar.gz -> ${PN%-apache}-${PV}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+ S=${WORKDIR}/${PN%-apache}-${PV}/${PN}
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="Apache plugin for certbot (Let's Encrypt Client)"
+HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+RDEPEND=">=app-crypt/acme-${PV}[${PYTHON_USEDEP}]
+ >=app-crypt/certbot-${PV}[${PYTHON_USEDEP}]
+ dev-python/python-augeas[${PYTHON_USEDEP}]
+ dev-python/zope-component[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
diff --git a/app-crypt/certbot-apache/certbot-apache-9999.ebuild b/app-crypt/certbot-apache/certbot-apache-9999.ebuild
index b46b10fa3536..4a5e9753518c 100644
--- a/app-crypt/certbot-apache/certbot-apache-9999.ebuild
+++ b/app-crypt/certbot-apache/certbot-apache-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
PYTHON_COMPAT=( python3_{8..10} )
DISTUTILS_USE_SETUPTOOLS=rdepend