summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-09-06 22:33:21 +0200
committerMichał Górny <mgorny@gentoo.org>2022-09-06 22:33:21 +0200
commit8a79d35b8789770ff1da60f4a816d73086a2e297 (patch)
treea5670575ed134565920bce55c9475d1f1d135163
parentdev-python/bottle: Remove old (diff)
downloadgentoo-8a79d35b8789770ff1da60f4a816d73086a2e297.tar.gz
gentoo-8a79d35b8789770ff1da60f4a816d73086a2e297.tar.bz2
gentoo-8a79d35b8789770ff1da60f4a816d73086a2e297.zip
dev-python/flask: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/flask/Manifest1
-rw-r--r--dev-python/flask/flask-2.1.3.ebuild63
2 files changed, 0 insertions, 64 deletions
diff --git a/dev-python/flask/Manifest b/dev-python/flask/Manifest
index 608d2d03566f..18ae453b4afc 100644
--- a/dev-python/flask/Manifest
+++ b/dev-python/flask/Manifest
@@ -1,3 +1,2 @@
-DIST Flask-2.1.3.tar.gz 630206 BLAKE2B 83c876fe94d2cb1b35677227214664b35b6908270097d3ef0e1150a7259cdce82fb91fa6ba7cc90e819623bb9cc79f8254cc5688c6dd1e1dedaa673f23591bfb SHA512 6289bcaa295265c501fda1292b496911768525acf4155c856e14479a213aec4ca50a45ddd81b30ccd31fd684da1942ec10400f2dc8280ceff6ded9baf55494e5
DIST Flask-2.2.1.tar.gz 687433 BLAKE2B 9d5fbc6827110882c64102f596b1d272bf5b16fd5540eedf0bad52f4456b54c3ab53e474ec74bb0e7d3cc7cfc26a22d19fd908d0973b94e64b47ee3a66c5a4e6 SHA512 845857cd6441e935a5274f362708c1e84654f757b0412bb57dd1235943d1d0562b081b53e77920ab9891bbe6810a06f7564e828cda472844413f7a1249335d1a
DIST Flask-2.2.2.tar.gz 677389 BLAKE2B a7385c619dee7c25538a69bc514393c6efa2ee3cbd8394cde28c64a41d7252b4f12896728bf76a4b8bf5247cf19614bd9b8f94d7d82f22a6a8073011286758fc SHA512 d330398829cb0393e07a4dcf495a3939f0e8f7962c0a517fc866d333425dffe1ce8fd26e39a40445259028d46eff4566e97b3f5eba0d6bddf14b9d7bac138945
diff --git a/dev-python/flask/flask-2.1.3.ebuild b/dev-python/flask/flask-2.1.3.ebuild
deleted file mode 100644
index 48df9fe3e438..000000000000
--- a/dev-python/flask/flask-2.1.3.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="A microframework based on Werkzeug, Jinja2 and good intentions"
-HOMEPAGE="
- https://palletsprojects.com/p/flask/
- https://github.com/pallets/flask/
- https://pypi.org/project/Flask/
-"
-MY_PN="Flask"
-MY_P="${MY_PN}-${PV}"
-if [[ ${PV} == *9999* ]]; then
- EGIT_REPO_URI="https://github.com/mitsuhiko/flask.git"
- inherit git-r3
-else
- SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
- KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"
- S="${WORKDIR}/${MY_P}"
-fi
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="examples"
-
-RDEPEND="
- >=dev-python/click-8.0[${PYTHON_USEDEP}]
- dev-python/blinker[${PYTHON_USEDEP}]
- >=dev-python/itsdangerous-2.0[${PYTHON_USEDEP}]
- >=dev-python/jinja-3.0[${PYTHON_USEDEP}]
- >=dev-python/werkzeug-2.0[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- >=dev-python/importlib_metadata-3.6.0[${PYTHON_USEDEP}]
- ' 3.8 3.9)
-"
-BDEPEND="
- test? (
- >=dev-python/asgiref-3.2[${PYTHON_USEDEP}]
- !!dev-python/shiboken2
- )
-"
-
-distutils_enable_sphinx docs \
- dev-python/pallets-sphinx-themes \
- dev-python/sphinx-issues \
- dev-python/sphinx-tabs \
- dev-python/sphinxcontrib-log_cabinet
-distutils_enable_tests pytest
-
-python_test() {
- epytest -p no:httpbin
-}
-
-python_install_all() {
- use examples && dodoc -r examples
- distutils-r1_python_install_all
-}