summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-08-23 21:42:21 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-08-24 00:14:29 +0200
commit8a7bf39761bcaa41cdf5b066af497f0e614c26b0 (patch)
treef3a41d18d0c19f9d7bae46d3185f81494123e933
parentgames-util/cartridges: drop old 1.5.6 (diff)
downloadgentoo-8a7bf39761bcaa41cdf5b066af497f0e614c26b0.tar.gz
gentoo-8a7bf39761bcaa41cdf5b066af497f0e614c26b0.tar.bz2
gentoo-8a7bf39761bcaa41cdf5b066af497f0e614c26b0.zip
games-util/cartridges: bump to 2.2.1
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--games-util/cartridges/Manifest1
-rw-r--r--games-util/cartridges/cartridges-2.2.1.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/games-util/cartridges/Manifest b/games-util/cartridges/Manifest
index 6892b188ab65..713354ff4af8 100644
--- a/games-util/cartridges/Manifest
+++ b/games-util/cartridges/Manifest
@@ -1,2 +1,3 @@
DIST cartridges-2.0.4.tar.gz 1332584 BLAKE2B 07cd5f19ad74c169cd1a98136920fc8f10fda001f1cde93f26fd0a77e556f0406995efc07b54722571f468983b9af53d7db2ce95e434d91f7e10a7b5855d1b46 SHA512 892be1a587aa7ad4baed457069fdf7019472bcf0d7acf301e8aca96719ebe259f59989fc966cb32376326273406ac688a51e95bd395b5de7b63c85c031dcf15a
DIST cartridges-2.1.1.tar.gz 1337163 BLAKE2B 6d4a67d8d6ecc035e6b3b12a7d5c9160de2af46423264c670bb7e448d00393a6dc7742ab30047eaa888689d9ad0eb5baf9657523164761cff3b71d4b23a9d551 SHA512 0963e2e5183a8cbb8c1de1fbbf9f67beda65eb7396aaf644fcc30ed79a3dd8136e5e78d3a5b065c9b6f2a4cba4e3c715e412f1cc651a555195d9af5cc6f1e22b
+DIST cartridges-2.2.1.tar.gz 1277149 BLAKE2B 5295253e8347254905b7911a8fc9bab44b953dbed90a9d7211eef651317bd38e6d04a7218cb4c418a7af5223bc53789e866c688cc85239b922d54722a9c055bc SHA512 f2e0ed8ef9f916cf0cdf1e1134286d1242948291b24cf6103c2171a232c97c05c3260aeb307f6cfaee6d78a473151440f2e0854bcb1ccaf1f854952b8a50a2c6
diff --git a/games-util/cartridges/cartridges-2.2.1.ebuild b/games-util/cartridges/cartridges-2.2.1.ebuild
new file mode 100644
index 000000000000..05c8ac27f772
--- /dev/null
+++ b/games-util/cartridges/cartridges-2.2.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit gnome2-utils meson python-single-r1 xdg
+
+DESCRIPTION="Simple game launcher written in Python using GTK4 and Libadwaita"
+HOMEPAGE="https://github.com/kra-mo/cartridges/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/kra-mo/${PN}.git"
+else
+ SRC_URI="https://github.com/kra-mo/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ gui-libs/gtk:4[introspection]
+ gui-libs/libadwaita:1[introspection]
+ $(python_gen_cond_dep '
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-libs/appstream-glib
+ dev-util/blueprint-compiler
+ dev-util/desktop-file-utils
+"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.5.4-dont-validate-appstream.patch )
+
+src_install() {
+ meson_src_install
+
+ python_fix_shebang "${ED}"/usr/bin
+ python_optimize "${ED}"/usr/share/cartridges/cartridges
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ xdg_pkg_postinst
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+ xdg_pkg_postrm
+}