summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2023-01-31 09:47:51 -0500
committerCraig Andrews <candrews@gentoo.org>2023-01-31 09:48:33 -0500
commit8a7f4c0e95f78caa6f64babb88a07e0f536d4d93 (patch)
treea9f03ce543b33d67637a84f943e0f4febf730287
parentmail-mta/postfix: add 3.8_pre20230128, drop 3.8_pre20230121 (diff)
downloadgentoo-8a7f4c0e.tar.gz
gentoo-8a7f4c0e.tar.bz2
gentoo-8a7f4c0e.zip
net-libs/ngtcp2: Add static-libs USE flag
Closes: https://bugs.gentoo.org/892734 Signed-off-by: Craig Andrews <candrews@gentoo.org>
-rw-r--r--net-libs/ngtcp2/ngtcp2-0.13.0-r1.ebuild52
-rw-r--r--net-libs/ngtcp2/ngtcp2-9999.ebuild3
2 files changed, 54 insertions, 1 deletions
diff --git a/net-libs/ngtcp2/ngtcp2-0.13.0-r1.ebuild b/net-libs/ngtcp2/ngtcp2-0.13.0-r1.ebuild
new file mode 100644
index 000000000000..47638e878cea
--- /dev/null
+++ b/net-libs/ngtcp2/ngtcp2-0.13.0-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/ngtcp2/ngtcp2.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/ngtcp2/ngtcp2/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~hppa ~riscv ~x86"
+fi
+
+DESCRIPTION="Implementation of the IETF QUIC Protocol"
+HOMEPAGE="https://github.com/ngtcp2/ngtcp2/"
+
+LICENSE="MIT"
+SLOT="0/0"
+IUSE="+gnutls openssl +ssl test"
+REQUIRED_USE="ssl? ( || ( gnutls openssl ) )"
+
+BDEPEND="virtual/pkgconfig"
+RDEPEND="
+ ssl? (
+ gnutls? ( >=net-libs/gnutls-3.7.2:0= )
+ openssl? (
+ >=dev-libs/openssl-1.1.1:0=
+ )
+ )"
+DEPEND="${RDEPEND}
+ test? ( >=dev-util/cunit-2.1[${MULTILIB_USEDEP}] )"
+RESTRICT="!test? ( test )"
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DENABLE_STATIC_LIB=$(usex static-libs)
+ -DENABLE_GNUTLS=$(usex gnutls)
+ -DENABLE_OPENSSL=$(usex openssl)
+ -DENABLE_BORINGSSL=OFF
+ -DENABLE_PICOTLS=OFF
+ -DENABLE_WOLFSSL=OFF
+ -DCMAKE_DISABLE_FIND_PACKAGE_Libev=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_Libnghttp3=ON
+ )
+ cmake_src_configure
+}
+
+multilib_src_test() {
+ cmake_build check
+}
diff --git a/net-libs/ngtcp2/ngtcp2-9999.ebuild b/net-libs/ngtcp2/ngtcp2-9999.ebuild
index b46e1455bcb4..47638e878cea 100644
--- a/net-libs/ngtcp2/ngtcp2-9999.ebuild
+++ b/net-libs/ngtcp2/ngtcp2-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -35,6 +35,7 @@ RESTRICT="!test? ( test )"
multilib_src_configure() {
local mycmakeargs=(
+ -DENABLE_STATIC_LIB=$(usex static-libs)
-DENABLE_GNUTLS=$(usex gnutls)
-DENABLE_OPENSSL=$(usex openssl)
-DENABLE_BORINGSSL=OFF