summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-06 07:23:59 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-06 07:26:52 +0200
commit8a86ba0e639521efb16784e1f3e07484d9321717 (patch)
tree6cfb54a58c4406311bf6aa5309542a05f9130b14
parentdev-python/django-cors-headers: Bump to 3.13.0 (diff)
downloadgentoo-8a86ba0e639521efb16784e1f3e07484d9321717.tar.gz
gentoo-8a86ba0e639521efb16784e1f3e07484d9321717.tar.bz2
gentoo-8a86ba0e639521efb16784e1f3e07484d9321717.zip
dev-python/pyxdg: Bump to 0.28
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pyxdg/Manifest1
-rw-r--r--dev-python/pyxdg/metadata.xml2
-rw-r--r--dev-python/pyxdg/pyxdg-0.28.ebuild28
3 files changed, 30 insertions, 1 deletions
diff --git a/dev-python/pyxdg/Manifest b/dev-python/pyxdg/Manifest
index f50d9b96884d..4fa27a428f10 100644
--- a/dev-python/pyxdg/Manifest
+++ b/dev-python/pyxdg/Manifest
@@ -1 +1,2 @@
DIST pyxdg-rel-0.27.tar.gz 75385 BLAKE2B 44c275ad7f698ffea6963f67bdce46e4faed5c7ae7f6a5aeb03f31dba6358c07263ea826458982cc4f88c0e163c2732f5b498a8d38b5881433e5321cfb181ac6 SHA512 fa3b046ce741574a6c71ef9d1e57752f6c9775431110f6ea38dc851780b5e1f9033eabeb15c67c91bc9bef68bf8f545a25ef856c60e16ab2c4fcbbb053d8341e
+DIST pyxdg-rel-0.28.gh.tar.gz 75755 BLAKE2B ba6d0dd956b13b7722d48f3d8a4ffa73b17efd6b4db3e73f521de72338dfacf11301449445bc911657f45de1c849c6425a24e5523f67116d96c7f38aa7bf320b SHA512 e1a7c8675afa109495e3530d9acc59a17368723b03ff66ee502133fd383bbe11c9908d93b18fdad3b589d47225ff8bf6bb8cacc800b1c1f39059e1178dafc1b5
diff --git a/dev-python/pyxdg/metadata.xml b/dev-python/pyxdg/metadata.xml
index 04ac42b9b8d2..7bcc4753878b 100644
--- a/dev-python/pyxdg/metadata.xml
+++ b/dev-python/pyxdg/metadata.xml
@@ -7,7 +7,7 @@
</maintainer>
<stabilize-allarches/>
<upstream>
- <doc lang="en">https://pyxdg.readthedocs.org/en/latest/</doc>
+ <doc lang="en">https://pyxdg.readthedocs.io/en/latest/</doc>
<bugs-to>https://bugs.freedesktop.org/</bugs-to>
<remote-id type="pypi">pyxdg</remote-id>
<remote-id type="launchpad">pyxdg</remote-id>
diff --git a/dev-python/pyxdg/pyxdg-0.28.ebuild b/dev-python/pyxdg/pyxdg-0.28.ebuild
new file mode 100644
index 000000000000..3a32f58fe79a
--- /dev/null
+++ b/dev-python/pyxdg/pyxdg-0.28.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+MY_P="${PN}-rel-${PV}"
+DESCRIPTION="A Python module to deal with freedesktop.org specifications"
+HOMEPAGE="
+ https://freedesktop.org/wiki/Software/pyxdg/
+ https://cgit.freedesktop.org/xdg/pyxdg/
+ https://pypi.org/project/pyxdg/
+"
+SRC_URI="
+ https://github.com/takluyver/pyxdg/archive/rel-${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+distutils_enable_tests pytest