summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormatoro <matoro@users.noreply.github.com>2022-06-15 00:25:03 -0400
committerMatt Turner <mattst88@gentoo.org>2022-10-22 17:33:10 -0400
commit8a8e1ef39ebeb9c7c3679ae4bb54987b5f040bf1 (patch)
tree0ccad2542593e411811d21bf2de34685466946df
parentdev-ruby/async-container: new package, add 0.16.12 (diff)
downloadgentoo-8a8e1ef39ebeb9c7c3679ae4bb54987b5f040bf1.tar.gz
gentoo-8a8e1ef39ebeb9c7c3679ae4bb54987b5f040bf1.tar.bz2
gentoo-8a8e1ef39ebeb9c7c3679ae4bb54987b5f040bf1.zip
dev-ruby/async-io: new package, add 1.33.0
Signed-off-by: matoro <matoro@users.noreply.github.com> Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--dev-ruby/async-io/Manifest1
-rw-r--r--dev-ruby/async-io/async-io-1.33.0.ebuild32
-rw-r--r--dev-ruby/async-io/metadata.xml11
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-ruby/async-io/Manifest b/dev-ruby/async-io/Manifest
new file mode 100644
index 000000000000..6c335c81e8b1
--- /dev/null
+++ b/dev-ruby/async-io/Manifest
@@ -0,0 +1 @@
+DIST async-io-1.33.0.tar.gz 33901 BLAKE2B 0331cbfd70e504b2ffe213d2b5b5593e713db449af6c450522bd8d7f4ec2ba567706b52f2d819b7b4622128b16090197f2d2e36ad815af0b6c353c65c0144dcc SHA512 5c70179df163952754bcdd506e13d83f1b039d434e7c6c692ead80f0efebc1ffd17e47c9cf53fe6d29bfd452551098bf31d8a463ed212d54a4910eef93fac6b7
diff --git a/dev-ruby/async-io/async-io-1.33.0.ebuild b/dev-ruby/async-io/async-io-1.33.0.ebuild
new file mode 100644
index 000000000000..75b432695d8b
--- /dev/null
+++ b/dev-ruby/async-io/async-io-1.33.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby26 ruby27 ruby30 ruby31"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_EXTRA_DOC="README.md"
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+inherit ruby-fakegem
+
+DESCRIPTION="Provides support for asynchonous TCP, UDP, UNIX and SSL sockets"
+HOMEPAGE="https://github.com/socketry/async-io"
+SRC_URI="https://github.com/socketry/async-io/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~sparc"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/async"
+
+ruby_add_bdepend "test? (
+ >=dev-ruby/async-container-0.15:0
+ >=dev-ruby/async-rspec-1.10:1
+ dev-ruby/rack-test
+)"
+
+all_ruby_prepare() {
+ sed -i -E 's/require_relative "(.+)"/require File.expand_path("\1")/g' "${RUBY_FAKEGEM_GEMSPEC}" || die
+ sed -i -E 's/require '"'"'covered\/rspec'"'"'//g' "spec/spec_helper.rb" || die
+}
diff --git a/dev-ruby/async-io/metadata.xml b/dev-ruby/async-io/metadata.xml
new file mode 100644
index 000000000000..2b591f89a8e8
--- /dev/null
+++ b/dev-ruby/async-io/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">socketry/async-io</remote-id>
+ </upstream>
+</pkgmetadata>