summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-04-04 00:04:22 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-04-04 00:04:36 +0200
commit8a91e3d56901b0b2fe6deabd17e1a69acd508779 (patch)
treee5f90816875c313d9271172e93f5b1c0da6c963d
parentsci-electronics/kicad: Remove old (diff)
downloadgentoo-8a91e3d56901b0b2fe6deabd17e1a69acd508779.tar.gz
gentoo-8a91e3d56901b0b2fe6deabd17e1a69acd508779.tar.bz2
gentoo-8a91e3d56901b0b2fe6deabd17e1a69acd508779.zip
app-admin/newsyslog: EAPI 6 bump.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--app-admin/newsyslog/newsyslog-1.1-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-admin/newsyslog/newsyslog-1.1-r1.ebuild b/app-admin/newsyslog/newsyslog-1.1-r1.ebuild
new file mode 100644
index 000000000000..5f5290e27ad2
--- /dev/null
+++ b/app-admin/newsyslog/newsyslog-1.1-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+#inherit eutils
+
+DESCRIPTION="a highly configurable program for managing and archiving log files"
+HOMEPAGE="http://www.weird.com/~woods/projects/newsyslog.html"
+SRC_URI="ftp://ftp.weird.com/pub/local/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND="sys-apps/groff"
+
+RDEPEND="
+ virtual/cron
+ app-arch/gzip"
+
+PATCHES=( "${FILESDIR}"/newsyslog-html.patch )
+
+DOCS=( newsyslog.conf AUTHORS ChangeLog INSTALL NEWS ToDo )
+
+src_configure() {
+ local myconf="--with-syslogd_pid=/var/run/syslog.pid"
+
+ has_version 'app-admin/syslog-ng' \
+ && myconf="--with-syslogd_pid=/var/run/syslog-ng.pid"
+
+ econf \
+ --with-gzip \
+ --with-newsyslog_conf=/etc/newsyslog.conf \
+ ${myconf}
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ catmandir="${T}"/dont-install \
+ install
+ einstalldocs
+}