summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2023-08-27 00:56:07 +0200
committerConrad Kostecki <conikost@gentoo.org>2023-08-27 01:42:01 +0200
commit8a9d72fe2f1660596be14c6afcead5648336daff (patch)
treea0642943ef91658c47bded72a3ef7efb09c6f4a2
parentgames-server/bedrock-server: drop 1.20.11.01, 1.20.13.01-r1, 1.20.14.01 (diff)
downloadgentoo-8a9d72fe2f1660596be14c6afcead5648336daff.tar.gz
gentoo-8a9d72fe2f1660596be14c6afcead5648336daff.tar.bz2
gentoo-8a9d72fe2f1660596be14c6afcead5648336daff.zip
dev-lua/lanes: add 3.16.1
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--dev-lua/lanes/Manifest1
-rw-r--r--dev-lua/lanes/lanes-3.16.1.ebuild93
2 files changed, 94 insertions, 0 deletions
diff --git a/dev-lua/lanes/Manifest b/dev-lua/lanes/Manifest
index adf004c115a4..e114d4b48f66 100644
--- a/dev-lua/lanes/Manifest
+++ b/dev-lua/lanes/Manifest
@@ -1 +1,2 @@
DIST lanes-3.16.0.tar.gz 257945 BLAKE2B aecc0bd551f10b29791acdde8da30fb83591395eac4d152999a0e92fe9738a6171b13363edae2d94b1db47398a01e011833ccee7a7f234033d3230605423c0b6 SHA512 ffd935baae8af752591251bbb1a7f936034ad281870d453e6e1b4291c175c91537ccae23ec25a616b45e8ab601222f323e05e938d7887091ba7e132b0cd5e449
+DIST lanes-3.16.1.tar.gz 446136 BLAKE2B e9505db907660378eb2e67f674a9e671c9554d7587ddeedca6ecaf332cdd03985d027ae5dfa7ae510da9c710b2dc70246e4eb42812347068536dd070a396e20b SHA512 bbc4e7d4dccb10a25f7560dbc4980e36b8f6bb0fbce667471d0be0ad028afc7e1dc88810e78be52a3aee9846512ec10a5ddd324dbe53f9a1db9af647f959014e
diff --git a/dev-lua/lanes/lanes-3.16.1.ebuild b/dev-lua/lanes/lanes-3.16.1.ebuild
new file mode 100644
index 000000000000..42af43b2d1d9
--- /dev/null
+++ b/dev-lua/lanes/lanes-3.16.1.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+
+inherit lua toolchain-funcs
+
+DESCRIPTION="Lightweight, native, lazy evaluating multithreading library"
+HOMEPAGE="https://github.com/LuaLanes/lanes"
+SRC_URI="https://github.com/LuaLanes/lanes/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+
+# Tests are currently somehow problematic.
+# https://github.com/LuaLanes/lanes/issues/197
+# https://github.com/LuaLanes/lanes/issues/198
+RESTRICT="test"
+
+RDEPEND="${LUA_DEPS}"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ test? ( ${RDEPEND} )
+"
+
+HTML_DOCS=( "docs/." )
+
+PATCHES=( "${FILESDIR}/${PN}-3.13.0-makefile.patch" )
+
+src_prepare() {
+ default
+
+ lua_copy_sources
+}
+
+lua_src_compile() {
+ pushd "${BUILD_DIR}" || die
+
+ local myemakeargs=(
+ "CC=$(tc-getCC)"
+ "LUA=${ELUA}"
+ "LUA_FLAGS=$(lua_get_CFLAGS)"
+ "LUA_LIBS="
+ "OPT_FLAGS=${CFLAGS}"
+ )
+
+ tc-export PKG_CONFIG
+
+ emake "${myemakeargs[@]}"
+
+ popd
+}
+
+src_compile() {
+ lua_foreach_impl lua_src_compile
+}
+
+lua_src_test() {
+ pushd "${BUILD_DIR}" || die
+
+ emake LUA="${ELUA}" test
+
+ popd
+}
+
+src_test() {
+ lua_foreach_impl lua_src_test
+}
+
+lua_src_install() {
+ pushd "${BUILD_DIR}" || die
+
+ local myemakeargs=(
+ "LUA_LIBDIR=${ED}/$(lua_get_cmod_dir)"
+ "LUA_SHAREDIR=${ED}/$(lua_get_lmod_dir)"
+ )
+
+ emake "${myemakeargs[@]}" install
+
+ popd
+}
+
+src_install() {
+ lua_foreach_impl lua_src_install
+
+ einstalldocs
+}