summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2020-10-09 16:21:16 +0200
committerAgostino Sarubbo <ago@gentoo.org>2020-10-09 16:21:16 +0200
commit8ab149641f2b2bed15b2cc7603366180a0f48aa3 (patch)
tree5e0bbde8f9f41ce95f108591cc3eac885c8ccba4
parentsci-libs/cxsparse: update HOMEPAGE, use https (diff)
downloadgentoo-8ab14964.tar.gz
gentoo-8ab14964.tar.bz2
gentoo-8ab14964.zip
app-admin/exo: version bump to 1.19.0
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
-rw-r--r--app-admin/exo/Manifest1
-rw-r--r--app-admin/exo/exo-1.19.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/app-admin/exo/Manifest b/app-admin/exo/Manifest
index ac797edb64c1..bf0c96185c4e 100644
--- a/app-admin/exo/Manifest
+++ b/app-admin/exo/Manifest
@@ -1 +1,2 @@
DIST exo-1.18.0.tar.gz 4625622 BLAKE2B 618aec5cec7a41f06963d728c627f043f08ba39695691154118261a6fb71bac93cdb07b039e74e05a464227dca4da66c17c4c319553894f2d46af6203a36a038 SHA512 862dd138a6b6cbf9471206a07cf4447df113a77f44523e72e89a1f87362086fa168ded51d43c32408946b8cf2d6cb9668ff29818494a2eb6d94b0ef7d3bf4420
+DIST exo-1.19.0.tar.gz 4624195 BLAKE2B 49b1e39ac7a9893620b9694d088a5d8681602c51f25288f9ace5ee7ea5f213626e9c5a3817f8e26a0608446c79e175db98a83bca270a9d6d6914f57ccc8e4478 SHA512 acd0b11b5f858288601f32254647e0d2d79f06a79b5b4fe7d6dc72b5f6040b5e52d88648d5eb574bbec7cb47e80358c368369d569255773048ee4e54f4d14dea
diff --git a/app-admin/exo/exo-1.19.0.ebuild b/app-admin/exo/exo-1.19.0.ebuild
new file mode 100644
index 000000000000..0c2c8d861fe4
--- /dev/null
+++ b/app-admin/exo/exo-1.19.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Command-line tool for everything at Exoscale: compute, storage, dns."
+HOMEPAGE="https://github.com/exoscale/cli"
+SRC_URI="https://github.com/exoscale/cli/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE=""
+DEPEND="dev-lang/go:="
+RESTRICT="strip"
+QA_FLAGS_IGNORED=".*"
+
+S="${WORKDIR}/cli-${PV}"
+
+src_compile() {
+ go build -mod vendor -o ${PN} || die "build failed"
+}
+
+src_test() {
+ # run at least 'exo version' for test
+ ./exo version > /dev/null 2>&1
+ if [[ $? -ne 0 ]]
+ then
+ die "Test failed"
+ fi
+}
+
+src_install() {
+ dobin ${PN}
+}