summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-12-24 12:47:26 +0100
committerJeroen Roovers <jer@gentoo.org>2016-12-24 12:48:26 +0100
commit8aba76f823b47f963d9cae0a9ae34697b7219512 (patch)
tree92ed4ee1c73b87cecca1ca1fb254be23799d6981
parentnet-im/pyicq-t: Move fixed -r6 to stable and remove old (diff)
downloadgentoo-8aba76f8.tar.gz
gentoo-8aba76f8.tar.bz2
gentoo-8aba76f8.zip
net-misc/youtube-dl: Version bump.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--net-misc/youtube-dl/Manifest1
-rw-r--r--net-misc/youtube-dl/youtube-dl-2016.12.22.ebuild99
2 files changed, 100 insertions, 0 deletions
diff --git a/net-misc/youtube-dl/Manifest b/net-misc/youtube-dl/Manifest
index 48dbba311ff2..8f3f806e34db 100644
--- a/net-misc/youtube-dl/Manifest
+++ b/net-misc/youtube-dl/Manifest
@@ -2,3 +2,4 @@ DIST youtube-dl-2016.01.01.tar.gz 1874602 SHA256 732f37c99d71b4239d72d61dd32214b
DIST youtube-dl-2016.09.19.tar.gz 2395739 SHA256 276637e83525778a83d0457f6b9fbc29d6109bc8366d43125432ce835d28545e SHA512 a8fb1ce054e25180eab3969c898d976dec157901931b66cddde0fecd55ef322e64c13a70d50de945849cbc4ccbf8be0aede845cbb8ea390bba34f51fec0533bf WHIRLPOOL e58d38e49d58b86d8eb25b40427046955e011bf57b0862c433ebe459c0268905bff67188c03bb612593d15b3d1f3408a95b510ad6f863d0144ee4307ed012aba
DIST youtube-dl-2016.12.12.tar.gz 2478147 SHA256 643efa7755ac4aa03a241f106d8923dfd5dbaf8d3c14e56b696048c4f2fab430 SHA512 c9dd2390c990761873aa5109510ed1352234097cda75ae153985f37bf092af9a45e161204160b6df5e051b1d4e223a671c803a76978e85d387075e3a278281c3 WHIRLPOOL 0aa6c0919d035346334d57bbd9cdd4e149b8cf3bef895bc58d338f4351ad3d889305765790ceed1fee760e73a2dedaaf3832ec4e996810cd0474ca262bf7ad01
DIST youtube-dl-2016.12.15.tar.gz 2480252 SHA256 85d937a6edb8c14f8eac1b17d2e5d45574c7ec3f2cb792781ac1d8fb6a6ca39e SHA512 1e0b3f561142fffef9b0b530abeff5db0eed851b6b38275f8d8e78e673be03d9b563813ed7c40652ea3c44201fc0b0044455e2a6548e11e325868cb42d3faf29 WHIRLPOOL 7ef0d8377b732079bd53a0ed07ed9de9f42f9b7c42c64d44a398738cef97c91471bb5fecc9b3b13ee960938db83e999c949a76ae2c815ca6a8202fb964270783
+DIST youtube-dl-2016.12.22.tar.gz 2502964 SHA256 f5bc5eb1af17391b7a1da795f4181c3702fb2c1da2668b25f1260dbdba882524 SHA512 87fee134da660a4feb4cfcd2cbb35cb9682e6ed08c766e3c89f6c986f991cac78c64f5bf8a1d15c4080e4df0909c6a360137407a7896b93f8f41cf4493f341cb WHIRLPOOL 6909d34958e4152be3334723c68d207bb34db2996d90908829ebd3ee45d28768d7f6cba8ce0fb19de440b34fb96b46b3d5b8bf830c998037c4f4d59e574206c3
diff --git a/net-misc/youtube-dl/youtube-dl-2016.12.22.ebuild b/net-misc/youtube-dl/youtube-dl-2016.12.22.ebuild
new file mode 100644
index 000000000000..1470648bf54c
--- /dev/null
+++ b/net-misc/youtube-dl/youtube-dl-2016.12.22.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=(python{2_7,3_4,3_5})
+inherit bash-completion-r1 distutils-r1 eutils
+
+DESCRIPTION="Download videos from YouTube.com (and more sites...)"
+HOMEPAGE="https://rg3.github.com/youtube-dl/"
+SRC_URI="http://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="offensive test"
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-python/nose[coverage(+)] )
+"
+
+S="${WORKDIR}/${PN}"
+
+python_prepare_all() {
+ if ! use offensive; then
+ sed -i -e "/__version__/s|'$|-gentoo_no_offensive_sites'|g" \
+ youtube_dl/version.py || die
+ # these have single line import statements
+ local xxx=(
+ alphaporno anysex behindkink camwithher chaturbate eporner
+ eroprofile extremetube fourtube foxgay goshgay hellporno
+ hentaistigma hornbunny keezmovies lovehomeporn mofosex motherless
+ myvidster porn91 porncom pornhd pornotube pornovoisines pornoxo
+ ruleporn sexu slutload spankbang spankwire sunporno thisav tube8
+ vporn watchindianporn xbef xnxx xtube xvideos xxxymovies youjizz
+ youporn
+ )
+ # these have multi-line import statements
+ local mxxx=(
+ drtuber pornhub redtube xhamster tnaflix
+ )
+ # do single line imports
+ sed -i \
+ -e $( printf '/%s/d;' ${xxx[@]} ) \
+ youtube_dl/extractor/extractors.py \
+ || die
+
+ # do multiple line imports
+ sed -i \
+ -e $( printf '/%s/,/)/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/extractors.py \
+ || die
+
+ sed -i \
+ -e $( printf '/%s/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/generic.py \
+ || die
+
+ rm \
+ $( printf 'youtube_dl/extractor/%s.py ' ${xxx[@]} ) \
+ $( printf 'youtube_dl/extractor/%s.py ' ${mxxx[@]} ) \
+ test/test_age_restriction.py \
+ || die
+ fi
+
+ epatch_user
+
+ distutils-r1_python_prepare_all
+}
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+python_test() {
+ emake test
+}
+
+python_install_all() {
+ dodoc README.txt
+ doman ${PN}.1
+
+ newbashcomp ${PN}.bash-completion ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ newins youtube-dl.zsh _youtube-dl
+
+ insinto /usr/share/fish/completions
+ doins youtube-dl.fish
+
+ distutils-r1_python_install_all
+
+ rm -r "${ED}"/usr/etc || die
+}