summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-03-01 21:14:25 +0100
committerDavid Seifert <soap@gentoo.org>2017-03-01 21:34:50 +0100
commit8aca469b7b450488c3312fa2183433d9fcf42712 (patch)
tree931fbc5345ec316b75c3b7b7b07c31fee16cc84f
parentdev-cpp/sparsehash: Remove old (diff)
downloadgentoo-8aca469b7b450488c3312fa2183433d9fcf42712.tar.gz
gentoo-8aca469b7b450488c3312fa2183433d9fcf42712.tar.bz2
gentoo-8aca469b7b450488c3312fa2183433d9fcf42712.zip
sci-libs/libmuscle: Modernise to EAPI 6
Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--sci-libs/libmuscle/files/3.7-bufferoverflow.patch8
-rw-r--r--sci-libs/libmuscle/files/libmuscle-3.7-fix-build-system.patch21
-rw-r--r--sci-libs/libmuscle/libmuscle-3.7-r3.ebuild40
3 files changed, 65 insertions, 4 deletions
diff --git a/sci-libs/libmuscle/files/3.7-bufferoverflow.patch b/sci-libs/libmuscle/files/3.7-bufferoverflow.patch
index c34b8ccacbda..384f17acfbf4 100644
--- a/sci-libs/libmuscle/files/3.7-bufferoverflow.patch
+++ b/sci-libs/libmuscle/files/3.7-bufferoverflow.patch
@@ -1,5 +1,5 @@
---- libMUSCLE/globalslinux.cpp.old 2010-03-14 19:03:14.000000000 +1300
-+++ libMUSCLE/globalslinux.cpp 2010-03-14 19:11:09.000000000 +1300
+--- a/libMUSCLE/globalslinux.cpp
++++ b/libMUSCLE/globalslinux.cpp
@@ -159,7 +159,7 @@
}
return DEFAULT_RAM;
@@ -9,8 +9,8 @@
return ((double) Bytes)/1e6;
}
---- libMUSCLE/progress.cpp.old 2010-03-14 19:50:27.000000000 +1300
-+++ libMUSCLE/progress.cpp 2010-03-14 19:51:07.000000000 +1300
+--- a/libMUSCLE/progress.cpp
++++ b/libMUSCLE/progress.cpp
@@ -48,7 +48,7 @@
if (MB < 0)
return "";
diff --git a/sci-libs/libmuscle/files/libmuscle-3.7-fix-build-system.patch b/sci-libs/libmuscle/files/libmuscle-3.7-fix-build-system.patch
new file mode 100644
index 000000000000..2b2c28c8132a
--- /dev/null
+++ b/sci-libs/libmuscle/files/libmuscle-3.7-fix-build-system.patch
@@ -0,0 +1,21 @@
+* Make build system parallel buildable
+* Remove -funroll-loops and friends
+
+--- a/libMUSCLE/Makefile.am
++++ b/libMUSCLE/Makefile.am
+@@ -1,6 +1,4 @@
+-OPTIMIZATION = -O2 -Wall -funroll-loops -fomit-frame-pointer -ftree-vectorize -funsafe-math-optimizations
+-AM_CXXFLAGS = $(OPTIMIZATION) -DNDEBUG=1 @OPENMP_CXXFLAGS@
+-AM_LDFLAGS = $(OPTIMIZATION)
++AM_CXXFLAGS = -DNDEBUG=1 @OPENMP_CXXFLAGS@
+
+ LIBMUSCLE_H = \
+ alpha.h cluster.h clust.h clustsetdf.h clustset.h clustsetmsa.h diaglist.h distcalc.h distfunc.h dpregionlist.h dpreglist.h edgelist.h enumopts.h enums.h estring.h gapscoredimer.h gonnet.h intmath.h msadist.h msa.h muscle.h objscore.h params.h profile.h pwpath.h refine.h scorehistory.h seq.h seqvect.h textfile.h timing.h tree.h types.h unixio.h threadstorage.h
+@@ -36,6 +34,6 @@
+
+
+ muscle_SOURCES = main.cpp
+-muscle_LDADD = $(top_builddir)/libMUSCLE/libMUSCLE-3.7.la
++muscle_LDADD = libMUSCLE-3.7.la
+
+
diff --git a/sci-libs/libmuscle/libmuscle-3.7-r3.ebuild b/sci-libs/libmuscle/libmuscle-3.7-r3.ebuild
new file mode 100644
index 000000000000..d3a8107c1052
--- /dev/null
+++ b/sci-libs/libmuscle/libmuscle-3.7-r3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Library for sci-biology/mauve"
+HOMEPAGE="http://gel.ahabs.wisc.edu/mauve/"
+SRC_URI="mirror://gentoo/${P}-r1.tar.bz2"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc static-libs"
+
+RDEPEND="!sci-biology/muscle"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-bufferoverflow.patch
+ "${FILESDIR}"/${PN}-3.7-fix-build-system.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ # package provides .pc file
+ find "${D}" -name '*.la' -delete || die
+}