summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-10-15 11:13:16 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-10-15 13:25:34 +0200
commit8ad5311ea2e25c7a8f7eab2a711a97f1ac24d0fe (patch)
tree5c941068b63107c00e4f15feb810681f7243a308
parentdev-util/wstool: Bump to 0.1.12. (diff)
downloadgentoo-8ad5311ea2e25c7a8f7eab2a711a97f1ac24d0fe.tar.gz
gentoo-8ad5311ea2e25c7a8f7eab2a711a97f1ac24d0fe.tar.bz2
gentoo-8ad5311ea2e25c7a8f7eab2a711a97f1ac24d0fe.zip
dev-util/rosinstall: Bump to 0.7.7.
Package-Manager: portage-2.2.23
-rw-r--r--dev-util/rosinstall/Manifest1
-rw-r--r--dev-util/rosinstall/rosinstall-0.7.7.ebuild61
-rw-r--r--dev-util/rosinstall/rosinstall-9999.ebuild4
3 files changed, 64 insertions, 2 deletions
diff --git a/dev-util/rosinstall/Manifest b/dev-util/rosinstall/Manifest
index c68cf3b8a7fb..4090fdea69a0 100644
--- a/dev-util/rosinstall/Manifest
+++ b/dev-util/rosinstall/Manifest
@@ -1 +1,2 @@
DIST rosinstall-0.7.6.tar.gz 64788 SHA256 e5abe3ddb34a84cb77ce926a71112ccda985ed95462f757a24cb67f0e6aa3d9e SHA512 e7e480995e612557e146c9f8c5158aa3109dbc3a3b324f67d9a533cae75a10bae45bdd1573e63bb8bda2b3d7d1ef494c2de3eb06e8ee4f1e05d50f10e5015997 WHIRLPOOL 3affdbb949906007382bd1e2f59b48d0cb8d842d3f93ce6027066dbe644954b1ba337e44ea2d02acd26e9381a308452f84dd2d8ff3993eeb3d180ee82431e734
+DIST rosinstall-0.7.7.tar.gz 64838 SHA256 286802588ae4b16c5e081b52d46a0b1023deafa42200ee2f1c04c758fcae744d SHA512 1d36d78d4d8a770fda09f4db6463012a8c9a63f76d01e4cfe29505b388ae0f5289e70590b418730b1d04bfc2efa7f2554300787b6757e1ec85d39dcd514fdf52 WHIRLPOOL 5b06382611c95c7c192a45beb641f532aa468cf289a10d867938f98e9dd8586e0c87e8155a320d93fe306abe16eaff7bd92a646f54d45995a3e1c92809144b33
diff --git a/dev-util/rosinstall/rosinstall-0.7.7.ebuild b/dev-util/rosinstall/rosinstall-0.7.7.ebuild
new file mode 100644
index 000000000000..9b2ec8b48ac8
--- /dev/null
+++ b/dev-util/rosinstall/rosinstall-0.7.7.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/vcstools/rosinstall"
+fi
+
+inherit ${SCM} distutils-r1
+
+DESCRIPTION="Command-line tools for maintaining a workspace of projects for ROS"
+HOMEPAGE="http://wiki.ros.org/rosinstall http://wiki.ros.org/roslocate"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="http://download.ros.org/downloads/${PN}/${P}.tar.gz
+ https://github.com/vcstools/rosinstall/archive/${PV}.tar.gz -> ${P}.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="
+ dev-python/catkin_pkg[${PYTHON_USEDEP}]
+ >=dev-python/vcstools-0.1.38[${PYTHON_USEDEP}]
+ dev-python/rosdistro[${PYTHON_USEDEP}]
+ >=dev-util/wstool-0.1.12[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-vcs/git
+ dev-vcs/bzr
+ dev-vcs/mercurial
+ app-shells/zsh
+ )
+"
+
+python_test() {
+ # From travis.yml
+ # Set git config to silence some stuff in the tests
+ git config --global user.email "foo@example.com"
+ git config --global user.name "Foo Bar"
+ # Set the hg user
+ echo -e "[ui]\nusername = Your Name <your@mail.com>" >> ~/.hgrc
+ # Set the bzr user
+ bzr whoami "Your Name <name@example.com>"
+ # command to run tests
+ # Local tests work even if ros.org is down
+ export ROSINSTALL_SKIP_PYTHON3=1
+ nosetests test || die
+}
diff --git a/dev-util/rosinstall/rosinstall-9999.ebuild b/dev-util/rosinstall/rosinstall-9999.ebuild
index 57d4b294b2bb..9b2ec8b48ac8 100644
--- a/dev-util/rosinstall/rosinstall-9999.ebuild
+++ b/dev-util/rosinstall/rosinstall-9999.ebuild
@@ -31,9 +31,9 @@ IUSE="test"
RDEPEND="
dev-python/catkin_pkg[${PYTHON_USEDEP}]
- dev-python/vcstools[${PYTHON_USEDEP}]
+ >=dev-python/vcstools-0.1.38[${PYTHON_USEDEP}]
dev-python/rosdistro[${PYTHON_USEDEP}]
- dev-util/wstool[${PYTHON_USEDEP}]
+ >=dev-util/wstool-0.1.12[${PYTHON_USEDEP}]
dev-python/pyyaml[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
test? (