summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-10 19:59:42 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-10 20:10:58 +0200
commit8ae9f924180155baa7dbfeea73b1a252ca8c74ee (patch)
tree8b93b769d42dd1fc89d9200936fa1920332369e2
parentdev-qt/qtbase: remove xkbcommon patch in live (diff)
downloadgentoo-8ae9f924180155baa7dbfeea73b1a252ca8c74ee.tar.gz
gentoo-8ae9f924180155baa7dbfeea73b1a252ca8c74ee.tar.bz2
gentoo-8ae9f924180155baa7dbfeea73b1a252ca8c74ee.zip
dev-python/wtforms: Bump to 3.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/wtforms/Manifest1
-rw-r--r--dev-python/wtforms/wtforms-3.1.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/wtforms/Manifest b/dev-python/wtforms/Manifest
index 9dfb36115c0f..51e196500c14 100644
--- a/dev-python/wtforms/Manifest
+++ b/dev-python/wtforms/Manifest
@@ -1 +1,2 @@
DIST WTForms-3.0.1.tar.gz 137513 BLAKE2B 17fbb385a28baefaf3fe368b7c7dbd3d6671aaef887ee89617e60e0537ae060248442d4990e7ea926b15d4b85585a1c80ffb61c0fdad2627e5cca90799eb01d7 SHA512 a6db54a7ef9bc96b8fdf69cd65d3810fab9436ff9c056e1cfc580f5ecd0ed8837dcbb7c2adf92419cc5f74e865bb3a023e316407a87d5c5277da5d30e6836fb3
+DIST wtforms-3.1.0.tar.gz 134500 BLAKE2B a88f29eb600b50f7de964d9cef1dd195f7731312bf291b3cbfa1664537c4eb242a59d435994c007c2e84eaf19942db5316e58154639bdd8ebee85d336ca5a9dc SHA512 6afc9bb2980668c753887945692525a4039e7a06fb3f0e2b56d1a60c382f099e1b75d722f19786ec0f32a1043b4909b1be28c8aeccadc4745785414835aebf02
diff --git a/dev-python/wtforms/wtforms-3.1.0.ebuild b/dev-python/wtforms/wtforms-3.1.0.ebuild
new file mode 100644
index 000000000000..718aeb1fb598
--- /dev/null
+++ b/dev-python/wtforms/wtforms-3.1.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYPI_PN="WTForms"
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Flexible forms validation and rendering library for python web development"
+HOMEPAGE="
+ https://wtforms.readthedocs.io/
+ https://github.com/wtforms/wtforms/
+ https://pypi.org/project/WTForms/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/markupsafe[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/Babel[${PYTHON_USEDEP}]
+ test? (
+ dev-python/email-validator[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/sqlalchemy[${PYTHON_USEDEP}]
+ dev-python/webob[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest