summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-12 09:58:16 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-12 10:48:55 +0100
commit8b00c8780928849c2f086378087d9d5292713936 (patch)
tree7e5468c558c1b8c12f190c272c597d5a0a02fb14
parentdev-python/pygments: Bump to 2.7.4 (diff)
downloadgentoo-8b00c8780928849c2f086378087d9d5292713936.tar.gz
gentoo-8b00c8780928849c2f086378087d9d5292713936.tar.bz2
gentoo-8b00c8780928849c2f086378087d9d5292713936.zip
dev-python/python-stdnum: Bump to 1.15
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/python-stdnum/Manifest1
-rw-r--r--dev-python/python-stdnum/python-stdnum-1.15.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/python-stdnum/Manifest b/dev-python/python-stdnum/Manifest
index 6fd6bbf0eda9..253bf45853f9 100644
--- a/dev-python/python-stdnum/Manifest
+++ b/dev-python/python-stdnum/Manifest
@@ -1 +1,2 @@
DIST python-stdnum-1.14.tar.gz 953637 BLAKE2B 5772fd2284dc9c255b544c6f0d1f4d1ebbaa48547cf1ba9aafb082a4d649ce90574444b298a333c9fbac5e232d2ea144f2e5bbd817fb6e7b78ea66081ed871b2 SHA512 d17643a2e4d8efc5f554c9c114399802e6dae0ff60b6ab0e32ebf6ece7c87a96287dd1c2e68e4fcd97f8ab475a267de5dad41d726470690255a2a0aeddedbb8e
+DIST python-stdnum-1.15.tar.gz 1037630 BLAKE2B 7d4bc086a5c0e272b7c55ed5bead9561375b6410b286c6d1d78e49dfc1473a9021646fbd363cfa532bc3eb1a54284b253f46ab28f60d2d411efa0992772a02a0 SHA512 e6f1d921e8ce64a11f9c5572e7eabc27bd7c71c34017fb795c45fa585701fcc78ff81c15b1a9bd48b8d9975e1fbc354b3923942c6f81e8fe4dfb8f611e3ab9cc
diff --git a/dev-python/python-stdnum/python-stdnum-1.15.ebuild b/dev-python/python-stdnum/python-stdnum-1.15.ebuild
new file mode 100644
index 000000000000..5ec38434f38b
--- /dev/null
+++ b/dev-python/python-stdnum/python-stdnum-1.15.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A module to handle standardized numbers and codes"
+HOMEPAGE="https://arthurdejong.org/python-stdnum/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="vies"
+
+RDEPEND="
+ vies? (
+ || (
+ dev-python/zeep[${PYTHON_USEDEP}]
+ dev-python/suds[${PYTHON_USEDEP}]
+ )
+ )"
+
+DOCS=( ChangeLog NEWS README )
+
+distutils_enable_tests nose