summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2020-02-20 15:26:11 -0800
committerPatrick McLean <chutzpah@gentoo.org>2020-02-20 15:29:38 -0800
commit8b03bd4bad5835093ff44834251ba0e9cdad54be (patch)
treea4309e28ee5e5faed5eee9043e40966a072cee5c
parentmedia-video/peek: 1.5.1 bump (diff)
downloadgentoo-8b03bd4bad5835093ff44834251ba0e9cdad54be.tar.gz
gentoo-8b03bd4bad5835093ff44834251ba0e9cdad54be.tar.bz2
gentoo-8b03bd4bad5835093ff44834251ba0e9cdad54be.zip
app-vim/vim-nftables: New package
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
-rw-r--r--app-vim/vim-nftables/Manifest1
-rw-r--r--app-vim/vim-nftables/files/vim-nftables-0_pre20200220-extra-keywords.patch22
-rw-r--r--app-vim/vim-nftables/metadata.xml11
-rw-r--r--app-vim/vim-nftables/vim-nftables-0_pre20200220.ebuild27
4 files changed, 61 insertions, 0 deletions
diff --git a/app-vim/vim-nftables/Manifest b/app-vim/vim-nftables/Manifest
new file mode 100644
index 000000000000..7cda0a9521b1
--- /dev/null
+++ b/app-vim/vim-nftables/Manifest
@@ -0,0 +1 @@
+DIST vim-nftables-0_pre20200220.tar.gz 2419 BLAKE2B 7ee16e013f0873f5bd5d1e6beb3c824eabe38b759145a20aa0c9bb16b0abbb640d10eed59ffdc77ae0b4a7091158cc6d732cdec2589886edf52a8f6574f1145e SHA512 061b4410f261ea5449c366261ff8b3fd9ab15995ab73ac2f77a6de58e0d8764a0828973cbde152eb637f4bc6a8882c56efecdda65c7ecd6ca69df4f92fd190fe
diff --git a/app-vim/vim-nftables/files/vim-nftables-0_pre20200220-extra-keywords.patch b/app-vim/vim-nftables/files/vim-nftables-0_pre20200220-extra-keywords.patch
new file mode 100644
index 000000000000..b06349115788
--- /dev/null
+++ b/app-vim/vim-nftables/files/vim-nftables-0_pre20200220-extra-keywords.patch
@@ -0,0 +1,22 @@
+From e378b1484a85399032ff32d86ad2a5bde936762f Mon Sep 17 00:00:00 2001
+From: adrian5 <adrian5@users.noreply.github.com>
+Date: Mon, 17 Feb 2020 22:13:50 +0100
+Subject: [PATCH] Add icmpv6 keyword
+
+---
+ syntax/nftables.vim | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/syntax/nftables.vim b/syntax/nftables.vim
+index c80eb9d..d5d0e3f 100644
+--- a/syntax/nftables.vim
++++ b/syntax/nftables.vim
+@@ -23,7 +23,7 @@ syn keyword Function table chain
+ syn keyword Statement type hook
+ syn keyword Type ip ip6 inet arp bridge
+ syn keyword Type filter nat route
+-syn keyword Type ether vlan arp ip ip6 tcp udp udplite sctp dccp ah esp ipcomp icmp
++syn keyword Type ether vlan arp ip ip6 tcp udp udplite sctp dccp ah esp ipcomp icmp icmpv6 igmp
+ syn keyword Type ct
+ syn keyword Type length protocol priority mark iif iifname iiftype oif oifname oiftype skuid skgid rtclassid
+ syn keyword Constant prerouting input forward output postrouting
diff --git a/app-vim/vim-nftables/metadata.xml b/app-vim/vim-nftables/metadata.xml
new file mode 100644
index 000000000000..0172dae3d8ef
--- /dev/null
+++ b/app-vim/vim-nftables/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>chutzpah@gentoo.org</email>
+ <name>Patrick McLean</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>vim@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-vim/vim-nftables/vim-nftables-0_pre20200220.ebuild b/app-vim/vim-nftables/vim-nftables-0_pre20200220.ebuild
new file mode 100644
index 000000000000..779cf1310579
--- /dev/null
+++ b/app-vim/vim-nftables/vim-nftables-0_pre20200220.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vim-plugin
+
+COMMIT_ID="aad8540ef56f495baa589f646edc1253db990f1a"
+
+DESCRIPTION="vim plugin: "
+HOMEPAGE="https://github.com/nfnty/vim-nftables"
+SRC_URI="https://github.com/nfnty/${PN}/archive/${COMMIT_ID}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT_ID}"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+
+PATCHES=(
+ "${FILESDIR}/vim-nftables-0_pre20200220-extra-keywords.patch"
+)
+
+src_prepare() {
+ default
+
+ # will install license file by default
+ rm LICENSE || die
+}