summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2024-01-15 09:34:42 -0800
committerRobin H. Johnson <robbat2@gentoo.org>2024-01-15 09:41:10 -0800
commit8b0ab7baa902af199cb17b6daecea314ae74679f (patch)
tree177ed7561d9d5997d91822409979078ab11de439
parentapp-admin/puppet-lint: fix EmptyGlobalAssignment (diff)
downloadgentoo-8b0ab7baa902af199cb17b6daecea314ae74679f.tar.gz
gentoo-8b0ab7baa902af199cb17b6daecea314ae74679f.tar.bz2
gentoo-8b0ab7baa902af199cb17b6daecea314ae74679f.zip
dev-libs/cjose: new package, dep for www-apache/mod_auth_openidc
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
-rw-r--r--dev-libs/cjose/Manifest1
-rw-r--r--dev-libs/cjose/cjose-0.6.2.2.ebuild36
-rw-r--r--dev-libs/cjose/metadata.xml14
3 files changed, 51 insertions, 0 deletions
diff --git a/dev-libs/cjose/Manifest b/dev-libs/cjose/Manifest
new file mode 100644
index 000000000000..4fa7b26db7a8
--- /dev/null
+++ b/dev-libs/cjose/Manifest
@@ -0,0 +1 @@
+DIST cjose-0.6.2.2.tar.gz 498461 BLAKE2B 4914019652f47ac12745cb3b8914f66cb41cb8da33f83735d866cac816dd8f6475d12fde4a6e3f58456c463cb7c6c6fdfeb4928c232f94e3fa6b1b4c8e5ef132 SHA512 71a087709816f0aac060a7c5f037068e981366b1809f6ee32e39eaded02ad8be061b0e2fa5093515a8acec10c7f4aca232281004426221b4b7e5edbd203eb49c
diff --git a/dev-libs/cjose/cjose-0.6.2.2.ebuild b/dev-libs/cjose/cjose-0.6.2.2.ebuild
new file mode 100644
index 000000000000..8e203e264c0f
--- /dev/null
+++ b/dev-libs/cjose/cjose-0.6.2.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="C library implementing the Javascript Object Signing and Encryption (JOSE)"
+HOMEPAGE="https://github.com/OpenIDC/cjose"
+
+SRC_URI="https://github.com/OpenIDC/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=dev-libs/jansson-2.11:=
+ >=dev-libs/openssl-1.0.2u:="
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( >=app-doc/doxygen-1.8 )
+ test? ( >=dev-libs/check-0.9.4 )"
+
+src_prepare() {
+ default
+ eautoreconf --force --install
+}
+
+src_install() {
+ default
+ find "${ED}" -type f -name '*.la' -delete || die
+}
diff --git a/dev-libs/cjose/metadata.xml b/dev-libs/cjose/metadata.xml
new file mode 100644
index 000000000000..307a3af57a82
--- /dev/null
+++ b/dev-libs/cjose/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>robbat2@gentoo.org</email>
+ </maintainer>
+ <maintainer type="project">
+ <email>infra@gentoo.org</email>
+ <name>Gentoo Infrastructure Team</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">OpenIDC/cjose</remote-id>
+ </upstream>
+</pkgmetadata>