summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2023-12-21 17:54:48 -0500
committerMichael Orlitzky <mjo@gentoo.org>2024-01-22 06:29:15 -0500
commit8b0ec57cd46dd6db6112f546ea617b6cb85369ae (patch)
tree721fb3112bdfca3057c2776c55556563bf055be5
parentdev-gap/genss: new package, add 1.6.8 (diff)
downloadgentoo-8b0ec57cd46dd6db6112f546ea617b6cb85369ae.tar.gz
gentoo-8b0ec57cd46dd6db6112f546ea617b6cb85369ae.tar.bz2
gentoo-8b0ec57cd46dd6db6112f546ea617b6cb85369ae.zip
dev-gap/hap: new package, add 1.60
Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
-rw-r--r--dev-gap/hap/Manifest1
-rw-r--r--dev-gap/hap/hap-1.60.ebuild54
-rw-r--r--dev-gap/hap/metadata.xml34
3 files changed, 89 insertions, 0 deletions
diff --git a/dev-gap/hap/Manifest b/dev-gap/hap/Manifest
new file mode 100644
index 000000000000..49f2ea59e1a5
--- /dev/null
+++ b/dev-gap/hap/Manifest
@@ -0,0 +1 @@
+DIST hap-1.60.tar.gz 21322579 BLAKE2B 2ac276e33109fa6bb975ebe6f0cf1f503e9e6b3b29a2f4381723e84ba8659f54ddb66cec0470894d01edd64894691febb098a34a1e6366162037ea229a7c0e74 SHA512 fe121efe7d65d1ea7f156ff4cca04eeb95591ea44343b562ff34cbf5a702301630a8a92f7aca1ac12a46b9058b54b88fbd42621c1cdedaebf5e5702c72a34416
diff --git a/dev-gap/hap/hap-1.60.ebuild b/dev-gap/hap/hap-1.60.ebuild
new file mode 100644
index 000000000000..08c73706089a
--- /dev/null
+++ b/dev-gap/hap/hap-1.60.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gap-pkg
+
+DESCRIPTION="Homological Algebra Programming (HAP) in GAP"
+SRC_URI="https://github.com/gap-packages/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+#IUSE="test"
+RESTRICT=test
+
+RDEPEND="dev-gap/aclib
+ dev-gap/crystcat
+ dev-gap/fga
+ dev-gap/nq
+ dev-gap/polycyclic"
+
+# Singular: https://docs.gap-system.org/pkg/hap/doc/chap14.html
+# EDIM: https://docs.gap-system.org/pkg/hap/doc/chap11.html
+# congruence is needed for ResolutionSL2Z()
+# tst/testextra/3.6.1.tst calls LieAlgebra() from laguna
+# EquivariantEuclideanSpace() in tst/testallV11/1.8.1.tst needs hapcryst
+#
+# The imagemagick "convert" utility is used in a few places, and it does
+# actually need to be imagemagick (and not graphicsmagick) because e.g.
+# ReadImageAsPureCubicalComplex parses the comment that only imagemagick
+# puts at the top of a text file:
+#
+# https://github.com/gap-packages/hap/issues/115
+#
+# BDEPEND="test? (
+# dev-gap/congruence
+# dev-gap/edim
+# dev-gap/hapcryst
+# dev-gap/laguna
+# dev-gap/polymaking
+# dev-gap/singular
+# media-gfx/imagemagick[png]
+# )"
+
+HTML_DOCS="www/* tutorial"
+
+GAP_PKG_EXTRA_INSTALL=( boolean )
+gap-pkg_enable_tests
+
+pkg_postinst() {
+ elog "Some optional functions require media-gfx/graphviz"
+ elog "to be installed at runtime."
+}
diff --git a/dev-gap/hap/metadata.xml b/dev-gap/hap/metadata.xml
new file mode 100644
index 000000000000..147ed3e9c377
--- /dev/null
+++ b/dev-gap/hap/metadata.xml
@@ -0,0 +1,34 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mjo@gentoo.org</email>
+ </maintainer>
+ <maintainer type="person">
+ <email>frp.bissey@gmail.com</email>
+ <name>François Bissey</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci-mathematics@gentoo.org</email>
+ <name>Gentoo Mathematics Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ HAP is a package for some calculations in elementary algebraic
+ topology and the cohomology of groups. The initial focus of the
+ library was on computations related to the cohomology of finite and
+ infinite groups, with particular emphasis on integral
+ coefficients. The focus has since broadened to include Steenrod
+ algebras of finite groups, Bredon homology, cohomology of simplicial
+ groups, and general computations in algebraic topology relating to
+ finite CW-complexes, covering spaces, knots, knotted surfaces, and
+ topics such as persitent homology arising in topological data
+ analysis.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">gap-packages/hap</remote-id>
+ </upstream>
+</pkgmetadata>