summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Baranov <reagentoo@gmail.com>2021-12-20 20:05:18 +0300
committerJoonas Niilola <juippis@gentoo.org>2022-01-10 18:27:11 +0200
commit8b3b4d9bee7eda2f19d8cdadceb0a1ebbc92d4cc (patch)
tree1beb8295bdd6bc4ab1c1089a5fa086cfae899989
parentmedia-video/yle-dl: drop 20210917 (diff)
downloadgentoo-8b3b4d9b.tar.gz
gentoo-8b3b4d9b.tar.bz2
gentoo-8b3b4d9b.zip
app-misc/ddccontrol: add 0.6.0
Closes: https://bugs.gentoo.org/829719 Signed-off-by: Dmitry Baranov <reagentoo@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--app-misc/ddccontrol/Manifest1
-rw-r--r--app-misc/ddccontrol/ddccontrol-0.6.0.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/app-misc/ddccontrol/Manifest b/app-misc/ddccontrol/Manifest
index 2b389cf7bf63..ae0337f1aeef 100644
--- a/app-misc/ddccontrol/Manifest
+++ b/app-misc/ddccontrol/Manifest
@@ -1 +1,2 @@
DIST ddccontrol-0.4.4_p20200630.tar.gz 173792 BLAKE2B 7a7ef330eb471f1cbddbfd90745e212a8a66f4be6cc6a4ccb8014c41498a86a09e4bc0226a300201102c202da37c0f4b8020aa88f08b5e2acaa92ac0dc2971b6 SHA512 7aaadf98eaf24d4b040073dce6f469e6e4aaae1efde0e8f988fb9c5fb99b776b1836573c069b9d8f12eaa724d3b39df5d4f247aa47ca2b7911dc9a9df727a50a
+DIST ddccontrol-0.6.0.tar.gz 180376 BLAKE2B d844f03ae4843a710a3a7143b1270656202c261b5e412822c49c2096c150052ddb6747b62f7c1d2404cffeb13af5ed604be915061b3fd339c8dcf66473bbd791 SHA512 49e857e8ef8f2ba87dc51056b9511ce55f3e6471222cd9171a324e2ee179b8c96a8f4d90c63bb379260ccc8e1d9653964f90748d6589d298ff2bbe6982efd3e2
diff --git a/app-misc/ddccontrol/ddccontrol-0.6.0.ebuild b/app-misc/ddccontrol/ddccontrol-0.6.0.ebuild
new file mode 100644
index 000000000000..d6e7410b62fe
--- /dev/null
+++ b/app-misc/ddccontrol/ddccontrol-0.6.0.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="control monitor parameters, like brightness, contrast, RGB color levels via DDC"
+HOMEPAGE="http://ddccontrol.sourceforge.net/"
+SRC_URI="https://github.com/ddccontrol/ddccontrol/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc gtk nls +pci static-libs"
+
+RDEPEND="app-misc/ddccontrol-db
+ dev-libs/libxml2:2
+ app-arch/xz-utils
+ gtk? ( x11-libs/gtk+:2 )
+ nls? ( sys-devel/gettext )
+ pci? ( sys-apps/pciutils )"
+DEPEND="${RDEPEND}
+ dev-perl/XML-Parser
+ dev-util/intltool
+ sys-kernel/linux-headers
+ doc? (
+ >=app-text/docbook-xsl-stylesheets-1.65.1
+ >=dev-libs/libxslt-1.1.6
+ app-text/htmltidy
+ )"
+
+src_prepare() {
+ sed -i 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:' configure.ac || die #467574
+ sed -i '/;Application/d' src/gddccontrol/gddccontrol.desktop.in || die
+
+ # ppc/ppc64 do not have inb/outb/ioperm
+ # they also do not have (sys|asm)/io.h
+ if ! use amd64 && ! use x86 ; then
+ local card
+ for card in sis intel810 ; do
+ sed -r -i \
+ -e "/${card}.Po/d" \
+ -e "s~${card}[^[:space:]]*~ ~g" \
+ src/ddcpci/Makefile.{am,ini} || die
+ done
+ sed -i \
+ -e '/sis_/d' \
+ -e '/i810_/d' \
+ src/ddcpci/main.c || die
+ fi
+
+ eapply_user
+
+ ## Save for a rainy day or future patching
+ touch config.rpath ABOUT-NLS
+ eautoreconf
+ intltoolize --force || die "intltoolize failed"
+}
+
+src_configure() {
+ # amdadl broken, bug #527268
+ econf \
+ --htmldir='$(datarootdir)'/doc/${PF}/html \
+ --disable-gnome-applet \
+ --disable-amdadl \
+ $(use_enable doc) \
+ $(use_enable gtk gnome) \
+ $(use_enable nls) \
+ $(use_enable pci ddcpci) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ use static-libs || find "${ED}" -name '*.la' -delete
+}