summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-05-01 14:09:13 +0200
committerDavid Seifert <soap@gentoo.org>2021-05-01 14:09:13 +0200
commit8b55dcf5d4e525de5bf22009ce51f08c6d697847 (patch)
tree2bb55e58846c104c54dd96f4f029b2c5ff06cc28
parentgames-arcade/burgerspace: Bump to 1.9.3 (diff)
downloadgentoo-8b55dcf5d4e525de5bf22009ce51f08c6d697847.tar.gz
gentoo-8b55dcf5d4e525de5bf22009ce51f08c6d697847.tar.bz2
gentoo-8b55dcf5d4e525de5bf22009ce51f08c6d697847.zip
games-arcade/burgerspace: Remove old
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--games-arcade/burgerspace/Manifest1
-rw-r--r--games-arcade/burgerspace/burgerspace-1.9.2-r1.ebuild54
-rw-r--r--games-arcade/burgerspace/files/burgerspace-1.9.2-gcc11.patch202
3 files changed, 0 insertions, 257 deletions
diff --git a/games-arcade/burgerspace/Manifest b/games-arcade/burgerspace/Manifest
index 331b56aebaae..05af86cb66e6 100644
--- a/games-arcade/burgerspace/Manifest
+++ b/games-arcade/burgerspace/Manifest
@@ -1,2 +1 @@
-DIST burgerspace-1.9.2.tar.gz 505314 BLAKE2B 8a6de753e41de791fdc3a2ceb106f193da3de6c04c80c19b9f84cb03f569982ae8f3fe2e5541c1c389e16085d51867733d4911f04266497420eafd170d085095 SHA512 b2af53d6fcf1d52164870147aa8a5b08941ecb62f3d9bbce5c2872885923057481c21bc34f1e19b8aeb8a76acadd9a11c11fa7b6304438610e8a23e043b7deee
DIST burgerspace-1.9.3.tar.gz 517492 BLAKE2B 6d3cf554580a1a370720f349ae71edab7228c18426d4ae39a8f5bb9177071204715e527beea52aa6b11b9112db5a168951d92b0de60189cfdb1882c85c79d1f2 SHA512 59629ca497a0a379858ba69bb444182f935b58be6554109fb9b309713bd6bde0d771e63858802f9153a4e46bbfe63b5edf58f857bb94ca337dbba89ff3c610cb
diff --git a/games-arcade/burgerspace/burgerspace-1.9.2-r1.ebuild b/games-arcade/burgerspace/burgerspace-1.9.2-r1.ebuild
deleted file mode 100644
index 7ff631c964f4..000000000000
--- a/games-arcade/burgerspace/burgerspace-1.9.2-r1.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools
-
-DESCRIPTION="Clone of the 1982 BurgerTime video game by Data East"
-HOMEPAGE="https://perso.b2b2c.ca/~sarrazip/dev/burgerspace.html"
-SRC_URI="https://perso.b2b2c.ca/~sarrazip/dev/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="network"
-RESTRICT="test" # doesn't really test anything
-
-RDEPEND=">=dev-games/flatzebra-0.1.6"
-DEPEND="${RDEPEND}"
-BDEPEND="virtual/pkgconfig"
-
-PATCHES=( "${FILESDIR}"/${PN}-1.9.2-gcc11.patch )
-
-src_prepare() {
- default
-
- sed -i \
- -e "/^pkgsounddir/ s:sounds.*:\$(PACKAGE)/sounds:" \
- -e "/^desktopentrydir/ s:=.*:=/usr/share/applications:" \
- -e "/^pixmapdir/ s:=.*:=/usr/share/pixmaps:" \
- src/Makefile.am \
- || die
-
- sed -i \
- -e "/Categories/s:Application;::" \
- -e "/Icon/s:\..*::" \
- -e "/Terminal/s:0:false:" \
- src/burgerspace.desktop.in \
- || die
-
- eautoreconf
-}
-
-src_configure() {
- econf \
- $(use_with network)
-}
-
-src_install() {
- emake -C src DESTDIR="${D}" install
-
- doman doc/${PN}.6
- dodoc AUTHORS NEWS README THANKS
-}
diff --git a/games-arcade/burgerspace/files/burgerspace-1.9.2-gcc11.patch b/games-arcade/burgerspace/files/burgerspace-1.9.2-gcc11.patch
deleted file mode 100644
index aea4d2ee3189..000000000000
--- a/games-arcade/burgerspace/files/burgerspace-1.9.2-gcc11.patch
+++ /dev/null
@@ -1,202 +0,0 @@
---- a/src/BurgerSpaceClient.cpp
-+++ b/src/BurgerSpaceClient.cpp
-@@ -209,7 +209,7 @@
-
-
- void
--BurgerSpaceClient::loadPixmaps() throw(PixmapLoadError)
-+BurgerSpaceClient::loadPixmaps()
- {
- /* Tiles:
- */
---- a/src/BurgerSpaceClient.h
-+++ b/src/BurgerSpaceClient.h
-@@ -177,7 +177,7 @@
-
- ///////////////////////////////////////////////////////////////////////////
-
-- void loadPixmaps() throw(flatzebra::PixmapLoadError);
-+ void loadPixmaps();
- void restoreBackground();
- void draw();
- void displayMessage(int row, const char *msg);
---- a/src/BurgerSpaceServer.cpp
-+++ b/src/BurgerSpaceServer.cpp
-@@ -733,7 +733,7 @@
-
-
- BurgerSpaceServer::BurgerSpaceServer(int initLevelNumber,
-- bool _oldMotionMode) throw(int, string)
-+ bool _oldMotionMode)
- : theScreenSizeInPixels(SCREEN_WIDTH_IN_PIXELS, SCREEN_HEIGHT_IN_PIXELS),
-
- initLevelNo(1),
-@@ -830,7 +830,7 @@
-
-
- void
--BurgerSpaceServer::displayErrorMessage(const string &msg) throw()
-+BurgerSpaceServer::displayErrorMessage(const string &msg)
- {
- cerr << msg << endl;
- }
-@@ -871,7 +871,7 @@
-
-
- void
--BurgerSpaceServer::initializeSprites() throw(PixmapLoadError)
-+BurgerSpaceServer::initializeSprites()
- /* Initializes the sprites that appear at the beginning of a level,
- like the ingredients.
-
-@@ -930,7 +930,7 @@
-
-
- void
--BurgerSpaceServer::initializeMisc() throw(string)
-+BurgerSpaceServer::initializeMisc()
- /* Initializes things that need to be initialized once, but not at the
- beginning of each level.
-
-@@ -1160,7 +1160,7 @@
-
-
- void
--BurgerSpaceServer::initNextLevel(int levelNo /*= 0*/) throw(int)
-+BurgerSpaceServer::initNextLevel(int levelNo /*= 0*/)
- /* Initialize the next level. Increments the current level number if
- levelNo is zero, or uses levelNo if it is positive.
- */
-@@ -2118,7 +2118,7 @@
- if (numDirectionsAllowed == 0)
- {
- belowStructure = true;
-- allowedDirections[UP]++;
-+ allowedDirections[UP] = true;
- }
- }
-
-@@ -2643,7 +2643,7 @@
- static void
- loadPixmap(const char **xpmData,
- SDL_Surface *&pixmap,
-- Couple &pixmapSize) throw(PixmapLoadError)
-+ Couple &pixmapSize)
- {
- pixmapSize.zero();
-
-@@ -2661,7 +2661,6 @@
-
- static void
- loadPixmap(const char **xpmData, PixmapArray &pa, size_t index)
-- throw(PixmapLoadError)
- {
- // Masks are not be relevant with SDL.
-
-@@ -2674,7 +2673,7 @@
-
-
- void
--BurgerSpaceServer::loadPixmaps() throw(PixmapLoadError)
-+BurgerSpaceServer::loadPixmaps()
- {
- /* Load the player pixmaps:
-
-@@ -2813,7 +2812,7 @@
-
-
- void
--BurgerSpaceServer::loadLevel(int levelNo) throw(string)
-+BurgerSpaceServer::loadLevel(int levelNo)
- /* Affects the data member 'theCurrentLevel', which must already be
- initialized to defined values.
- 'levelNo' may exceed NUM_LEVELS.
---- a/src/BurgerSpaceServer.h
-+++ b/src/BurgerSpaceServer.h
-@@ -72,7 +72,7 @@
- {
- public:
-
-- BurgerSpaceServer(int initLevelNumber, bool _oldMotionMode) throw(int, std::string);
-+ BurgerSpaceServer(int initLevelNumber, bool _oldMotionMode);
-
- void finishInit(); // must be called after constructor -- calls virtual functions
-
-@@ -355,7 +355,7 @@
- void putSprite(const flatzebra::Sprite &s);
- void showInstructions();
- void initGameParameters();
-- void initNextLevel(int levelNo = 0) throw(int);
-+ void initNextLevel(int levelNo = 0);
- void resetPlay();
- int isPositionAtSideOfStructure(flatzebra::Couple pos) const;
- void animateTemporarySprites(flatzebra::SpriteList &slist) const;
-@@ -369,11 +369,11 @@
- bool ingredientGroupCollidesWithSprite(
- const flatzebra::Couple groupPos, const flatzebra::Couple groupSize,
- const flatzebra::Sprite &s) const;
-- void loadLevel(int levelNo) throw(std::string);
-- void displayErrorMessage(const std::string &msg) throw();
-+ void loadLevel(int levelNo);
-+ void displayErrorMessage(const std::string &msg);
- void createPlayerSprite();
-- void initializeSprites() throw(flatzebra::PixmapLoadError);
-- void initializeMisc() throw(std::string);
-+ void initializeSprites();
-+ void initializeMisc();
- void deleteSprite(flatzebra::Sprite *s) const;
- void deleteSprites(flatzebra::SpriteList &sl) const;
- void deleteSprites(IngredientSprite::List &isl) const;
-@@ -386,7 +386,7 @@
- size_t carryEnemiesInList(IngredientGroup &g, flatzebra::SpriteList &slist);
- size_t releaseCarriedEnemies(IngredientGroup &g);
- void createScoreSprites(long n, flatzebra::Couple center);
-- void loadPixmaps() throw(flatzebra::PixmapLoadError);
-+ void loadPixmaps();
- void moveEnemyList(flatzebra::SpriteList &slist, int speedFactor);
- flatzebra::Couple getDistanceToPerfectPos(const flatzebra::Sprite &s) const;
- bool isSpriteOnFloor(const flatzebra::Sprite &s) const;
---- a/src/EnemySprite.cpp
-+++ b/src/EnemySprite.cpp
-@@ -29,7 +29,7 @@
-
- EnemySprite::EnemySprite(const PixmapArray &pa,
- Couple pos, Couple speed,
-- Couple collBoxPos, Couple collBosSize) throw(int)
-+ Couple collBoxPos, Couple collBosSize)
- : Sprite(pa, pos, speed, Couple(0, 0), collBoxPos, collBosSize),
- carryingGroup(NULL),
- disappearanceTime(0),
---- a/src/EnemySprite.h
-+++ b/src/EnemySprite.h
-@@ -45,7 +45,7 @@
- flatzebra::Couple pos,
- flatzebra::Couple speed,
- flatzebra::Couple collBoxPos,
-- flatzebra::Couple collBosSize) throw(int);
-+ flatzebra::Couple collBosSize);
- /* Calls Sprite constructor.
- */
-
---- a/src/IngredientSprite.h
-+++ b/src/IngredientSprite.h
-@@ -42,7 +42,7 @@
-
- IngredientSprite(const flatzebra::PixmapArray &pixmapArray,
- const flatzebra::Couple &pos,
-- IngredientGroup *ig) throw(int)
-+ IngredientGroup *ig)
- : flatzebra::Sprite(pixmapArray, pos,
- flatzebra::Couple(0, 0), flatzebra::Couple(0, 0),
- flatzebra::Couple(0, 5), flatzebra::Couple(24, 1)),
---- a/src/server.cpp
-+++ b/src/server.cpp
-@@ -304,7 +304,7 @@
- {
- public:
-
-- BurgerSpaceCommandLineServer(int _initLevelNumber, int _sock, Uint32 _minMSBetweenWrites) throw(int, std::string)
-+ BurgerSpaceCommandLineServer(int _initLevelNumber, int _sock, Uint32 _minMSBetweenWrites)
- : BurgerSpaceServer(_initLevelNumber, false),
- sock(_sock),
- minMSBetweenWrites(_minMSBetweenWrites),