summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2018-02-07 21:42:06 -0500
committerCraig Andrews <candrews@gentoo.org>2018-02-07 21:44:45 -0500
commit8b562a8466429b92ff06f0a5cbcf9eff15cbc1ca (patch)
treee5431f0874c0166a5becb17e9a1cf78689973968
parentdev-python/ebuildtester: Updated homepage (diff)
downloadgentoo-8b562a84.tar.gz
gentoo-8b562a84.tar.bz2
gentoo-8b562a84.zip
net-p2p/cpuminer-opt: 3.8.1 version bump
Package-Manager: Portage-2.3.24, Repoman-2.3.6
-rw-r--r--net-p2p/cpuminer-opt/Manifest1
-rw-r--r--net-p2p/cpuminer-opt/cpuminer-opt-3.8.1.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/net-p2p/cpuminer-opt/Manifest b/net-p2p/cpuminer-opt/Manifest
index c8bb0f3c553f..217040e103d8 100644
--- a/net-p2p/cpuminer-opt/Manifest
+++ b/net-p2p/cpuminer-opt/Manifest
@@ -2,3 +2,4 @@ DIST cpuminer-opt-3.7.10.tar.gz 1629412 BLAKE2B 7ac3144345aad4b7616a5293092452b4
DIST cpuminer-opt-3.7.9.tar.gz 1623402 BLAKE2B f9e225989bf1f2dd249de1ed43e7e1532c8e825f6fb25e54020a0f4382ab156a9fd7463e82510a90c5c6f71b8a9749c94cc4acc01d05b6f189766099a5772fec SHA512 17457900cad97b57d92160aba8d22256a39660dc29afbcd5be35b3e9c9045f81cd43332c7890cbde44427345eff61a6a1346ce31620e281160b5acaf729863d3
DIST cpuminer-opt-3.8.0.1.tar.gz 1656058 BLAKE2B 685e5a7813f32e276a1cdd179c5d518c670e323b185270cce7368aa2f2c7b80a77076280d8604609d184e9e94776067050e65b722b20f1efdd5a4c3caba397c3 SHA512 0b7de89d37334c0c9867b65362c8664547a5b1f840446c071259cdd00848e9aab9ea3c160665a5d72efe9f50322f3c2e45f01035671b8eb4f341cb53abdd8452
DIST cpuminer-opt-3.8.0.tar.gz 1656474 BLAKE2B 145126762aeb245d042c1a208b60fd4727b450b77ab2585043b13b82b61b947dea0db2489de08e619dcd54b8eb1ec429f83f21ce1e49c34e140f585eccdd14f0 SHA512 c610d58236c5d84a850e68e172d3fdfede5b86aefa8ff09890ffc43d47efd4754aeb345f6b5fd48b6afcbc771541418f6fde1c9e621ad89c17d2dad4c16151f9
+DIST cpuminer-opt-3.8.1.tar.gz 1654969 BLAKE2B b8805e748b71d3c7049d5c97dd74a51da55f88c697963c938a372ff5ff0ac72fcabce81b86f373fdca2dcef7393bba3f53c049bc30dfbd02691ff5e9630cf5bc SHA512 800edbecf5edb0902adc54480a4984602c19087d55675212832ce24df109b7d66544d9db78112a04c3c374521737e2680013d354b6ff8195a17abeb213e2a556
diff --git a/net-p2p/cpuminer-opt/cpuminer-opt-3.8.1.ebuild b/net-p2p/cpuminer-opt/cpuminer-opt-3.8.1.ebuild
new file mode 100644
index 000000000000..a1f4a660f6b9
--- /dev/null
+++ b/net-p2p/cpuminer-opt/cpuminer-opt-3.8.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools flag-o-matic systemd
+
+DESCRIPTION="Optimized multi algo CPU miner"
+HOMEPAGE="https://github.com/JayDDee/cpuminer-opt"
+IUSE="cpu_flags_x86_sse2 curl libressl"
+LICENSE="GPL-2"
+SLOT="0"
+REQUIRED_USE="cpu_flags_x86_sse2"
+DEPEND="
+ dev-libs/gmp:0
+ dev-libs/jansson
+ curl? ( >=net-misc/curl-7.15[ssl] )
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+"
+RDEPEND="${DEPEND}"
+if [[ ${PV} == "9999" ]] ; then
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/JayDDee/${PN}.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://github.com/JayDDee/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ append-ldflags -Wl,-z,noexecstack
+ econf --with-crypto $(use_with curl)
+}
+
+src_install() {
+ default
+ systemd_dounit "${FILESDIR}"/${PN}.service
+ insinto "/etc/${PN}"
+ doins cpuminer-conf.json
+}