summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-27 10:53:20 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-27 11:02:22 +0100
commit8b5a1cd17ae546b84dd835e8b449ead391482af9 (patch)
tree2337f191d3a0c3ed9f37d380003c4297d2fa13d2
parentdev-python/typing-extensions: Switch to PEP 517 build (diff)
downloadgentoo-8b5a1cd1.tar.gz
gentoo-8b5a1cd1.tar.bz2
gentoo-8b5a1cd1.zip
dev-python/url-normalize: Switch to PEP 517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/url-normalize/url-normalize-1.4.3-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/url-normalize/url-normalize-1.4.3-r1.ebuild b/dev-python/url-normalize/url-normalize-1.4.3-r1.ebuild
new file mode 100644
index 000000000000..8ede2a4e84e6
--- /dev/null
+++ b/dev-python/url-normalize/url-normalize-1.4.3-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="URL normalization for Python"
+HOMEPAGE="
+ https://github.com/niksite/url-normalize/
+ https://pypi.org/project/url-normalize/"
+SRC_URI="
+ https://github.com/niksite/url-normalize/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # remove problematic pytest options
+ rm tox.ini || die
+ sed -e '/requires/s:poetry:&-core:' \
+ -e '/backend/s:poetry:&.core:' \
+ -i pyproject.toml || die
+ distutils-r1_src_prepare
+}