summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-02-08 07:27:34 +0100
committerMichał Górny <mgorny@gentoo.org>2020-02-09 17:46:17 +0100
commit8b6adf9a0d6942b062d5f4e0e46bbb23e08fc462 (patch)
treece23b006357f7beb6398acf01f9fc3c71b8f388a
parentapp-text/pylize: Switch to PYTHON_MULTI_USEDEP API (diff)
downloadgentoo-8b6adf9a0d6942b062d5f4e0e46bbb23e08fc462.tar.gz
gentoo-8b6adf9a0d6942b062d5f4e0e46bbb23e08fc462.tar.bz2
gentoo-8b6adf9a0d6942b062d5f4e0e46bbb23e08fc462.zip
dev-embedded/platformio: Switch to PYTHON_MULTI_USEDEP API
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-embedded/platformio/platformio-4.1.0-r1.ebuild42
-rw-r--r--dev-embedded/platformio/platformio-4.1.0.ebuild38
2 files changed, 42 insertions, 38 deletions
diff --git a/dev-embedded/platformio/platformio-4.1.0-r1.ebuild b/dev-embedded/platformio/platformio-4.1.0-r1.ebuild
new file mode 100644
index 000000000000..0c28bb271d22
--- /dev/null
+++ b/dev-embedded/platformio/platformio-4.1.0-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1
+
+DESCRIPTION="An open source ecosystem for IoT development"
+HOMEPAGE="https://platformio.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ $(python_gen_cond_dep '
+ dev-python/setuptools[${PYTHON_MULTI_USEDEP}]
+ ')"
+RDEPEND="${DEPEND}
+ $(python_gen_cond_dep '
+ <dev-python/bottle-0.13[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/click-5[${PYTHON_MULTI_USEDEP}]
+ <dev-python/click-8[${PYTHON_MULTI_USEDEP}]
+ dev-python/colorama[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/pyserial-3[${PYTHON_MULTI_USEDEP}]
+ <dev-python/pyserial-4[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/requests-2.4[${PYTHON_MULTI_USEDEP}]
+ <dev-python/requests-3[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/semantic_version-2.8.1[${PYTHON_MULTI_USEDEP}]
+ <dev-python/semantic_version-3[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/tabulate-0.8.3[${PYTHON_MULTI_USEDEP}]
+ <dev-python/tabulate-1[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/pyelftools-0.25[${PYTHON_MULTI_USEDEP}]
+ <dev-python/pyelftools-1[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/marshmallow-2.20.5[${PYTHON_MULTI_USEDEP}]
+ <dev-python/marshmallow-3[${PYTHON_MULTI_USEDEP}]
+ ')"
diff --git a/dev-embedded/platformio/platformio-4.1.0.ebuild b/dev-embedded/platformio/platformio-4.1.0.ebuild
deleted file mode 100644
index 29d4e2ad7b49..000000000000
--- a/dev-embedded/platformio/platformio-4.1.0.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7} )
-DISTUTILS_SINGLE_IMPL=1
-
-inherit distutils-r1
-
-DESCRIPTION="An open source ecosystem for IoT development"
-HOMEPAGE="https://platformio.org/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}
- <dev-python/bottle-0.13[${PYTHON_USEDEP}]
- >=dev-python/click-5[${PYTHON_USEDEP}]
- <dev-python/click-8[${PYTHON_USEDEP}]
- dev-python/colorama[${PYTHON_USEDEP}]
- >=dev-python/pyserial-3[${PYTHON_USEDEP}]
- <dev-python/pyserial-4[${PYTHON_USEDEP}]
- >=dev-python/requests-2.4[${PYTHON_USEDEP}]
- <dev-python/requests-3[${PYTHON_USEDEP}]
- >=dev-python/semantic_version-2.8.1[${PYTHON_USEDEP}]
- <dev-python/semantic_version-3[${PYTHON_USEDEP}]
- >=dev-python/tabulate-0.8.3[${PYTHON_USEDEP}]
- <dev-python/tabulate-1[${PYTHON_USEDEP}]
- >=dev-python/pyelftools-0.25[${PYTHON_USEDEP}]
- <dev-python/pyelftools-1[${PYTHON_USEDEP}]
- >=dev-python/marshmallow-2.20.5[${PYTHON_USEDEP}]
- <dev-python/marshmallow-3[${PYTHON_USEDEP}]"