summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2023-11-24 14:39:15 +0100
committerPacho Ramos <pacho@gentoo.org>2023-11-24 14:54:04 +0100
commit8b7c576f77c71d547730e6338b5716d05a8f3cb9 (patch)
tree15c724deb7939b00c5b1e3c6c232e332c54b4962
parentmedia-sound/sooperlooper: add 1.7.8_p2 (diff)
downloadgentoo-8b7c576f.tar.gz
gentoo-8b7c576f.tar.bz2
gentoo-8b7c576f.zip
media-sound/spek: Port to wxGTK 3.2
And other fixes from Debian Closes: https://bugs.gentoo.org/889622 Closes: https://bugs.gentoo.org/899768 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
-rw-r--r--media-sound/spek/files/00_dfsg.patch19
-rw-r--r--media-sound/spek/files/01_arm64-mips64el.patch15
-rw-r--r--media-sound/spek/files/02_ftbfs-gcc13.patch10
-rw-r--r--media-sound/spek/files/03_metainfo.patch66
-rw-r--r--media-sound/spek/spek-0.8.5-r1.ebuild40
5 files changed, 150 insertions, 0 deletions
diff --git a/media-sound/spek/files/00_dfsg.patch b/media-sound/spek/files/00_dfsg.patch
new file mode 100644
index 000000000000..4384fc1f326d
--- /dev/null
+++ b/media-sound/spek/files/00_dfsg.patch
@@ -0,0 +1,19 @@
+Author: Matteo Bini <matteobin@tiepi.it>
+Description: Remove DFSG excluded files for Autoconf
+Forwarded: not-needed
+--- a/configure.ac
++++ b/configure.ac
+@@ -81,13 +81,10 @@ AC_CONFIG_FILES([
+ data/icons/32x32/Makefile
+ data/icons/48x48/Makefile
+ data/icons/scalable/Makefile
+- dist/osx/Info.plist
+- dist/win/spek.wxs
+ man/Makefile
+ po/Makefile.in
+ src/Makefile
+ tests/Makefile
+- web/version
+ ])
+ AC_OUTPUT
+
diff --git a/media-sound/spek/files/01_arm64-mips64el.patch b/media-sound/spek/files/01_arm64-mips64el.patch
new file mode 100644
index 000000000000..8d14a48b3b29
--- /dev/null
+++ b/media-sound/spek/files/01_arm64-mips64el.patch
@@ -0,0 +1,15 @@
+Author: Mike Wang <mikewang000000@gmail.com>
+Bug: https://github.com/alexkay/spek/issues/262
+Description: Fix FFT unit tests
+Forwarded: https://github.com/alexkay/spek/commit/0998df9a7ac99d509ddd10fb76d883f24efc0179
+--- a/tests/test-fft.cc
++++ b/tests/test-fft.cc
+@@ -62,7 +62,7 @@ static void test_sine()
+ if (i == k) {
+ continue;
+ }
+- if (plan->get_output(i) > -150.0f) {
++ if (plan->get_output(i) > -149.0f) {
+ silence = false;
+ break;
+ }
diff --git a/media-sound/spek/files/02_ftbfs-gcc13.patch b/media-sound/spek/files/02_ftbfs-gcc13.patch
new file mode 100644
index 000000000000..3271d2eb3947
--- /dev/null
+++ b/media-sound/spek/files/02_ftbfs-gcc13.patch
@@ -0,0 +1,10 @@
+Author: Matteo Bini <matteobin@tiepi.it>
+Description: Fix ftbfs with GCC-13
+Forwarded: https://github.com/alexkay/spek/commit/b1600d9926fa434330171cbebb407d2d0ccdcf03
+--- a/tests/perf.cc
++++ b/tests/perf.cc
+@@ -1,3 +1,4 @@
++#include <cstdint>
+ #include <cstdlib>
+ #include <iostream>
+ #include <fstream>
diff --git a/media-sound/spek/files/03_metainfo.patch b/media-sound/spek/files/03_metainfo.patch
new file mode 100644
index 000000000000..f4e57657f36a
--- /dev/null
+++ b/media-sound/spek/files/03_metainfo.patch
@@ -0,0 +1,66 @@
+Author: Nils Fürniß <contact@nalsai.de>
+Description: Add metainfo file
+Forwarded: https://github.com/alexkay/spek/commit/03d7fb6a1a01e7a0adffd0b083fa4c026efb8f84
+--- a/data/Makefile.am
++++ b/data/Makefile.am
+@@ -6,8 +6,15 @@ desktopdir = $(datadir)/applications
+ desktop_in_files = spek.desktop.in
+ desktop_DATA = spek.desktop
+
+-EXTRA_DIST = spek.desktop.in
+-CLEANFILES = spek.desktop
++appdatadir = $(datadir)/metainfo
++appdata_in_files = spek.metainfo.xml.in
++appdata_DATA = spek.metainfo.xml
++
++EXTRA_DIST = spek.desktop.in spek.metainfo.xml.in
++CLEANFILES = spek.desktop spek.metainfo.xml
+
+ spek.desktop: spek.desktop.in $(wildcard $(top_srcdir)/po/*po)
+ $(AM_V_GEN)$(MSGFMT) --desktop --template $< -d $(top_srcdir)/po -o $@
++
++spek.metainfo.xml: spek.metainfo.xml.in $(wildcard $(top_srcdir)/po/*po)
++ $(AM_V_GEN)$(MSGFMT) --xml --template $< -d $(top_srcdir)/po -o $@
+--- a/data/spek.metainfo.xml.in
++++ b/data/spek.metainfo.xml.in
+@@ -0,0 +1,40 @@
++<?xml version="1.0" encoding="UTF-8"?>
++<component type="desktop-application">
++ <id>cc.spek.Spek</id>
++ <metadata_license>CC0-1.0</metadata_license>
++ <project_license>GPL-3.0</project_license>
++ <name>Spek</name>
++ <summary>View spectrograms of your audio files</summary>
++ <description>
++ <p>Spek is an acoustic spectrum analyser written in C and C++. It uses FFmpeg libraries for audio decoding and wxWidgets for the GUI.</p>
++ <ul>
++ <li>Supports all popular lossy and lossless audio file formats thanks to the FFmpeg libraries.</li>
++ <li>Ultra-fast signal processing, uses multiple threads to further speed up the analysis.</li>
++ <li>Shows the codec name and the audio signal parameters.</li>
++ <li>Allows to save the spectrogram as an image file.</li>
++ <li>Drag-and-drop support; associates with common audio file formats.</li>
++ <li>Auto-fitting time, frequency and spectral density rulers.</li>
++ <li>Adjustable spectral density range.</li>
++ <li>Translated into 19 languages.</li>
++ </ul>
++ </description>
++ <screenshots>
++ <screenshot type="default">
++ <image>https://raw.githubusercontent.com/alexkay/spek/b3759bbb7d1108b3193394b941eeee982f15b739/web/flac.png</image>
++ </screenshot>
++ </screenshots>
++ <categories>
++ <category>Audio</category>
++ <category>AudioVideo</category>
++ </categories>
++ <url type="homepage">https://www.spek.cc/</url>
++ <url type="bugtracker">https://github.com/alexkay/spek/issues</url>
++ <developer_name>alexkay</developer_name>
++ <content_rating type="oars-1.1" />
++ <launchable type="desktop-id">spek.desktop</launchable>
++ <releases>
++ <release version="0.8.5" date="2023-01-10"/>
++ <release version="0.8.4" date="2022-07-11"/>
++ <release version="0.8.2" date="2016-01-19"/>
++ </releases>
++</component>
diff --git a/media-sound/spek/spek-0.8.5-r1.ebuild b/media-sound/spek/spek-0.8.5-r1.ebuild
new file mode 100644
index 000000000000..f40e5769fa0b
--- /dev/null
+++ b/media-sound/spek/spek-0.8.5-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+WX_GTK_VER="3.2-gtk3"
+
+inherit autotools wxwidgets xdg
+
+DESCRIPTION="Analyse your audio files by showing their spectrogram"
+HOMEPAGE="http://spek.cc/"
+SRC_URI="https://github.com/alexkay/spek/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=media-video/ffmpeg-5:=
+ x11-libs/wxGTK:${WX_GTK_VER}[X]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.8.4-disable-updates.patch
+ # Debian patches
+ "${FILESDIR}"/00_dfsg.patch
+ "${FILESDIR}"/01_arm64-mips64el.patch
+ "${FILESDIR}"/02_ftbfs-gcc13.patch
+ "${FILESDIR}"/03_metainfo.patch
+)
+
+src_prepare() {
+ setup-wxwidgets unicode
+ default
+ eautoreconf
+}