summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-15 21:53:36 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-15 22:26:02 +0200
commit8bbb36725fc83cc3683f9ae8984a511061fb9447 (patch)
treee09654ecdac215bc77a239b05c8ad84693d560c5
parentdev-python/Faker: Bump to 8.13.2 (diff)
downloadgentoo-8bbb3672.tar.gz
gentoo-8bbb3672.tar.bz2
gentoo-8bbb3672.zip
dev-python/asyncstdlib: Bump to 3.10.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/asyncstdlib/Manifest1
-rw-r--r--dev-python/asyncstdlib/asyncstdlib-3.10.1.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/asyncstdlib/Manifest b/dev-python/asyncstdlib/Manifest
index b3c008784e0a..de424f10d2d0 100644
--- a/dev-python/asyncstdlib/Manifest
+++ b/dev-python/asyncstdlib/Manifest
@@ -1,3 +1,4 @@
DIST asyncstdlib-3.10.0.gh.tar.gz 45242 BLAKE2B 12fb7f96d9c7c6e7ddad67b6c25b805de95812f902e14935a11440c4c55437f550df18c388727d21745b99e6db97917849547fdf726a89c62136ce1d01b8545b SHA512 9e930fa906139d664575d7f41d4e5ddf7da62e02bc946efeadadf6631ae63c15ca2ac1b5793172424f9ad916d32bbd4a741de5844b247c2fa506b63431711933
+DIST asyncstdlib-3.10.1.gh.tar.gz 45230 BLAKE2B daefacbb5712d200dc61d99cbf0deaa50925cfe2e8203f01a8083531d762b838d9603110a07ac1e1a00f17f1bb8ee7dc1a759d35949570fe134d21c4e48993ae SHA512 05e0e64f8262cf3ba6f8e784490597397e0d6a74f2052da80bb531df557dd3143c032589c429a407049ed04b093757c7a09674c66110befd6ab66b0edf883909
DIST asyncstdlib-3.9.1.gh.tar.gz 40224 BLAKE2B 8d1e564c9f5ac10c7f05dfa3933f695ae458685550fb67401f3bd0d1294ef0b170f5b385cdcf63c0096854538219a0dea77d4d80bd801f1a9b15f5ad3f2c562a SHA512 de7860d84cee7bfdc974a0677cc231323c86238bcb0bfd2f32a62b7356042aad647ee8d627393be35c5a134855d5f76967143ad8347df9d6258f46bc2b43a62a
DIST asyncstdlib-3.9.2.gh.tar.gz 41963 BLAKE2B da40c23bacc58c1347aca94107e3026829d9b27645eddc47fc46a96cab4be7baa9ed3c31f6f0045b884130d4316394d6a0b6b44818b42b6e6c512c641847d556 SHA512 f5268451325b48b967747b5e1ffe4e773a5aae82c6d481781e6c95f483d972da2b3806c1117067256d22efaba1238787898667a6a50ac4b2512dac4b5343d2a2
diff --git a/dev-python/asyncstdlib/asyncstdlib-3.10.1.ebuild b/dev-python/asyncstdlib/asyncstdlib-3.10.1.ebuild
new file mode 100644
index 000000000000..10f7da0d6a0d
--- /dev/null
+++ b/dev-python/asyncstdlib/asyncstdlib-3.10.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="The missing async toolbox"
+HOMEPAGE="
+ https://github.com/maxfischer2781/asyncstdlib/
+ https://pypi.org/project/asyncstdlib/"
+SRC_URI="
+ https://github.com/maxfischer2781/asyncstdlib/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests pytest